Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 6th February 2010, 19:15
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,628
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

Set the correct hostname for the server in the ispconfig server settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #12  
Old 7th February 2010, 04:47
catalyst catalyst is offline
Member
 
Join Date: Mar 2007
Posts: 43
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
Set the correct hostname for the server in the ispconfig server settings.
Yes! The hostname is correct. It is the same as the hostname when I installed the Cent OS.
Any other issue?
Thank you!
Reply With Quote
  #13  
Old 7th February 2010, 16:22
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,628
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

Ok. But ispconfig is doing the phpmyadmin redirect to the hostname that you have set in ispconfig server settings, if the redirect goes to a wrong hostname / domain, then it can not be set correctly in ispconfig. There is no other option, so please check again and compare the domain / hostname you get redirected to with the settings in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #14  
Old 10th March 2010, 16:28
Stojc Stojc is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Smile

Quote:
Originally Posted by till View Post
Ok. But ispconfig is doing the phpmyadmin redirect to the hostname that you have set in ispconfig server settings, if the redirect goes to a wrong hostname / domain, then it can not be set correctly in ispconfig. There is no other option, so please check again and compare the domain / hostname you get redirected to with the settings in ispconfig.
I think it can be corrected and phpmyadmin will then work on any domain and on the right port. Simply open file database_phpmyadmin.php in /var/www/ispconfig/sites/ and look for line

header('location:' . $http . '://' . $serverData['server_name'] . '/phpmyadmin'); (not sure why is this rewrite needed - except if you want
always to come in from same address)

and replace it with

header('location:/phpmyadmin');

Save it and then try. On my server works fine.
Reply With Quote
  #15  
Old 17th March 2010, 20:25
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

I had this same problem with 3.0.2. The port number is lost when the link is clicked and it is trying on port 80.

I changed the line above to include the port number and it now works...
Code:
header('location:' . $http . '://' . $serverData['server_name'] . ':8080/phpmyadmin');
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #16  
Old 17th March 2010, 20:27
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,628
Thanks: 793
Thanked 4,998 Times in 3,909 Posts
Default

The above does not apply to ISPConfig 3.0.2 anymore, in ISPConfig 3.0.2, you set the link to phpmyadmin under System > Interface Config. So instead of modifying any code, enter the URL to phpmyadmin in the interface config settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
BorderAmigos (17th March 2010)
  #17  
Old 17th March 2010, 20:33
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Thank you. I did not know that.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #18  
Old 17th March 2010, 22:22
Stojc Stojc is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks, Till. I also noticed that, but few days later (after I changed the code).

Regards
Reply With Quote
  #19  
Old 23rd March 2010, 23:08
menahem menahem is offline
Member
 
Join Date: Aug 2006
Posts: 40
Thanks: 0
Thanked 1 Time in 1 Post
Default phpmyadmin

Quote:
Originally Posted by till View Post
The above does not apply to ISPConfig 3.0.2 anymore, in ISPConfig 3.0.2, you set the link to phpmyadmin under System > Interface Config. So instead of modifying any code, enter the URL to phpmyadmin in the interface config settings.
Till,
It did not worked for me.

phpmyadmin was installed by apt-get. (we are talking about debian etch - 4.0r8)

At /var/www lib i have a link to:/usr/share/phpmyadmin.

At ispconfig (ver 3.0.2.1) -->system-->interface config-->PHPMyAdmin URL i inserted: www.domain.tld.

www.domain.tld is the FQDN for the 1 domain hosted by the server i.e server domain name (server it self) lets say is abcd.com server full domain name (after running hostname -f)= host.abcd.com.

Now: 1st. web site is... www.abcd.com

Putting the URL www.abcd.com/phpmyadmin in ispconfig (ver 3.0.2.1) -->system-->interface config-->PHPMyAdmin URL i am getting a (nice looking) 404.

Please advice hoto fix it.
Thank you.
Menahem
Reply With Quote
  #20  
Old 25th March 2010, 19:39
miguelal miguelal is offline
Junior Member
 
Join Date: Mar 2010
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I had the exact same problem. You probably already fixed it but in the interest of helping any others that stumble upon this thread:

Appending the following line to /etc/apache2/apache2.conf did it for me:

Include /etc/phpmyadmin/apache.conf
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
phpmyadmin error filch Installation/Configuration 11 22nd March 2009 15:08
phpmyadmin login problem ddouma Installation/Configuration 14 20th January 2009 02:33
phpMyAdmin goes PHP5 & MySQL5 Hans General 5 28th September 2008 20:46
phpmyadmin problem on ubuntu mail server virtual domains almeister9 HOWTO-Related Questions 1 19th September 2008 16:52


All times are GMT +2. The time now is 09:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.