Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2009, 01:48
pewichali pewichali is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default e-mail issues- can´t send mails to any domain but mine

Hi, I installed ISPConfig with the perfect setup OpenSuse 10.2 all seems to work fine the domain, the site, i have no problems login and managing accounts; but i have an issue with the email. It happens that i can receive mails to mydomain.net from any domains but when im sending mails it only delivers mail to mydomain.net i cant send mails to any other domain different to mine. What can it be, plz helpme that's the only failure im experiencing with it.

Checking the log on /var/log/mail it says something like:
to=<dude@mydomain.net>, relay=none, delay=0.24, delays=0.07/0.01/0.17/0, dsn=5.4.6, status=bounced (mail for www.mydomain.net loops back to myself)
is it something i did wrong???
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2009, 09:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

Please add:

www.mydomain.net

at the end of the file /etc/postfix/local-host-names and restart postfix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pewichali (11th April 2009)
  #3  
Old 10th April 2009, 23:52
pewichali pewichali is offline
Junior Member
 
Join Date: Apr 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for answering, Ok i did it and still cant send mails to any other domain, if i send mails from yahoo; hotmail, gmail or any other account it is picked up by the mail server and delivered to the intended receiver; but the problem is that if i send an email from mydomain.net to gmail with a cc to mydomain.net I only receive the one that goes to mydomain.net I`m still waiting on the other accounts to get my copy of all those tests mails.

I've copied another line of /var/log/mail and say:
postfix/smtp[5574]: connect to mx3.hotmail.com[65.55.37.120]: Connection timed out (port 25)
Apr 9 14:25:10 dynamic74-131 postfix/smtp[5574]: 57C624386B: to=<dude@hotmail.com>, relay=none, delay=153, delays=2.3/0.47/151/0, dsn=4.4.1, status=deferred (connect to mx3.hotmail.com[65.55.37.120]: Connection timed out)

and here is some lines when a mails goes to mydomain:
postfix/local[5597]: E64C44386C: to=<dude@mydomain.net>, orig_to=<dude@mydomain.net>, relay=local, delay=4.2, delays=0.14/2.5/0/1.6, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)

It seems to me like if my postfix isn't sending some data to mx3.hotmail and that's why sends a timed out conection, am i right? any sugestions? (sorry 4 my english, im trying to be as clear as i can)

Last edited by pewichali; 10th April 2009 at 23:56.
Reply With Quote
  #4  
Old 11th April 2009, 10:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,397 Times in 4,241 Posts
Default

Ask your provider if they block outgoing smtp connections and in case that you run your server on a dynamic IP then hotmail will reject the mails from their side.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 19th April 2009, 20:26
tebokkel tebokkel is offline
Member
 
Join Date: Feb 2007
Location: The Netherlands
Posts: 96
Thanks: 0
Thanked 9 Times in 9 Posts
 
Default

Check with telnet if you can reach any outside port 25:
telnet mx3.hotmail.com 25

If not, you could also try to use your providers mailserver to forward your email (in /etc/postfix/main.cf):
relayhost = smtp.yourprovider.nl

Paul
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
:D All recieved mails goes to the system admin user ??help Mounir Installation/Configuration 8 31st July 2006 12:22
Can not recieve mail with de virtual mail adress Mounir Installation/Configuration 9 24th July 2006 23:16
How to send mails using php mail function outside domain pankaj Technical 1 19th December 2005 22:09
Mail server jas_esp Server Operation 1 7th December 2005 18:17


All times are GMT +2. The time now is 06:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.