#1  
Old 8th April 2009, 18:58
irado irado is offline
Junior Member
 
Join Date: Apr 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default stuck with ntop (CentOS 5.3)

I am trying to use ntop and install it as per these howto:


http://www.cyberciti.biz/faq/howto-i...-fedora-linux/

(also rrdtools):

http://www.cyberciti.biz/faq/howto-i...on-rhel-linux/
(installed and tested as per instructions)

in the a.m. howto it was not possible to use ntop at all, due to this error:

ntop-3.3.9/
autogen.sh --with-rrd-home=/usr/local/rrdtool
[.. lots of information ..]
configure: error: Unable to find RRD at /usr/local/rrdtool: please use --with-rrd-home=DIR

error; note that even with the proper "DIR" information it returns such error AND stops.

then I installed ntop with yum - all runs smoothly and ntop runs (apparently) normal here EXCEPT that, when asking for any graphic (network load, traffic) it doesnot show any graph, just this message:

"NOTE: this page is not operational when the RRD plugin is disabled, misconfigured or missing."

BUT.. these (and some others) are already enabled.

So, I am stuck: HOW can I got those nice graphics? think that it is closely related with those "Unable to find RRD at /usr/local/rrdtool", but I have nor error messages nor log's pointing me to the right direction.

Any hint, pls?
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2009, 14:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you see any errors when you built RRDTool?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th April 2009, 15:43
irado irado is offline
Junior Member
 
Join Date: Apr 2009
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no, but I managed to solve it and, using the debug tool got rrd to function.. but problem changed somewhat:

situation now:

a) the summary/network loads shows the traditional "NOTE: this page is not operational when the RRD plugin is disabled, misconfigured or missing." besides it is properly configured/activated (think so).

b) if using the "info about" a particular host (all protocols/traffic, then any host) and click in the "historical data" icon (last line, right), it shows various empty chart, no data at all.


so.. I am still stuck.
Reply With Quote
  #4  
Old 10th April 2009, 13:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

That sounds like a permissions problem (like RRDTool is not allowed to write graphics to a certain directory). Did you check your log files?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Tags
centos, ntoop, rrdtool

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stuck on Centos Yum update fgaughan Installation/Configuration 6 20th September 2013 14:40
Bind-Server doesn't start Centos 5.3 oepastor General 9 7th April 2009 20:17
CentOS 5.3 + ispconfig 3 bongo Installation/Configuration 2 2nd April 2009 09:12
trouble with ntop - maybe need to install/configure http server ? shelby HOWTO-Related Questions 6 14th March 2008 14:10
Install ISPConfig on CentOS Server, in brief gfts Tips/Tricks/Mods 11 4th April 2006 08:29


All times are GMT +2. The time now is 12:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.