Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th April 2009, 02:23
DiAvOl DiAvOl is offline
Junior Member
 
Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default Virtual Users And Domains With Postfix on Debian Lenny: localhost.localdomain

First of all hello to everyone since this is my first post here!

I have a question about the localhost.localdomain address that the tutorial mentions. I have installed a debian lenny system and my default value in the /etc/hosts file is 127.0.0.1 localhost.

Should I change that to 127.0.0.1 localhost.localdomain localhost ? What is this used for?

Thanks for your help & regards
Reply With Quote
Sponsored Links
  #2  
Old 7th April 2009, 17:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I recommend to add localhost.localdomain because some services might use localhost.localdomain instead of localhost, and if localhost.localdomain isn't listed in /etc/hosts, then the system doesn't know which host is localhost.localdomain.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th April 2009, 19:42
DiAvOl DiAvOl is offline
Junior Member
 
Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks for the quick reply.

I read in some threads ( http://lists.debian.org/debian-devel.../msg00387.html ) that using:
Quote:
127.0.0.1 localhost.localdomain localhost
instead of:
Quote:
127.0.0.1 localhost localhost.localdomain
or plain:
Quote:
127.0.0.1 localhost
is not a good practice. Can this change cause any problems to other services that depend on 127.0.0.1 returning localhost?

Thanks
Reply With Quote
  #4  
Old 8th April 2009, 13:11
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I don't see how this change can cause any problems.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 11th April 2009, 07:30
DiAvOl DiAvOl is offline
Junior Member
 
Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Thanks falko.

One note that probably is missing from the tutorial:

By default the spamassasin daemon is disabled.

In order to enable it one should edit the file /etc/default/spamassassin
and change:
ENABLED=0
to
ENABLED=1
Reply With Quote
The Following User Says Thank You to DiAvOl For This Useful Post:
falko (12th April 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 11:14
Virtual Users And Domains With Postfix on Debian Lenny: Quarantine Question zeus80 HOWTO-Related Questions 2 13th April 2009 22:11
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 17:39
Help configure Postfix to use alt port 465 or 587 BoloMarkIII Installation/Configuration 10 16th March 2009 17:57
Question on Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) Horizon HOWTO-Related Questions 12 26th February 2008 20:22


All times are GMT +2. The time now is 07:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.