Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th April 2009, 12:37
jaze jaze is offline
Junior Member
 
Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems make suphp-0.7.0 Centos 5.2 - ISPCONFIG Howto

Im trying to follow falko exellent howto - on installling ISPCONFIG 3 on Centos everyting has worked till now.

Im at this point -
cd /tmp
wget http://www.suphp.org/download/suphp-0.7.0.tar.gz
tar xvfz suphp-0.7.0.tar.gz
cd suphp-0.7.0/
./configure --prefix=/usr --sysconfdir=/etc --with-apr=/usr/bin/apr-1-config --with-apxs=/usr/sbin/apxs --with-apache-user=apache --with-setid-mode=owner --with-php=/usr/bin/php-cgi --with-logfile=/var/log/httpd/suphp_log --enable-SUPHP_USE_USERGROUP=yes
make <---- here is where I receive the errors
make install <---- here is where I receive the errors


[...] similiar output.
mod_suphp.c:24:19: error: httpd.h: Ingen sådan fil eller filkatalog
mod_suphp.c:25:25: error: http_config.h: Ingen sådan fil eller filkatalog
mod_suphp.c:26:26: error: http_request.h: Ingen sådan fil eller filkatalog
mod_suphp.c:27:23: error: http_core.h: Ingen sådan fil eller filkatalog
mod_suphp.c:28:27: error: http_protocol.h: Ingen sådan fil eller filkatalog
mod_suphp.c:29:23: error: http_main.h: Ingen sådan fil eller filkatalog
mod_suphp.c:30:22: error: http_log.h: Ingen sådan fil eller filkatalog
mod_suphp.c:31:25: error: util_script.h: Ingen sådan fil eller filkatalog
mod_suphp.c:47: fejl: expected =, ,, ;, asm or __attribute__ before MODULE_VAR_EXPORT
mod_suphp.c:59: fejl: expected specifier-qualifier-list before table


and I get this when i try to restart apache

Starting httpd: httpd: Syntax error on line 210 of /etc/httpd/conf/httpd.conf: Syntax error on line 1 of /etc/httpd/conf.d/suphp.conf: Cannot load /etc/httpd/modules/mod_suphp.so into server: /etc/httpd/modules/mod_suphp.so: cannot open shared object file: No such file or directory

Any ideas to get me moving ...

Last edited by jaze; 4th April 2009 at 13:04.
Reply With Quote
Sponsored Links
  #2  
Old 5th April 2009, 01:13
jaze jaze is offline
Junior Member
 
Join Date: Apr 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

well found that
yum install mod_suphp worked

after i edited
vi /etc/suphp.conf

as Falko says in
The Perfect Server - CentOS 5.2 [ISPConfig 3] - Page 5

moving on, so lets see what else happens
Reply With Quote
  #3  
Old 31st May 2009, 05:48
stottle stottle is offline
Junior Member
 
Join Date: May 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem and was also able to run yum install on suphp, but I ran into problems after that. The problems were blank webpages from testing webmail, phpmyadmin and the initial page for ISPConfig.

This was on CentOS 5.3 x86_64. Turns out this error was because I only had the i386 install of apr-devel (I think configure was looking for an x86_64 header file that didn't exist from the i386 install). Running "yum install apr-devel" got the x86_64 version, and then I was able to successfully use ./configure, make and make install on suphp after that.

Note, since I had already run yum install suphp, I had to delete the yum installed version of /etc/httpd/conf.d/suphp.conf and create a new one with only the line from the tutorial ("LoadModule suphp_modules modules/mod_suphp.so").

BTW, the newest version of ISPConfig (3.0.1.3) seems to work on CentOS 5.3 if you follow the CentOS 5.2 instructions. (and replace i386 with x86_64 if you use 64 bit).

Hope this helps anyone else who runs into the same problem.

Thanks for the great tutorials!
Brett
Reply With Quote
  #4  
Old 15th June 2009, 00:54
kird03 kird03 is offline
Junior Member
 
Join Date: Oct 2005
Posts: 18
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Had same problem as topic starter...

The post of stottle made the How-to working again!

thanx!
Reply With Quote
  #5  
Old 22nd February 2010, 10:11
stevebor1 stevebor1 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 6
Thanks: 1
Thanked 1 Time in 1 Post
Default

sorry to resurrect the dead, but i have wasted 2 days and longs on this.

Had the same problem as stottle, php woulnd parse correctly after running the Perfect Server Centos ISPConfig. I was getting plank white pages for webmail and phpmyadmin.

Solution, from above, edit suphp.conf, comment everything out except 'LoadModule suphp_modules modules/mod_suphp.so'
Reply With Quote
The Following User Says Thank You to stevebor1 For This Useful Post:
falko (23rd February 2010)
  #6  
Old 28th November 2011, 18:26
agriz agriz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am getting the same error.
I tried

Code:
yum install mod_suphp
There is no package available.
I know it is old thread.

I m now using CentOS 6

Which repo did you use to install mod_suphp ?

Thanks
Reply With Quote
  #7  
Old 30th November 2011, 00:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

mod_suphp is available in the RPMforge repo, so you need to enable this first.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 30th November 2011, 01:14
agriz agriz is offline
Junior Member
 
Join Date: Nov 2011
Posts: 19
Thanks: 0
Thanked 0 Times in 0 Posts
Default

can i get the url to enable RPMforge repo?

Thanks
Reply With Quote
  #9  
Old 30th November 2011, 20:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Take a look at chapter 7 on http://www.howtoforge.com/perfect-se...ispconfig-3-p3
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig setup - DNS, router and general access problems ingvar Installation/Configuration 6 31st July 2010 14:13
Can't get mail (CentOS 5.2 + ISPconfig 2.2.29) wammy28 Installation/Configuration 4 28th January 2009 12:33
CENTOS 5.2 and ISPConfig 2.2.25 BIG problem sygram General 4 1st September 2008 19:59
SuPHP for PHP4 and PHP5 with ISPConfig Rustin Tips/Tricks/Mods 2 29th November 2006 09:52


All times are GMT +2. The time now is 08:16.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.