Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd April 2009, 23:44
kextra1 kextra1 is offline
Senior Member
 
Join Date: Apr 2008
Posts: 121
Thanks: 12
Thanked 10 Times in 6 Posts
Default 2.2.30 not writing to Vhost_ispconfig.conf apache file

Hello,

I can create a domain in ispconfig and it shows up...however it keeps sending it to the shared ip page

I looked at /etc/apache2/vhosts/Vhost_ispconfig.conf

and noticed that the domains i have just created under 2.2.30 are not showing up in the vhosts file like all the others!

Please help!
Reply With Quote
Sponsored Links
  #2  
Old 3rd April 2009, 09:20
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,502
Thanks: 813
Thanked 5,264 Times in 4,128 Posts
Default

http://www.howtoforge.com/forums/sho...=date+appended
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
kextra1 (4th April 2009)
  #3  
Old 4th April 2009, 03:01
kextra1 kextra1 is offline
Senior Member
 
Join Date: Apr 2008
Posts: 121
Thanks: 12
Thanked 10 Times in 6 Posts
Default httpd -t worked

copied old Vhost file to new one

httpd -t


Syntax error on line 836 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
SSLCertificateKeyFile: file '/var/www/web48/ssl/www.domain.net.key' does not exist or is empty

I never did change any of my apache configuration manually since the problem started though....i did change my SSL site from one domain to the other....that's about it...that shouldnt make a diff. should it?

Thank you for your help though Till.

Wouldnt

I'm running:

Debian etch 4.0
PHP5
etc. etc...everything seems to be all functional

Last edited by kextra1; 4th April 2009 at 03:13. Reason: update
Reply With Quote
  #4  
Old 4th April 2009, 09:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,502
Thanks: 813
Thanked 5,264 Times in 4,128 Posts
Default

Are there any copies of the file Vhosts_ispconfig.conf with the date appended to the name that you changed the ssl site?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 4th April 2009, 12:19
kextra1 kextra1 is offline
Senior Member
 
Join Date: Apr 2008
Posts: 121
Thanks: 12
Thanked 10 Times in 6 Posts
Default Friend must've fixed it

Hey Till!

I just got on the vpn and tested everything and it works. I got an email from an old good friend of mine saying that he found the answer within the link Till provided but also had to modify config.inc.php and ispconfig_web.lib.php (optional) so he left me some files to diff and said to read the post u linked above more carefully. Hehe, so thanks again Till! I'll be more thorough in the future man. Plus I'll post a detailed fix once i figure out what all was changed.
Reply With Quote
  #6  
Old 4th April 2009, 12:37
kextra1 kextra1 is offline
Senior Member
 
Join Date: Apr 2008
Posts: 121
Thanks: 12
Thanked 10 Times in 6 Posts
 
Default SSL Error Question

The error was:

Syntax error on line 836 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
SSLCertificateKeyFile: file '/var/www/web48/ssl/www.domain.net.key' does not exist or is empty

This was removed, none of the sites have the SSL box checkmarked, however I still want the default ispconfig ssl cert (https://www.domain.com:81) to be valid so it doesnt show up in red.

My provider i bought the cert from gives me options like:

Apache + ApacheSSL
Apache2 + OpenSSL

Although ISPConfig runs OpenSSL Falko informed me that ApacheSSL was the best choice....however i see no choice for apache2+apachessl on the rapidssl cert table. My certificate keeps coming up as self signed? Any ideas?

I appreciate your assistance once again Till, I'll get ya back one of these days. I'm a glutton for detail which makes me good at writing documentation
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
rewrite url not work apache2+mod_rewrite mohamedtah Installation/Configuration 1 31st January 2009 13:00
I Fail at installing ispconfig where did I go wrong? stocker741 Installation/Configuration 14 30th October 2008 14:12
jamed up my table borders?? Boon-Dog-Danny Installation/Configuration 5 23rd September 2006 16:12
PHP/MySQL/Apache2/ISPConfig configuration issues? senzapaura General 21 25th December 2005 14:01


All times are GMT +2. The time now is 15:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.