#1  
Old 23rd March 2006, 12:37
cbakken cbakken is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Apache2 trouble after install

Hi,
I finally managed to install ISPConfig on SLES9 SP3 aided by various helpful posts in this forum.
After a server restart I now have problems with Apache2, it won't start!
httpd2 -k start gives me the following error msg:
-------------------
httpd2: could not open document config file /etc/apache2/vhosts/Vhosts_ispconfig.conf
-------------------

permissions are:
-rwxr-xr-x 1 root root 2033 2006-03-23 03:26 Vhosts_ispconfig.conf

I've tried to chown it to wwwrun:www and chmod 777, but the same error appears.

Any idea, anyone?
Reply With Quote
Sponsored Links
  #2  
Old 23rd March 2006, 13:11
cbakken cbakken is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fixed! But another problem found.....

It was Novell's AppArmor that denied access to the file.
I disabled AppArmor, and now I can start Apache2.

But there's another problem:

I have added a site with MySQL database via ISPConfig.
When I open a shell and write <mysql -D web1_db1> I get an error stating that this database doesn't exist!

I need to import a database from another server into this database.

Thanks for any help.
Reply With Quote
  #3  
Old 23rd March 2006, 17:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Run
Code:
mysql -u root -p
SHOW DATABASES;
quit;
to find out which databases exist (or use phpMyAdmin to check).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 24th March 2006, 10:07
cbakken cbakken is offline
Junior Member
 
Join Date: Mar 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Fixed!

I had forgotten to give the MySQL user (which ISPConfig logs in as) GRANT rights. I then had to reload and restart mysqld.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem install perl modules Cirox Installation/Configuration 10 16th May 2007 16:04
Some trouble after install ISP Config ! fandi2000x Installation/Configuration 15 14th February 2006 02:59
suse 9.3 install: E: Couldn't find package ncftp aallen Installation/Configuration 4 26th January 2006 20:02
Install question/issue wr19026 Installation/Configuration 8 12th January 2006 09:44
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04


All times are GMT +2. The time now is 01:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.