Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st April 2009, 15:28
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Exclamation HELP: Enabled SSL on Site, Broke site

Using ISPCONFIG 3.0.1.1

I went a head and enabled SSL on one specific site, I ended up getting 500 Internal Errors so i decided to revert back and disable SSL.

I'm still getting the Internal 500 Errors though!
I removed all Certs. in the ssl directory for that site but still not working.
I removed the Cert. via ISPCONFIG in the options for the specific site but no luck.
What am I missing here??


I verified the *.vhost for the specific site and nothing appears to have changed here.

Here is the Error I'm getting the in the error.log:
Quote:
[Wed Apr 01 11:08:52 2009] [alert] [client IP address] /var/www/iwebsource.net/web/.htaccess: RewriteEngine not allowed here


What else do I have to do to get my site backup??

Last edited by astewart; 1st April 2009 at 16:10.
Reply With Quote
The Following User Says Thank You to astewart For This Useful Post:
AbannyvabVask (17th December 2013)
Sponsored Links
  #2  
Old 1st April 2009, 19:01
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

So I fixed the Internal 500 Errors but now sh404SEF (Joomla Component) no longer works.

The .htaccess file has not been modified so I can't figure out why sh404SEF no longer works.

Question: When enabling SSL for a site in ISPCONFIG 3, does it modify any Apache2 files?

I tried a number of different ways but I can't get it to work.

Has anyone else experienced issues with sh404SEF when SSL is enabled for a site?
Reply With Quote
The Following User Says Thank You to astewart For This Useful Post:
AbannyvabVask (17th December 2013)
  #3  
Old 1st April 2009, 21:20
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

Alright, Issue is solved.
I edited the *.vhost for the specific site and commented out line for both directory paths:

#AllowOverride Indexes AuthConfig Limit

After that the .htaccess now works again.

Last edited by astewart; 1st April 2009 at 21:30.
Reply With Quote
The Following User Says Thank You to astewart For This Useful Post:
AbannyvabVask (20th December 2013)
  #4  
Old 2nd April 2009, 10:54
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,709
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Do not edit .vhost files manually, ISPConfig will remove all your changes. If you want to set different AllowOverride Options, you can do that in the apache directives field of the website.

Also what you did above is a big security problem if your server is used as hosting server for more then one customer. Commenting out the line means that your customers can now work around every limit you have set them by uploading an .htaccess file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd April 2009, 18:35
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

Thanks Till,
Your right, I took a look at the specific *.vhost file and the two lines I commented out are un-commented again.

And the site no longer works, 500 Errors again.

So in the ISPCONFIG control panel, under the 'Apache directives' for the specific site, would I simply add:

Quote:
<Directory /var/www/iwebsource.net/web>
Options FollowSymLinks
#AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
<Directory /var/clients/client0/web2/web>
Options FollowSymLinks
#AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
Then save the changes?

I tried adding the above it didn't work.
I then tried adding:
Quote:
Options FollowSymLinks
#AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
But this didnt work either.

I tried:
Quote:
AllowOverride All
This didnt work either.
What am I suppse to add to get this working?

Last edited by astewart; 2nd April 2009 at 18:51.
Reply With Quote
  #6  
Old 2nd April 2009, 20:04
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,709
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Quote:
So in the ISPCONFIG control panel, under the 'Apache directives' for the specific site, would I simply add: .....
No.

Post the error message that you get in the error log of the website as you have to address this specific problem of apache.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 2nd April 2009, 20:36
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

It is the same error as I was getting from my original post:
Quote:
[Thu Apr 02 14:08:52 2009] [alert] [client IP address] /var/www/iwebsource.net/web/.htaccess: RewriteEngine not allowed here
I was able to resolve this yesturday by commenting out the following line in the specific *.vhost file for the site. But like you mentioned, ISPCONFIG did restore the default settings and now I'm back to the Internal 500 Errors.

This is what I commented out in the vhost file:
Quote:
AllowOverride Indexes AuthConfig Limit
eg.
Quote:
<Directory /var/www/iwebsource.net/web>
Options FollowSymLinks
#AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
<Directory /var/clients/client0/web2/web>
Options FollowSymLinks
#AllowOverride Indexes AuthConfig Limit
Order allow,deny
Allow from all
</Directory>
Reply With Quote
The Following User Says Thank You to astewart For This Useful Post:
AbannyvabVask (17th December 2013)
  #8  
Old 2nd April 2009, 23:34
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
 
Question

So are there any other ways to allow .htaccess within the web directories without having to Comment-out:
Quote:
AllowOverride Indexes AuthConfig Limit
Is there something I can add in the Apache directives in ISPCONFIG to correct this?

Is there anyone else experiencing this issue?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Apache will not load if SSL is enabled cephlon General 13 8th October 2008 06:29
The classic MySQL connect error swggy Installation/Configuration 13 10th April 2008 21:45
Setting up a customer SSL site catdude General 3 24th January 2008 18:34
SSL Issue - Unable to connect to any site Menzor Installation/Configuration 4 27th May 2007 04:03


All times are GMT +2. The time now is 08:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.