Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 6th April 2009, 09:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

Quote:
if i remove the extra tables manualy and then update the database...will i have a chance in successing ?
yes, that should work. make sure that you backup your database before you modify it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #32  
Old 6th April 2009, 09:44
robilaur robilaur is offline
Member
 
Join Date: Sep 2007
Location: Romania
Posts: 86
Thanks: 4
Thanked 12 Times in 9 Posts
Send a message via Yahoo to robilaur
Default

OK!!! ) Yeyyy..... verry happy now...

So .. for the ones that first updated to SVN and after that t wanted to uprade to 3.0.1.1 and couldn`t because the database was screwd up.... here is the simplest posible resolution to that problem.

go to : http://domain.tld/phpmyadmin
login as root , select dbispconfig and you will see there 54 tables.... the new version of ispconfig has only 44 and as you try to upgrade the extra 10 tables screws you up. So ...u make a back-up to the database then u select the folowing tables : billing_invoice, billing_product, billing_service, billing_service_class, billing_tax, client_address_book, domain ,domain_handle ,domain_provider , domain_tld and u drop them (delete them).

After that you log in to console and update ispconfig :
Code:
 ispconfig_update.sh
and select stable version.


Hope this helps and on the future ...remember!!! Do not use SVN on production machines!!!.... wait for stable
__________________
Best Regards,

Robert

Last edited by robilaur; 6th April 2009 at 10:36.
Reply With Quote
The Following 3 Users Say Thank You to robilaur For This Useful Post:
falko (7th April 2009), peterspoon (12th April 2009), till (6th April 2009)
  #33  
Old 9th April 2009, 22:26
Net-Pet Net-Pet is offline
Junior Member
 
Join Date: Oct 2005
Posts: 22
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to Net-Pet
Default

Quote:
Originally Posted by robilaur View Post
Table 'dbispconfig.billing_invoice' doesn't exist! Can anyone tell me what is this and way doesnt it exist?
Thanx
I made the same mistake from the guide and installed both svn and stable possible the stable version. The isp gui was older and not ISPConfig 3.0.1.1 so I have to start over again to get the stable version
but now I have also installed (important: Jailkit must be installed before ISPConfig - it cannot be installed afterwards!)
so maybe I ned to start all over again or can it be avoided ?
Reply With Quote
  #34  
Old 10th April 2009, 13:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,736 Times in 2,571 Posts
Default

Quote:
Originally Posted by Net-Pet View Post
so maybe I ned to start all over again or can it be avoided ?
What exactly are you referring to?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #35  
Old 10th April 2009, 20:57
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default ISPConfig 3 as a LVM-based XEN VM

Hi Till,
I am prepairing a new production server and i've setup IPSConfig3 in a LVM-based XEN VM. I want you to know that ISPConfig 3 is functioning very well in this environment!

Thanks one more time for this nice hosting control panel!
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #36  
Old 11th April 2009, 10:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

I dont see a reason why it should not work. ISPConfig does not interact with xen or lvm, so it should work like on any other server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #37  
Old 11th April 2009, 11:44
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 212
Thanked 648 Times in 294 Posts
Send a message via Skype™ to Hans
Default

That's true Till, but i'm a little enthusiastic!

One more thing:
i see in ISPConfig 3 that the red/orange bar in the left menu appears sometimes twice. So When this happens there are two red/orange bars instead of one.

This happens especially within the cp section of the menu.

Can this behaviour be solved?
__________________
Hans

BB-Hosting | Quality Web Hosting since 2005
Reply With Quote
  #38  
Old 15th April 2009, 11:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

The menu bar colora are changed with plain css, so most likely your browser has some issues with that as I dont see it in the browsers that I have installed on my computer.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #39  
Old 18th April 2009, 14:03
Cracklefish Cracklefish is offline
Member
 
Join Date: Mar 2009
Posts: 95
Thanks: 8
Thanked 3 Times in 3 Posts
Default

I must admit I had my fingers crossed when I did the update as I think I had broken the original install!

on doing the update I got an "unknown host" message and "PHP Notice: Undefined Offset: 0 in /tmp/isp.../update.php on line 81.

I said "yes" to reconfigure services - no further error messages.

Now the original problems.

Maybe I have shot myself in the foot...

I changed the mail directory to /src/mail

when I create a mailbox I get /srv/mail/domain/mail and /srv/mail/mailfilters/domain/mail
both ../mail folders are empty and don't receive mail but it is not being rejected, at least not yet (24 hours)

I have an apache problem too.

With no sites created I get a error when I try to connect to the machine because there is no index.html in /srv/www/htdocs/

If I put a file there I can see it until I add a site. Then the site shows.

If I add a second site still only site 1 shows.
Reply With Quote
  #40  
Old 18th April 2009, 17:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
 
Default

You can not chsnge the mail directory, if you cahnge it your setup gets broken. The best is to uninstall ispconfig snd then reinstall it without changing the directory.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.1 released till General 36 29th March 2009 14:30
ISPConfig 2.2.27 released till General 20 28th November 2008 12:45
ISPConfig 3.0.0.6 Beta released till General 38 21st September 2008 19:15
phpMyAdmin 2.11.8 package released for ISPConfig 2 Hans General 2 29th July 2008 07:23
ISPConfig 2.3.3-dev released till General 10 12th March 2008 21:08


All times are GMT +2. The time now is 11:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.