Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #71  
Old 28th March 2010, 00:35
paxpacis paxpacis is offline
Member
 
Join Date: Jan 2009
Posts: 31
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Hi, I will try it out coming week, I use suexec.. let you know how it goes

Quote:
Originally Posted by djtremors View Post

Anyone one to try it out, not tested with suphp or suexec which i'm sure the /ispcstats path will not work for it but happy to make changes for those would want a solution.

George
Reply With Quote
Sponsored Links
  #72  
Old 5th August 2010, 00:28
wikidd wikidd is offline
Junior Member
 
Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Any update on ISPC3, Awstats and Jawstats?

I followed the instructions on djtremors website to install the Awstats plugin.

But it doesn't seem to work. When I go to domain.tld/stats I get a redirect to domain.tld/jawstats/?config=domain.tld but its a 404 Error.

I installed jawstats according to the website except didn't know if I had to manually add all the site to the config (hoping the awstats script did that somehow like it does for awstats).

I tried to turn off jawstats and go back to just awstats but when I made jawstats = false in the plugin config the redirect was still pointing to the jawstats directory.

Any help getting this to work is greatly appreciated - at minimum I would be happy with awstats running but ideally would like jawstats.
Reply With Quote
  #73  
Old 5th August 2010, 00:29
wikidd wikidd is offline
Junior Member
 
Join Date: Aug 2010
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Update

I just checked the jawstats config file and it looks like it had been updated with the sites

Now to just get the stats working instead of the 404 error
Reply With Quote
  #74  
Old 8th August 2010, 03:40
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 13 Times in 11 Posts
Default

Quote:
Originally Posted by wikidd View Post
I just checked the jawstats config file and it looks like it had been updated with the sites

Now to just get the stats working instead of the 404 error
Yes, you need to wait for ISPC to poll for changes before it updates the config files. I'd have to double check what default I placed into this plugin on the site but thought awstats was the default, not jawstats.

Also remember that after installation, you need to wait for the overnight cron to process the web log files before things will start to populate and work properly. You could technically forcefully run the cron to update immediately to see if things work or not and not wait for cron.
__________________
www.emperor-it.com for ISPConfig mods/hacks
Reply With Quote
  #75  
Old 14th September 2010, 13:10
warlock warlock is offline
Member
 
Join Date: Nov 2008
Posts: 93
Thanks: 1
Thanked 6 Times in 4 Posts
Default

@djtremors :

I followed your install and the plugin works to a point, it has generated teh awstats.conf
When I run the update script it generates the stats files but I can't seem to get to display if I goto www.xxx.com/ispcstats, and I am getting a 404 error

any ideas ?
Reply With Quote
  #76  
Old 14th September 2010, 14:43
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 13 Times in 11 Posts
Default

http://www.emperor-it.com/component/...3-awstats.html

if you check on my page above, it says to place the below snip into /etc/apache2/conf.d/awstats.conf, has this been done and apache reloaded? I haven't tested on every distro so can't guarantee would it work on all but will help on request.

.
.
Alias /awstats-icon/ /usr/share/awstats/icon/
ScriptAlias /ispcstats/ /usr/lib/cgi-bin/

Also, you should be visiting /stats and not directly to /ispcstats unless you know the full url path/config settings.etc.
__________________
www.emperor-it.com for ISPConfig mods/hacks
Reply With Quote
  #77  
Old 14th September 2010, 14:45
warlock warlock is offline
Member
 
Join Date: Nov 2008
Posts: 93
Thanks: 1
Thanked 6 Times in 4 Posts
Default

Ok now have disabled jawstats as I can't get this to work, I have version 0.7 installed but even after I add statsname => "myformat [MM][YYYY].txt I am still getting an error
The data file being looked for is awstats20109.12volt.co.za.txt in folder :

Anyway, awstats seem to work but I can't login, what's the user and password ?
Reply With Quote
  #78  
Old 15th September 2010, 11:46
warlock warlock is offline
Member
 
Join Date: Nov 2008
Posts: 93
Thanks: 1
Thanked 6 Times in 4 Posts
Default

Quote:
Originally Posted by djtremors View Post
Hey djtremors,

your step
6. dit the /etc/awstats/awstats.conf and enabled the setting AllowAccessFromWebToAuthenticatedUsersOnly to 1. This is the protection to stop 1 domain on your host checking the other domains on your system in combination with the per site setting AllowAccessFromWebToFollowingAuthenticatedUsers.

AllowAccessFromWebToAuthenticatedUsersOnly=1

This is not required, else what happens is the user gets prompted for 2 logins, once by ispconfigs setting "admin" and then by yours "client name".

As ispconfig has the option to change or set a password for the stats site, the user will be prompted for this anyway.

I had endless problems trying to find out why I am being asked twice.

This now presents a problem if the users edit the web address ?config=example.co.za to another sites address they will have access to those stats.


if you do turn off

you will also need to comment out
# vi /etc/apache2/conf.d/awstats.conf

AuthType Basic
AuthName "Site Client Access Only"
AuthUserFile /usr/lib/cgi-bin/.htpasswd_stats
<limit GET PUT POST>
require valid-user
</limit>

Last edited by warlock; 15th September 2010 at 11:56.
Reply With Quote
  #79  
Old 15th October 2010, 14:06
djtremors djtremors is offline
Senior Member
 
Join Date: Apr 2006
Location: Sydney
Posts: 278
Thanks: 0
Thanked 13 Times in 11 Posts
Default

that problem you are now facing is because you removed what you said is not required.. but it is exactly for that reason

/ispcstats is global to all sites, hence all logins are stored in /usr/lib/cgi-bin/.htpasswd_stats for this url.

AllowAccessFromWebToAuthenticatedUsersOnly=1 forced that users MUST be authenticated (fair enough).

AllowAccessFromWebToFollowingAuthenticatedUsers="a dminuser1 ispc3admin" this is a website specific config which says which of those users authenticated have access to this websites stats (this stops cross site access).

www.client1website.com/stats is just a wrapper to preauth the site user(s) and then point to http://www.client1website.com/cgi-bi...nt1website.com making it easier to type in. User is already authenticated the first time, it should not reauthenticate unless it changes domain.

Check to make sure your ./web/stats/.htaccess file is redirecting to the same website URL

so www.clientsite.com, the file redirect should be

Redirect 301 /stats http://www.clientsite.com/awstats/?c...clientsite.com

PS: sorry, not monitoring this thread much.
__________________
www.emperor-it.com for ISPConfig mods/hacks
Reply With Quote
  #80  
Old 26th October 2010, 17:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
 
Default

Please be aware that ispconfig 3.0.3 includes awsatst support with static pages in the /stats directory. This plugin and the steps here might interfere with the ispconfig 3.0.3 awstats implemenatation and may not work or might destroy the ispconfoig 3.0.3 awsatst setup. I recommend to not use this plugin on ispconfig sstems that are newer then 3.0.2.2
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
awstats plugin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 12:47
Cant update ispconfig and awstats install issue supervos Installation/Configuration 6 4th November 2007 11:12
ISPConfig 2.2.13 released till General 35 23rd July 2007 17:28
Another Awstats Configuration Thingy For ISPConfig asyadiqin Installation/Configuration 2 6th August 2006 14:20
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16


All times are GMT +2. The time now is 18:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.