Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #41  
Old 2nd February 2010, 17:36
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

As I say in the start of the previous post, /etc/apache2/conf.d does not contain any awstats.conf files.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
Sponsored Links
  #42  
Old 2nd February 2010, 18:11
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by BorderAmigos View Post
As I say in the start of the previous post, /etc/apache2/conf.d does not contain any awstats.conf files.
Sorry about that, I mis-read your previous post.

So your telling me that you do not have an apache2 config file for awstats?
How are you able to get the icons loading then without that?

You must have an apache Config file somewhere for awstats, with directives and script aliases setup don't you?

So from Post #26:
http://www.howtoforge.com/forums/sho...9&postcount=26

Where do you have this setup:
Quote:
Alias /awstatsclasses "/usr/share/awstats/classes/"
Alias /awstatscss "/usr/share/awstats/css/"
Alias /awstats-icon "/usr/share/awstats/icon/"
ScriptAlias /stats/ "/usr/lib/cgi-bin/"
#
# This is to permit URL access to scripts/files in AWStats directory.
#
<Directory "/usr/share/awstats">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
If you don't have it setup, I'm unsure how you have awstats configured.

Have your tried clicking on the links in the main AWSTATS page, like when you want to vire the 'Full List' for Top Counties or Hosts?

Last edited by astewart; 2nd February 2010 at 18:17.
Reply With Quote
  #43  
Old 2nd February 2010, 18:35
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

My mistake, sorry. After coffee I see /etc/apache2/conf.d/awstats.conf is
Code:
<Directory "/usr/share/awstats">
        Options None
        AllowOverride all
        Order allow,deny
        Allow from all
</Directory>
Looking back at your suexec.log
Code:
[2010-02-01 14:29:42]: uid: (5004/web2) gid: (5004/5004) cmd: .php-fcgi-starter
[2010-02-01 15:17:01]: uid: (5004/web2) gid: (5004/5004) cmd: awstats.pl
[2010-02-01 15:17:01]: command not in docroot (/var/clients/client0/web2/cgi-bin/awstats.pl)
This is saying the file awstats.pl is not in the docroot. Also, the permissions look a bit off, gid: (5004/5004) should be maybe 5004/client0 ?

Make sure the awstats.pl file is in /var/clients/client0/web2/cgi-bin/ then try
Code:
chown -R web2:client0 /var/clients/client0/web2/cgi-bin
__________________
System6Hosting.com, ISPConfig 3, Debian.

Last edited by BorderAmigos; 2nd February 2010 at 18:42.
Reply With Quote
  #44  
Old 2nd February 2010, 18:46
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

I've done this a few days ago:
Quote:
root@myServer: cd /var/clients/client0/web2/cgi-bin
root@myServer:/var/clients/client0/web2/cgi-bin# ls -al
total 552
drwxr-x--x 2 web2 client0 4096 2010-01-28 08:31 .
drwxr-xr-x 9 root root 4096 2010-01-31 00:13 ..
-rwxr-xr-x 1 web2 client0 548956 2010-01-28 08:31 awstats.pl

Thats why I'm confused why 'suexec' is still giving me the same Error.
Both the 'cgi-bin' directory and the 'awstats.pl' file have permissions set to 755. Also tried 777 but no luck.

Reply With Quote
  #45  
Old 2nd February 2010, 18:51
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Does the cgi-bin directory have the same permissions, owner and group as the file?
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #46  
Old 2nd February 2010, 18:55
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Quote:
Originally Posted by BorderAmigos View Post
Does the cgi-bin directory have the same permissions, owner and group as the file?
It does:

Quote:
root@Server:/var/clients/client0/web2# ls -al
total 48
drwxr-xr-x 9 root root 4096 2010-01-31 00:13 .
drwxr-xr-x 6 root root 4096 2010-01-28 16:40 ..
drwxr-x--x 2 web2 client0 4096 2010-01-28 08:31 cgi-bin
drwxr-xr-x 4 web2 client0 4096 2008-11-11 22:29 home
-rw-rw-r-- 1 root root 40 2009-11-27 08:42 .htpasswd_stats
lrwxrwxrwx 1 web2 client0 39 2008-12-08 16:06 log -> /var/log/ispconfig/httpd/mydomain.net
drwxrwxrwx 2 web2 client0 12288 2009-10-21 16:01 tmp
drwxr-xr-x 23 web2 client0 4096 2010-01-29 11:03 web
root@Server:/var/clients/client0/web2#
Just to verifiy it isn't a problem with this one domain, I also tried thisa with a few of my other domains but I get the same results.
Reply With Quote
  #47  
Old 2nd February 2010, 19:02
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Sorry, I'm out of ideas then.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #48  
Old 2nd February 2010, 21:02
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Default

Yeah, no matter what I've tried I keep getting the same damb error:

Quote:
[2010-02-02 15:51:16]: uid: (5004/web2) gid: (5004/5004) cmd: awstats.pl
[2010-02-02 15:51:16]: command not in docroot (/var/clients/client0/web2/cgi-bin/awstats.pl)
I'm starting to wonder if 'suexec' is working properly. Once I disable it for that specific site, I have no problems following the internal awstat links (Full List, etc)

suexec info:
Quote:
root@myServer:/etc/apache2/conf.d# /usr/lib/apache2/suexec -V
-D AP_DOC_ROOT="/var/www"
-D AP_GID_MIN=100
-D AP_HTTPD_USER="www-data"
-D AP_LOG_EXEC="/var/log/apache2/suexec.log"
-D AP_SAFE_PATH="/usr/local/bin:/usr/bin:/bin"
-D AP_UID_MIN=100
-D AP_USERDIR_SUFFIX="public_html"
I'm wondering if I should be executing the 'awstats.pl' from /var/www
...

Last edited by astewart; 2nd February 2010 at 21:13.
Reply With Quote
  #49  
Old 2nd February 2010, 21:32
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

I show the exact same suexec info as you and am running it from the cgi-bin directory and it is working.
Code:
[2010-02-02 15:51:16]: uid: (5004/web2) gid: (5004/5004) cmd: awstats.pl
The (5004/5004) here still looks wrong to me. Something somewhere has the wrong uid/gid. Here is a script that sets up user/groups for a domain in mine. Not sure if it will help you.
Code:
chown -R web1:client1 /var/www/clients/client1/web1/*
chown -R web1:client1 /var/www/clients/client1/web1/.*
chown root:root /var/www/clients/client1/web1/
chown -R root:root /var/www/clients/client1/web1/bin
chown -R root:root /var/www/clients/client1/web1/dev
chown -R root:root /var/www/clients/client1/web1/etc
chown -R root:root /var/www/clients/client1/web1/lib
chown -R root:root /var/www/clients/client1/web1/usr
chown -R web1:client1 /var/www/clients/client1/web1/cgi-bin
Some have to be root for the chroot jail to work.
I think suexec is more picky about UID and GID than permissions.
__________________
System6Hosting.com, ISPConfig 3, Debian.

Last edited by BorderAmigos; 2nd February 2010 at 21:35.
Reply With Quote
  #50  
Old 3rd February 2010, 13:58
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
 
Default

Thanks for trying to help BorderAmigos, Unfortunately I've checked the uid/gid over a million times and everything is as it should be.

It might be a bug in the version of Ubuntu or something (8.04), or something else conflicting with suexec.



Anyone else have any other ideas?
Reply With Quote
Reply

Bookmarks

Tags
awstats plugin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47
Cant update ispconfig and awstats install issue supervos Installation/Configuration 6 4th November 2007 10:12
ISPConfig 2.2.13 released till General 35 23rd July 2007 16:28
Another Awstats Configuration Thingy For ISPConfig asyadiqin Installation/Configuration 2 6th August 2006 13:20
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 20:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.