Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Tips/Tricks/Mods

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 27th January 2010, 17:43
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

It is working on my setup. For me it does not replace the webalizer stats in /stats but gives me additional in /awstats. Both packages are working.

Pretty much as above except create directory in the web root called awstats and give it permissions 777.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
Sponsored Links
  #32  
Old 27th January 2010, 17:58
stefanr stefanr is offline
HowtoForge Supporter
 
Join Date: Dec 2005
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hello BorderAmigos,

thanks for your answer, you mean that it is all done and everything is fine.
But i have no directory awstats in any domain. I create in one of the domains manually and chmod 777 the awstats. Now should the awstats plugin should work.

Can i do manually an awstats update?

kind regards

STEFAN
Reply With Quote
  #33  
Old 27th January 2010, 18:11
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Check to see that the config's were created (one for each site)...

Code:
/etc/awstats/awstats.example.com.conf
I use a cron job that runs the below, again for every site...

Code:
/usr/lib/cgi-bin/awstats.pl -update -config=example.com -output=main > /var/www/example.com/web/awstats/index.html
There may have been other tweaks I don't remember at the moment.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #34  
Old 27th January 2010, 18:23
stefanr stefanr is offline
HowtoForge Supporter
 
Join Date: Dec 2005
Posts: 48
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi,

thanks i've done and now i got this error

Error: SiteDomain parameter not defined in your config/domain file. You must edit it for using this version of AWStats.

Setup ('/etc/awstats/awstats.conf' file, web server or permissions) may be wrong.
Check config file, permissions and AWStats documentation (in 'docs' directory).

when i go to domain.de/awstats

cat /etc/awstats/awstats.domain.de.conf
Include "/etc/awstats/awstats.conf"
LogFile="/var/log/ispconfig/httpd/domain.de/access.log"
SiteDomain="domain.de"

shoud i give the webserver read//write rights to the awstats.conf file?

what do i wrong?

kind regards
STEFAN
Reply With Quote
  #35  
Old 27th January 2010, 18:38
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

All I can do is say what my settings are.

All of the conf files in /etc/awstats are owned by root and permissions of 644.

In /etc/awstats/awstats.conf
SiteDomain=""

in /etc/awstats/awstats.example.com.conf
SiteDomain="example.com"
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #36  
Old 1st February 2010, 21:02
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question Unable to exec awstats.pl from user cgi-bin directory

So I have awstats installed and no problems creating static 'index.html' file in the following path for each domain:
Quote:
/var/www/mydomain.net/web/awstats/
I have a seperate cron setup for each domain as follows:
Quote:
0 1 * * * /usr/lib/cgi-bin/awstats.pl -update -config=mydomain1.com -output=main > /var/www/mydomain1.com/web/awstats/index.html
0 1 * * * /usr/lib/cgi-bin/awstats.pl -update -config=mydomain2.net -output=main > /var/www/mydomain2.net/web/awstats/index.html
I copied the 'awstats.pl' file to each 'cgi-bin' directory for each domain that has 'cgi' enabled.
Chmodded the script to 755 and changed the user and group to to the owner of that domain, eg (web2:client0).

So there are no problems viewing the static page but anytime I click on one of the links from the main awstats page to see 'Full List' or any link for that matter that directly calls the 'awstats.pl', I get the 'Internal 500' error because of 'suexec'.
When I disabale 'suexec' it works fine but I don't want to have to disable it.

Obviously it has something to due with the settings in the 'awstats.conf' file, at least I think so.

Here is what the suexec.log shows:
Quote:
[2010-02-01 14:29:42]: uid: (5004/web2) gid: (5004/5004) cmd: .php-fcgi-starter
[2010-02-01 15:17:01]: uid: (5004/web2) gid: (5004/5004) cmd: awstats.pl
[2010-02-01 15:17:01]: command not in docroot (/var/clients/client0/web2/cgi-bin/awstats.pl)
Here is my awstats.conf file:
Quote:
Alias /awstatsclasses "/usr/share/awstats/classes/"
Alias /awstatscss "/usr/share/awstats/css/"
Alias /awstats-icon "/usr/share/awstats/icon/"
ScriptAlias /stats/ "/usr/lib/cgi-bin/"
ScriptAlias /cgi-bin/ "/usr/lib/cgi-bin/"
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
#
# This is to permit URL access to scripts/files in AWStats directory.
#
<Directory "/usr/share/awstats">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
And here is what is listed in one of my specified .vhost files for a domain: (Just the CGI Part)
Quote:
# cgi enabled
<Directory /var/clients/client0/web2/cgi-bin>
Order allow,deny
Allow from all
</Directory>
ScriptAlias /cgi-bin/ /var/clients/client0/web2/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
# suexec enabled
SuexecUserGroup web2 client0
# php as fast-cgi enabled
<Directory /var/www/mydomain.net/web>
AddHandler fcgid-script .php .php3 .php4 .php5
FCGIWrapper /var/www/php-fcgi-scripts/web2/.php-fcgi-starter .php
Options +ExecCGI
AllowOverride all
Order allow,deny
Allow from all
</Directory>
I've already done a lot of google searching but no luck.
Does anyone have any ideas why this is not working with 'suexec' enabled?

Thanks!

Last edited by astewart; 1st February 2010 at 21:04.
Reply With Quote
  #37  
Old 1st February 2010, 22:01
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

Not sure but check and make sure the directories involved have the correct owners, groups and permissions as well as the files. This messed me up at one point.
__________________
System6Hosting.com, ISPConfig 3, Debian.
Reply With Quote
  #38  
Old 2nd February 2010, 13:41
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

Quote:
Originally Posted by BorderAmigos View Post
Not sure but check and make sure the directories involved have the correct owners, groups and permissions as well as the files. This messed me up at one point.
I've been playing around with permissions and user/groups for the last 3 -4 days but no luck.

It has to be with the way I have the directive setup, but I think I tried everything (Well obviously not everything)


BorderAmigos, would you be able to show me what you have in your
/etc/apache2/conf.d/awstats.conf file?
Reply With Quote
  #39  
Old 2nd February 2010, 16:53
BorderAmigos BorderAmigos is offline
Senior Member
 
Join Date: Apr 2008
Location: San Diego & Tijuana
Posts: 302
Thanks: 26
Thanked 33 Times in 31 Posts
Send a message via MSN to BorderAmigos Send a message via Yahoo to BorderAmigos
Default

"BorderAmigos, would you be able to show me what you have in your
/etc/apache2/conf.d/awstats.conf file? "

I don't have this file in this location. It is not part of the Apache configuration. Under /etc/awstats there are awstats.conf and another awstats.example.com.conf for each domain and subdomain (24 files in my case).

Here is an example of one of the domain files...
Code:
Include "/etc/awstats/awstats.conf"
LogFile="/var/log/ispconfig/httpd/chloetry.com/access.log"
SiteDomain="chloetry.com"
HostAliases="www.chloetry.com localhost 127.0.0.1"
The awstats.conf is to big to post so I attached it.

PS The "Include awstats.local.conf" file included at the end is just a copy of the "awstats.conf" file without the include. It's there in case an update overwrites the original file.
Attached Files
File Type: txt awstats.conf.txt (58.2 KB, 300 views)
__________________
System6Hosting.com, ISPConfig 3, Debian.

Last edited by BorderAmigos; 2nd February 2010 at 16:58.
Reply With Quote
  #40  
Old 2nd February 2010, 17:02
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
 
Default

Quote:
Originally Posted by BorderAmigos View Post
"BorderAmigos, would you be able to show me what you have in your
/etc/apache2/conf.d/awstats.conf file? "

I don't have this file in this location. It is not part of the Apache configuration. Under /etc/awstats there are awstats.conf and another awstats.example.com.conf for each domain and subdomain (24 files in my case).

Here is an example of one of the domain files...
Code:
Include "/etc/awstats/awstats.conf"
LogFile="/var/log/ispconfig/httpd/chloetry.com/access.log"
SiteDomain="chloetry.com"
HostAliases="www.chloetry.com localhost 127.0.0.1"
The awstats.conf is to big to post so I attached it.

PS The "Include awstats.local.conf" file included at the end is just a copy of the "awstats.conf" file without the include. It's there in case an update overwrites the original file.
This is what i currently have in my '/etc/apache2/conf.d/awstats.conf '
Quote:
Alias /awstatsclasses "/usr/share/awstats/classes/"
Alias /awstatscss "/usr/share/awstats/css/"
Alias /awstats-icon "/usr/share/awstats/icon/"
ScriptAlias /stats/ "/usr/lib/cgi-bin/"
ScriptAlias /cgi-bin/ "/usr/lib/cgi-bin/"
Options ExecCGI -MultiViews +SymLinksIfOwnerMatch
#
# This is to permit URL access to scripts/files in AWStats directory.
#
<Directory "/usr/share/awstats">
Options None
AllowOverride None
Order allow,deny
Allow from all
</Directory>
Here is an example of one of my domain files:
Quote:
Include "/etc/awstats/awstats.conf"
LogFile="/var/log/ispconfig/httpd/mydomain.net/access.log"
SiteDomain="mydomain.net"
I noticed that you attached the awstats.conf file from /etc/awstats, I was wondering what you have in your awstats.conf file in /etc/apache2/conf.d directory?
Reply With Quote
Reply

Bookmarks

Tags
awstats plugin

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47
Cant update ispconfig and awstats install issue supervos Installation/Configuration 6 4th November 2007 10:12
ISPConfig 2.2.13 released till General 35 23rd July 2007 16:28
Another Awstats Configuration Thingy For ISPConfig asyadiqin Installation/Configuration 2 6th August 2006 13:20
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 13:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.