Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 27th March 2009, 15:53
Sydney Sydney is offline
Junior Member
 
Join Date: Mar 2009
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yes php is disabled, I'm not planning to use it, by why do I have to remove those lines to get the indexes to work?
Reply With Quote
Sponsored Links
  #12  
Old 27th March 2009, 15:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Yes php is disabled, I'm not planning to use it
But you tried to access a .php page, so this does not make any sense. if you have .php pages in the websites and want to access thejm, then php has to be enabled. Otherwise the lines have to pe present as it is a security risc to access a .php page with php disabled as it can contain passwords and other security relevant information in cleartext.

Quote:
by why do I have to remove those lines to get the indexes to work?
This has nothing to do with indexes.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #13  
Old 27th March 2009, 17:18
Sydney Sydney is offline
Junior Member
 
Join Date: Mar 2009
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

No you have misuderstood, with the php lines removed, I goto http://mysite.com/uploads/ and I get a directory list, which is what I want, however, with the php lines I goto http://mysite.com/uploads/ and I get the error:

[Fri Mar 27 16:14:08 2009] [error] [client 192.168.1.1] client denied by server configuration: /var/www/mysite.com/web/uploads/index.php

I do not know why it is looking for index.php :s
Reply With Quote
  #14  
Old 28th March 2009, 00:15
Sydney Sydney is offline
Junior Member
 
Join Date: Mar 2009
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

The php issue seems to have dissolved, but I still cannot understand why I get an options not allowed here error, when I use a .htaccess with "options +indexes", even tho I have allowoverride indexes in the vhost file
Reply With Quote
  #15  
Old 28th March 2009, 09:34
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

You can not set options +indexes in a .htaccess files as thos would be a very big security hole. You can set options +indexes instead in the apache directives field of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 28th March 2009, 15:54
Sydney Sydney is offline
Junior Member
 
Join Date: Mar 2009
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks Till that works, but only if I enable php, otherwise I get the 403 index.php error, when requesting a directory listing for some strange reason...
Reply With Quote
  #17  
Old 28th March 2009, 20:54
Sydney Sydney is offline
Junior Member
 
Join Date: Mar 2009
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Guess I will have to learn some php
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Install failure -- Apache 1.3 missing? Allen15 Installation/Configuration 11 24th February 2009 09:53
can't help ispconfig to install please help steve51184 Installation/Configuration 17 20th February 2009 10:37
ISPConfig install issues... flyingaggie Installation/Configuration 2 18th July 2008 10:46
add web site serr57 Installation/Configuration 18 13th April 2008 11:40
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 00:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.