Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th March 2009, 02:16
Polk Polk is offline
Member
 
Join Date: May 2008
Location: Denver, CO, USA
Posts: 84
Thanks: 21
Thanked 0 Times in 0 Posts
Send a message via ICQ to Polk Send a message via MSN to Polk
Default Putty server unexpectedly closed network connection

I'm getting this error in Putty:
Server unexpectedly closed network connection

Anyone knows how to fix it? All search results show to turn off UseDNS no but I'm not even using dns. I connect to IP directly. Anyway, tried that and it didn't work.

I'm able to connect from other locations. just one computer got blocked. I can't find anything in logs, tried to reinstall ssh, ssh-openserver, fail2ban.

I'm on Debian Lenny installed using Perfect Server manual.
Attached Images
 
Reply With Quote
Sponsored Links
  #2  
Old 26th March 2009, 19:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by Polk View Post
fail2ban
How many failed login attempts did you make from this computer? I guess fail2ban is blocking that computer.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 26th March 2009, 19:48
Polk Polk is offline
Member
 
Join Date: May 2008
Location: Denver, CO, USA
Posts: 84
Thanks: 21
Thanked 0 Times in 0 Posts
Send a message via ICQ to Polk Send a message via MSN to Polk
Default

Quote:
Originally Posted by falko View Post
How many failed login attempts did you make from this computer? I guess fail2ban is blocking that computer.

that's what I thought too. I did about 5 failed connections. I tried to uninstall fail2ban and also there was nothing in the iptables -L

Any ideas?
Reply With Quote
  #4  
Old 27th March 2009, 15:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

http://debianclusters.cs.uni.edu/ind...rute_Force_SSH
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 27th March 2009, 17:48
Polk Polk is offline
Member
 
Join Date: May 2008
Location: Denver, CO, USA
Posts: 84
Thanks: 21
Thanked 0 Times in 0 Posts
Send a message via ICQ to Polk Send a message via MSN to Polk
Default

Thank you. I found that link online too. And followed the steps. I did not have blocked IP in my list.
I also did apt-get remove fail2ban.
Reply With Quote
  #6  
Old 28th March 2009, 20:26
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

And connecting from another IP works?
Is the IP listed in /etc/hosts.deny?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
Polk (28th March 2009)
  #7  
Old 28th March 2009, 20:32
Polk Polk is offline
Member
 
Join Date: May 2008
Location: Denver, CO, USA
Posts: 84
Thanks: 21
Thanked 0 Times in 0 Posts
Send a message via ICQ to Polk Send a message via MSN to Polk
Default

Quote:
Originally Posted by falko View Post
And connecting from another IP works?
Is the IP listed in /etc/hosts.deny?
Yes, I was able to connect from other IPs and yes, my blocked IP was listed there. Thank you so much! I removed and it's now working again!

Thank you!
Reply With Quote
  #8  
Old 11th January 2010, 21:50
sadnem sadnem is offline
Junior Member
 
Join Date: Jan 2010
Posts: 26
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I post this just to inform people, my host was adding me automatically to /etc/hosts.deny so i had to erase my IP from /etc/hosts.deny and add it to /etc/hosts.allow I hope this can solve other people problems too
Reply With Quote
  #9  
Old 6th March 2010, 19:00
darkbeat darkbeat is offline
Junior Member
 
Join Date: Mar 2010
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hi im also having this problem when using smoothping putty.. can someon teach me how to fix it in much simplier instructions? hehe .. i already found tutorials on the web but sadly i find it really hard to understand T_T.. im using windows xp .. hope someone can help me
Reply With Quote
  #10  
Old 7th March 2010, 16:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
 
Default

Is your client IP listed in /etc/hosts.deny?

Have you tried to reboot the system?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
User unknown in relay recipient table Taxick Installation/Configuration 12 9th April 2013 13:31
Email Clients cannot send mail iverson0881 Installation/Configuration 3 8th May 2008 09:34
Mail retrieval - connection intentionally closed by the server vincentthe Installation/Configuration 21 3rd February 2007 14:49
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 12:30
The Inperfect Setup for me - Fedora Core 4. dstme HOWTO-Related Questions 26 14th November 2005 18:52


All times are GMT +2. The time now is 05:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.