Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th March 2006, 20:26
linuxuser1 linuxuser1 is offline
Member
 
Join Date: Oct 2005
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi falko,

This is the output of ls -la /var/www/web1
total 40
drwxr-xr-x 8 web1_alpharadio web1 4096 2006-03-27 21:12 .
drwxr-xr-x 6 root root 4096 2006-03-27 00:00 ..
drwxrwxr-x 3 web1_alpharadio web1 4096 2006-03-27 22:51 cgi-bin
-rw------- 1 web1_alpharadio web1 24 2006-03-27 21:12 .forward
drwxr-xr-x 2 web1_alpharadio web1 4096 2006-03-27 00:00 log
lrwxrwxrwx 1 root root 42 2006-03-27 21:12 Maildir -> /var/www/web 1/user/web1_alpharadio/Maildir
drwxrwxrwx 2 web1_alpharadio web1 4096 2006-03-28 09:20 phptmp
-rw-r--r-- 1 root root 486 2006-03-27 21:12 .procmailrc
drwxr-xr-x 2 web1_alpharadio web1 4096 2006-03-27 00:00 ssl
drwxr-xr-x 3 web1_alpharadio web1 4096 2006-03-27 00:00 user
lrwxrwxrwx 1 root root 50 2006-03-27 21:12 .vacation.cache -> /var /www/web1/user/web1_alpharadio/.vacation.cache
drwxrwxr-x 7 web1_alpharadio web1 4096 2006-03-27 22:19 web


Thanks.
Reply With Quote
Sponsored Links
  #12  
Old 28th March 2006, 20:50
linuxuser1 linuxuser1 is offline
Member
 
Join Date: Oct 2005
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko,

I have done the chown command as you said here is how the permission now looks:

debian:~#ls -la /var/www/web1/cgi-bin/messenger/messenger.cgi
-rwxr-xr-x 1 web1_alpharadio web1 91355 2006-03-27 21:13 /var/www/web1/cgi-bin/




debian:~# ls -la /var/www/web1 total 40
drwxr-xr-x 8 web1_alpharadio web1 4096 2006-03-27 21:12 .
drwxr-xr-x 6 root root 4096 2006-03-27 00:00 ..
drwxrwxr-x 3 web1_alpharadio web1 4096 2006-03-27 22:51 cgi-bin
-rw------- 1 web1_alpharadio web1 24 2006-03-27 21:12 .forward
drwxr-xr-x 2 web1_alpharadio web1 4096 2006-03-27 00:00 log
lrwxrwxrwx 1 root root 42 2006-03-27 21:12 Maildir -> /var/www/web1/user/web1_alpharadio/Maildir
drwxrwxrwx 2 web1_alpharadio web1 4096 2006-03-28 09:20 phptmp
-rw-r--r-- 1 root root 486 2006-03-27 21:12 .procmailrc
drwxr-xr-x 2 web1_alpharadio web1 4096 2006-03-27 00:00 ssl
drwxr-xr-x 3 web1_alpharadio web1 4096 2006-03-27 00:00 user
lrwxrwxrwx 1 root root 50 2006-03-27 21:12 .vacation.cache -> /var/www/web1/user/web1_alpharadio/.vacation.cache
drwxrwxr-x 7 web1_alpharadio web1 4096 2006-03-27 22:19 web


debian:~# ls -la /var/www/web1/cgi-bin/hello_world.pl
-rwxr-xr-x 1 web1_alpharadio web1 379 2004-06-04 18:11 /var/www/web1/cgi-bin/hello_world.pl


Thanks.
Reply With Quote
  #13  
Old 29th March 2006, 14:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by linuxuser1
debian:~# ls -la /var/www/web1/cgi-bin/hello_world.pl
-rwxr-xr-x 1 web1_alpharadio web1 379 2004-06-04 18:11 /var/www/web1/cgi-bin/hello_world.pl
Looks good. Did you test it?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 29th March 2006, 14:42
linuxuser1 linuxuser1 is offline
Member
 
Join Date: Oct 2005
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko,

Yes. I tested it and still not working. Its here:-
http://www.alpharadiotv.org.uk/cgi-bin/hello_world.pl
http://www.alpharadiotv.org.uk/cgi-b.../messenger.cgi

Any other idea?

Thanks.
Reply With Quote
  #15  
Old 29th March 2006, 20:07
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Do you see anything in the Apache error log when you try to access these Perl scripts?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 30th March 2006, 11:40
linuxuser1 linuxuser1 is offline
Member
 
Join Date: Oct 2005
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Falko,

The problem turned out to be with suexec. I install another debian server as per your perfect setup without suexec and this is now working quite well.

But I can I resolve the suexec problem because I will like to use this as am thinking it will be more secure.

Any thoughts.

Thanks as always.
Reply With Quote
  #17  
Old 30th March 2006, 12:33
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

Is your web root /home/www or /var/www ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #18  
Old 30th March 2006, 14:26
linuxuser1 linuxuser1 is offline
Member
 
Join Date: Oct 2005
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi Till,

Using suexec my web root is /var/www ?. But because I could not get this to work, like i said i now set up another new server and the web root = /home/www and things are now working. Ut i will really love to use suexec if it will work.

Can i also ask please. How do i now set up my server to act as an smtp server because the script am running on the server needs the name/ip address of my smtp server. I put localhost in the script and it does not send any e-mail so am wondering what i need to do to enable smtp usage.
Reply With Quote
  #19  
Old 30th March 2006, 15:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by linuxuser1
Hi Till,

Using suexec my web root is /var/www ?. But because I could not get this to work, like i said i now set up another new server and the web root = /home/www and things are now working. Ut i will really love to use suexec if it will work.
Please post the output of
Code:
updatedb
locate suexec
Quote:
Originally Posted by linuxuser1
Can i also ask please. How do i now set up my server to act as an smtp server because the script am running on the server needs the name/ip address of my smtp server. I put localhost in the script and it does not send any e-mail so am wondering what i need to do to enable smtp usage.
Have a look at the Postfix section in the Debian tutorial: http://www.howtoforge.com/perfect_setup_debian_sarge_p4
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 30th March 2006, 21:30
linuxuser1 linuxuser1 is offline
Member
 
Join Date: Oct 2005
Posts: 66
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi,

The postfix section has alredy been implemented in my initial setup because i followed the perfect set up letter by letter and got the exact result expected as per the setup document.

Thanks.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Help!!! - Perl hunter13605 Programming/Scripts 1 5th March 2006 15:04
Ispconfig cgi hosting Mahir General 6 21st November 2005 15:40
Internal Server Error with CGI scripts? lola Programming/Scripts 2 21st April 2005 17:00


All times are GMT +2. The time now is 23:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.