Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2006, 17:31
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default webmail problem

Hi working on Suse 10 64bit with latest version of ispconfig.

When I try and get to the webmail page after logging in I get the following error message

Warning: Header may not contain more than a single header, new line detected. in /home/admispconfig/ispconfig/web/webmail/inc/inc.php on line 136

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/web/webmail/inc/inc.php:136) in /home/admispconfig/ispconfig/web/webmail/msglist.php on line 65

Any ideas.

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2006, 17:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,986
Thanks: 840
Thanked 5,647 Times in 4,457 Posts
Default

Please have a look here:

http://www.howtoforge.com/forums/showthread.php?t=2945
http://www.howtoforge.com/forums/showthread.php?t=2842
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th April 2006, 18:19
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

Got that bit working but when I try and send mail to a user using outlook I get the following error also I cant send mail out either.

This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its recipients. This is a permanent error. The following address(es) failed:

user1@chesterfieldathletics.org.uk
Too many "Received" headers - suspected mail loop

------ This is a copy of the message, including all the headers. ------

Return-path: <mhayes@touchone.co.uk>
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by pih-relay04.plus.net with smtp (Exim) id 1FVVTE-0002Vn-Pl
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:56 +0100
Received: (qmail 70868 invoked from network); 17 Apr 2006 15:16:56 -0000
Received: from ptb-relay01.plus.net (212.159.14.212)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:56 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by ptb-relay01.plus.net with smtp (Exim) id 1FVVTE-0002tU-8L
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:56 +0100
Received: (qmail 70860 invoked from network); 17 Apr 2006 15:16:55 -0000
Received: from pih-relay05.plus.net (212.159.14.132)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:55 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by pih-relay05.plus.net with smtp (Exim) id 1FVVTD-0006jD-Cz
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:55 +0100
Received: (qmail 70851 invoked from network); 17 Apr 2006 15:16:54 -0000
Received: from ptb-relay01.plus.net (212.159.14.212)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:54 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by ptb-relay01.plus.net with smtp (Exim) id 1FVVTB-0002t2-DY
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:54 +0100
Received: (qmail 70838 invoked from network); 17 Apr 2006 15:16:53 -0000
Received: from pih-relay04.plus.net (212.159.14.131)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:53 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by pih-relay04.plus.net with smtp (Exim) id 1FVVTA-0002TM-Vi
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:53 +0100
Received: (qmail 70835 invoked from network); 17 Apr 2006 15:16:52 -0000
Received: from pih-relay05.plus.net (212.159.14.132)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:52 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by pih-relay05.plus.net with smtp (Exim) id 1FVVTA-0006hW-H2
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:52 +0100
Received: (qmail 70832 invoked from network); 17 Apr 2006 15:16:52 -0000
Received: from ptb-relay01.plus.net (212.159.14.212)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:52 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by ptb-relay01.plus.net with smtp (Exim) id 1FVVTA-0002r3-1v
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:52 +0100
Received: (qmail 70827 invoked from network); 17 Apr 2006 15:16:51 -0000
Received: from pih-relay04.plus.net (212.159.14.131)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:51 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by pih-relay04.plus.net with smtp (Exim) id 1FVVT9-0002Sq-Kv
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:51 +0100
Received: (qmail 70824 invoked from network); 17 Apr 2006 15:16:51 -0000
Received: from pih-relay06.plus.net (212.159.14.133)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:51 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by pih-relay06.plus.net with smtp (Exim) id 1FVVT9-00022c-5k
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:51 +0100
Received: (qmail 70821 invoked from network); 17 Apr 2006 15:16:50 -0000
Received: from ptb-relay01.plus.net (212.159.14.212)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:50 -0000
Received: from [212.159.3.225] (helo=autoturn.force9.net)
by ptb-relay01.plus.net with smtp (Exim) id 1FVVT8-0002qh-PW
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:50 +0100
Received: (qmail 70817 invoked from network); 17 Apr 2006 15:16:50 -0000
Received: from ptb-relay01.plus.net (212.159.14.212)
by autoturn.force9.net with SMTP; 17 Apr 2006 15:16:50 -0000
Received: from [212.159.54.1] (helo=touch01)
by ptb-relay01.plus.net with esmtp (Exim) id 1FVVT8-0002pb-9C
for user1@chesterfieldathletics.org.uk; Mon, 17 Apr 2006 16:16:50 +0100
Return-Receipt-To: "Martin Hayes" <mhayes@touchone.co.uk>
From: "Martin Hayes" <mhayes@touchone.co.uk>
To: <user1@chesterfieldathletics.org.uk>
Subject: Testing
Date: Mon, 17 Apr 2006 16:16:51 +0100
Message-ID: <!&!AAAAAAAAAAAYAAAAAAAAACMRtkYEJ2JJsY4Oj57J7iHCgA AAEAAAAPbXVKYLHV1AhrHkbO0BGBYBAAAAAA==@touchone.co .uk>
MIME-Version: 1.0
Content-Type: multipart/alternative;
boundary="----=_NextPart_000_001B_01C6623A.55F7B480"
X-Mailer: Microsoft Office Outlook 11
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.2900.2180
Thread-Index: AcZiLAqP3B7HmMhDQtavC0kRi1YreQ==
Disposition-Notification-To: "Martin Hayes" <mhayes@touchone.co.uk>

This is a multi-part message in MIME format.

------=_NextPart_000_001B_01C6623A.55F7B480
Content-Type: text/plain;
charset="us-ascii"
Content-Transfer-Encoding: 7bit

ect.....

Any ideas
Reply With Quote
  #4  
Old 17th April 2006, 18:21
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default my main.conf

sample_directory = /usr/share/doc/packages/postfix/samples

# readme_directory: The location of the Postfix README files.
#
readme_directory = /usr/share/doc/packages/postfix/README_FILES
inet_protocols = all
biff = no
mail_spool_directory = /var/mail
canonical_maps = hash:/etc/postfix/canonical
#virtual_maps = hash:/etc/postfix/virtual
relocated_maps = hash:/etc/postfix/relocated
transport_maps = hash:/etc/postfix/transport
sender_canonical_maps = hash:/etc/postfix/sender_canonical
masquerade_exceptions = root
masquerade_classes = envelope_sender, header_sender, header_recipient
myhostname = server1.$mydomain
program_directory = /usr/lib/postfix
inet_interfaces = all
masquerade_domains =
#mydestination = $myhostname, localhost.$mydomain
defer_transports =
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_ relay_domains
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = touchonehosting.co.uk
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Reply With Quote
  #5  
Old 17th April 2006, 18:22
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default End Of My Mail Log File

Apr 17 16:17:07 server1 postfix/smtpd[14461]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Apr 17 16:17:07 server1 postfix/smtpd[14461]: warning: inet_protocols: configuring for IPv4 support only
Apr 17 16:17:07 server1 postfix/proxymap[14464]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Apr 17 16:17:07 server1 postfix/proxymap[14464]: warning: inet_protocols: configuring for IPv4 support only
Apr 17 16:17:07 server1 postfix/smtpd[14461]: warning: connect to private/tlsmgr: No such file or directory
Apr 17 16:17:08 server1 postfix/smtpd[14461]: warning: connect to private/tlsmgr: No such file or directory
Apr 17 16:17:08 server1 postfix/smtpd[14461]: warning: problem talking to server private/tlsmgr: No such file or directory
Apr 17 16:17:08 server1 postfix/smtpd[14461]: warning: no entropy for TLS key generation: disabling TLS support
Apr 17 16:17:08 server1 postfix/smtpd[14461]: connect from localhost[127.0.0.1]
Apr 17 16:17:08 server1 postfix/cleanup[14467]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Apr 17 16:17:08 server1 postfix/cleanup[14467]: warning: inet_protocols: configuring for IPv4 support only
Apr 17 16:17:08 server1 postfix/smtpd[14461]: 2D10A340132: client=localhost[127.0.0.1]
Apr 17 16:17:08 server1 postfix/cleanup[14467]: 2D10A340132: message-id=<20060417151708.2D10A340132@server1.touchonehos ting.co.uk>
Apr 17 16:17:08 server1 postfix/qmgr[14371]: 2D10A340132: from=<web1-user1@chesterfieldathletics.org.uk>, size=801, nrcpt=1 (queue active)
Apr 17 16:17:08 server1 postfix/smtp[14470]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Apr 17 16:17:08 server1 postfix/smtp[14470]: warning: inet_protocols: configuring for IPv4 support only
Apr 17 16:17:08 server1 postfix/smtp[14470]: warning: connect to private/tlsmgr: No such file or directory
Apr 17 16:17:08 server1 postfix/smtpd[14461]: disconnect from localhost[127.0.0.1]
Apr 17 16:17:08 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
Apr 17 16:17:08 server1 pop3d: LOGIN, user=web1-user1, ip=[::ffff:127.0.0.1]
Apr 17 16:17:08 server1 pop3d: LOGOUT, user=web1-user1, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0
Apr 17 16:17:09 server1 postfix/smtp[14470]: warning: connect to private/tlsmgr: No such file or directory
Apr 17 16:17:09 server1 postfix/smtp[14470]: warning: problem talking to server private/tlsmgr: No such file or directory
Apr 17 16:17:09 server1 postfix/smtp[14470]: warning: no entropy for TLS key generation: disabling TLS support
Apr 17 16:17:29 server1 postfix/bounce[14482]: warning: inet_protocols: IPv6 support is disabled: Address family not supported by protocol
Apr 17 16:17:29 server1 postfix/bounce[14482]: warning: inet_protocols: configuring for IPv4 support only
Apr 17 16:17:29 server1 postfix/smtp[14470]: 2D10A340132: to=<mhayes@touchone.co.uk>, relay=none, delay=21, status=deferred (Host or domain name not found. Name service error for name=touchone.co.uk type=MX: Host not found, try again)
Apr 17 16:19:56 server1 pop3d: Connection, ip=[::ffff:127.0.0.1]
Apr 17 16:19:56 server1 pop3d: LOGIN, user=web1-user1, ip=[::ffff:127.0.0.1]
Apr 17 16:19:56 server1 pop3d: LOGOUT, user=web1-user1, ip=[::ffff:127.0.0.1], top=0, retr=0, time=0


Thanks for any help given
Reply With Quote
  #6  
Old 17th April 2006, 18:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Looks like you built a mail loop...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th April 2006, 18:38
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default





So how do we fix this.....
Reply With Quote
  #8  
Old 17th April 2006, 18:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Did you change anything in your Postfix configuration recently?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 17th April 2006, 18:45
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
Default

no installed everything a month or so ago, and then updated to your latest release and then I am now testing it and found this problem. The only thing I have done is adjust the modprobe file to take out ipv6 so that I can get on the web.... thats all I have changed.

Thanks
Reply With Quote
  #10  
Old 17th April 2006, 18:54
mphayesuk mphayesuk is offline
Senior Member
 
Join Date: Sep 2005
Location: UK, East Midlands
Posts: 517
Thanks: 1
Thanked 3 Times in 3 Posts
Send a message via MSN to mphayesuk
 
Default

Could anything in my host files cause this problem:

HOSTNAME - file contents (the case of this file is as it appears in the folder)
server1.touchonehosting.co.uk

hosts - file contents
hosts This file describes a number of hostname-to-address # mappings for the TCP/IP subsystem. It is mostly # used at boot time, when no name servers are running. # On small systems, this file can be used instead of a # "named" name server. # Syntax: # # IP-Address Full-Qualified-Hostname Short-Hostname # 127.0.0.1 localhost # special IPv6 addresses ::1 localhost ipv6-localhost ipv6-loopback fe00::0 ipv6-localnet ff00::0 ipv6-mcastprefix ff02::1 ipv6-allnodes ff02::2 ipv6-allrouters ff02::3 ipv6-allhosts 212.159.54.3 server1.touchonehosting.co.uk server1 212.159.54.4 server1.touchonehosting.co.uk

hosts.deny - file contents
/etc/hosts.deny # See 'man tcpd' and 'man 5 hosts_access' as well as /etc/hosts.allow # for a detailed description. http-rman : ALL EXCEPT LOCAL Thanks

Last edited by mphayesuk; 17th April 2006 at 18:57.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
tlsmgr webmail problem, suse 9.3 perfect setup dschmid Installation/Configuration 44 2nd April 2006 19:55
Uebimiau webmail problem rosa hsiao General 4 9th January 2006 11:09
Problem with Webmail URL, uses local network and not internet danf.1979 General 8 24th December 2005 17:24
webmail klient quota problem? jernis Installation/Configuration 9 30th November 2005 23:14
Problem with webmail MyLinux General 10 17th September 2005 15:31


All times are GMT +2. The time now is 03:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.