Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st March 2009, 23:24
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default ISPconfig 3.0.0.9 ([warn] NameVirtualHost IP...:80 has no VirtualHosts)

For some reason I'm getting the following warning when starting (and stopping) Apache2 on my ISPcondig 3.0.0.9 server. (I've masked the real IP)
OS is Debian Lenny.
Quote:
/etc/init.d/apache2 start
Starting web server: apache2[Sat Mar 21 22:16:01 2009] [warn] NameVirtualHost 65.55.21.250:80 has no VirtualHosts
[Sat Mar 21 22:16:01 2009] [warn] NameVirtualHost 65.55.21.250:443 has no VirtualHosts
Not sure if this was all the time, but today I've placed the server in a DC, and I needed to change all the IP's on it.

Looking at the /etc/apache2/sites-available/ispconfig.conf I do see the two IP's, but I do not see them in any of the .vhost files
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Sponsored Links
  #2  
Old 22nd March 2009, 16:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Do the .vhost files use the correct IPs?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd March 2009, 17:44
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Yes they do, but I found the problem (sort of)
I had all sites set to use IP *
After I set one of the sites to the server IP, the "[warn] NameVirtualHost 65.55.21.250:80 has no VirtualHosts" warning was gone.

I DO still have the warning: "[warn] NameVirtualHost 65.55.21.250:443 has no VirtualHosts"
__________________
Never execute code written on a Friday or a Monday.

Last edited by edge; 22nd March 2009 at 17:48.
Reply With Quote
  #4  
Old 22nd March 2009, 19:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,750
Thanks: 840
Thanked 5,601 Times in 4,412 Posts
Default

This warning is fine as you do not run a SSL site on this IP yet.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st August 2009, 22:57
alex288288 alex288288 is offline
Member
 
Join Date: Jul 2009
Posts: 32
Thanks: 2
Thanked 0 Times in 0 Posts
Default

im getting the same problem

Quote:
[root@208 ~]# /etc/init.d/httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost 208.93.233.53:80 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost 208.93.233.53:443 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost *:8080 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost *:443 has no VirtualHosts
[Sat Aug 01 16:05:09 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
do i need to delete this ? ive uninstalled ISPconfig3... needs to be reinstalled
Reply With Quote
  #6  
Old 2nd August 2009, 07:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,750
Thanks: 840
Thanked 5,601 Times in 4,412 Posts
 
Default

See my post #4. This warning is fine, so there has nothing to be changed.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.0.9 RC2 released till General 51 17th April 2009 18:12
ISPConfig 3.0.0.4 Beta Released till General 54 4th March 2009 10:55
ISPConfig 3.0.0.9 mail forwarding ihamouda Installation/Configuration 1 19th February 2009 13:16
NameVirtualHost *:80 lucasajackson Installation/Configuration 6 4th February 2009 22:46
NameVirtualHost www.mysite.it has no VirtualHosts gabrix Server Operation 20 23rd March 2007 19:27


All times are GMT +2. The time now is 17:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.