Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 21st March 2009, 03:52
leonhongkong leonhongkong is offline
Junior Member
 
Join Date: Mar 2009
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Question dkim-filter problem - can't read SMFIC_OPTNEG reply packet header

Hi. I use ubuntu 8.10 server 64 bit + postfix + dkim-filter + dovecot
There is a problem with dkim-filter. I followed the instruction at https://help.ubuntu.com/community/Postfix/dkim-milter
Everything worked fine until I ran apt-get upgrade.

The dkim-filter didn't work. When I sent mail, syslog said
Code:
...
Mar 19 16:40:57 myubuntu postfix/smtpd[6166]:warning: milter inet:127.0.0.1:8891: can't read SMFIC_OPTNEG reply packet header: Connection timed out
Mar 19 16:40:57 myubuntu postfix/smtpd[6166]: warning: milter inet:127.0.0.1:8891:read error in initial handshake
...
The mail is sent successful but without dkim's header. Hotmail just send my mail directly to the junk folder



when I tried to restart dkim-filter the syslog said
Code:
...
Mar 19 06:31:18 myubuntu dkim-filter[14604]: can't configure DKIM library; continuing
Mar 19 06:31:18 myubuntu dkim-filter[14604]: Sendmail DKIM Filter v2.6.0 starting (args: -x /etc/dkim-filter.conf -p local)
...
After restarted dkim-filter. It ran normally but didn't work with postfix!?!


any idea to fix dkim-filter?
Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 21st March 2009, 21:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the output of
Code:
netstat -tap
? Have you tried to restart dkim-filter?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
leonhongkong (22nd March 2009)
  #3  
Old 22nd March 2009, 18:21
leonhongkong leonhongkong is offline
Junior Member
 
Join Date: Mar 2009
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
What's the output of
Code:
netstat -tap
? Have you tried to restart dkim-filter?
"netstat -tap" output
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:imaps                 *:*                     LISTEN      14906/dovecot
tcp        0      0 *:pop3s                 *:*                     LISTEN      10524/pop3-login
tcp        0      0 localhost:mysql         *:*                     LISTEN      6859/mysqld
tcp        0      0 *:netbios-ssn           *:*                     LISTEN      7104/smbd
tcp        0      0 *:pop3                  *:*                     LISTEN      10524/pop3-login
tcp        0      0 *:imap2                 *:*                     LISTEN      14906/dovecot
tcp        0      0 *:webmin                *:*                     LISTEN      7482/perl
tcp        0      0 *:www                   *:*                     LISTEN      7279/apache2
tcp        0      0 *:ftp                   *:*                     LISTEN      7185/proftpd: (acce
tcp        0      0 192.168.122.1:domain    *:*                     LISTEN      7059/dnsmasq
tcp        0      0 myubuntu.xxx:domain *:*                     LISTEN      6745/named
tcp        0      0 localhost:domain        *:*                     LISTEN      6745/named
tcp        0      0 *:smtp                  *:*                     LISTEN      10761/master
tcp        0      0 localhost:953           *:*                     LISTEN      6745/named
tcp        0      0 localhost:8891          *:*                     LISTEN      10661/dkim-filter
tcp        0      0 *:https                 *:*                     LISTEN      7279/apache2
tcp        0      0 *:microsoft-ds          *:*                     LISTEN      7104/smbd
tcp6       0      0 [::]:8009               [::]:*                  LISTEN      7375/jsvc
tcp6       0      0 [::]:http-alt           [::]:*                  LISTEN      7375/jsvc
tcp6       0      0 [::]:domain             [::]:*                  LISTEN      6745/named
tcp6       0      0 localhost:953           [::]:*                  LISTEN      6745/named

Last edited by leonhongkong; 22nd March 2009 at 18:31.
Reply With Quote
  #4  
Old 22nd March 2009, 18:39
leonhongkong leonhongkong is offline
Junior Member
 
Join Date: Mar 2009
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Default

These are what I had tried

- update dkim-filter2.6 to dkim-filter2.8
- bind dkim-filter's port from 8891 to 8892
- change milter_protocol in /etc/postfix/main.cf from 2 to 3,4,6

still no luck
Reply With Quote
  #5  
Old 23rd March 2009, 18:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Have you tried to restart dkim-filter (or reboot the whole system)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
leonhongkong (23rd March 2009)
  #6  
Old 23rd March 2009, 20:21
leonhongkong leonhongkong is offline
Junior Member
 
Join Date: Mar 2009
Posts: 4
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Have you tried to restart dkim-filter (or reboot the whole system)?
yes, I tried.

I don't know if my problem relate to
Code:
Mar 20 07:42:19 myubuntu deliver(root): mail_location not set and autodetection failed: Mail storage autodetection failed with home=/root
Mar 20 07:42:19 myubuntu deliver(root): Fatal: Namespace initialization failed
in /var/log/syslog which have appeared frequency.

Nah,but I don't think "Namespace initialization failed" relate to dkim-filter
Reply With Quote
  #7  
Old 24th March 2009, 17:41
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I don't know what's wrong here.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 24th March 2009, 22:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Someone has just posted a reply to your comment: http://www.howtoforge.com/quick-and-...#comment-11713

Maybe that helps.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 16th September 2012, 10:15
helpmhost helpmhost is offline
Junior Member
 
Join Date: Sep 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I had the exact same problem. The cause (and solution) was that dkim does DNS lookups use TCP.

Open your firewall to allow outbound TCP DNS queries (and allow the replies back in) and it should work.

Martin
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
Transferring Hard Drive to new System latcarf Installation/Configuration 26 20th February 2007 18:51
ubuntu ispconfig joomla .htaccess steve1084 General 8 6th January 2007 15:55
Postfix problem : read timeout DarkBen General 14 21st April 2006 12:39


All times are GMT +2. The time now is 23:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.