Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 7th July 2009, 21:46
y87 y87 is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default myDNS not really starting

Thanks for showing me where the issue is! For some reason, even though /etc/init.d/mydns start/restart/stop appears to work, when I check my active processes, I don't see myDNS anywhere. I reconfigured with the newest version, and although myDNS will say it's starting, it doesn't, so I'm attempting to work that out. At least I don't have to focus on dnsmasq or the way I've set my configurations, now that I know the problem lies with myDNS. Any additional suggestions would also be appreciated, though I'm currently researching what may cause this behavior now.
Reply With Quote
Sponsored Links
  #12  
Old 8th July 2009, 14:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Are there any errors in your logs? Did you configure MyDNS to not listen on localhost.localdomain (since dnsmasq is listening there)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 8th July 2009, 21:27
y87 y87 is offline
Junior Member
 
Join Date: Jul 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Smile Reverse Dns

Yes, I configured myDNS to not listen when I was setting up dnsmasq. I think I've been barking up the wrong tree, though. I reinstalled Debian 5.0 and set everything up from scratch, and I still ran into the same issue. Then it occurred to me, that I never submitted a request to get Reverse Dns setup with my host, which I've now done. I check logs and saw no errors with myDNS. I'm correct in that Reverse DNS must be setup for nameservers to resolve properly, right? Thanks for all your help, and I'm pretty sure that everything was setup correctly per your many tutorials and that this was just an oversight on my part, though it will take awhile for Reverse DNS to propagate so that I know.
Reply With Quote
  #14  
Old 29th September 2009, 07:15
spikes spikes is offline
Member
 
Join Date: Sep 2009
Posts: 45
Thanks: 6
Thanked 2 Times in 1 Post
Default Query status refused problem

Hi,

I cannot get mydns to work. I have latest ispconfig3. I include below if someone can please help me. I am a newbie. Thanks in advance.

server1:~# dig @localhost www.mydomain.com

; <<>> DiG 9.5.1-P3 <<>> @localhost www.mydomain.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 40819
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;www.mydomain.com. IN A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Tue Sep 29 18:09:30 2009
;; MSG SIZE rcvd: 36


server1:~# netstat -tap | grep dns
getnameinfo failed
tcp 0 0 server1.mydomain:domain *:* LISTEN 1792/mydns
tcp 0 0 localhost.locald:domain *:* LISTEN 1191/dnsmasq
tcp6 0 0 [UNKNOWN]:domain [::]:* LISTEN 1792/mydns
Reply With Quote
  #15  
Old 29th September 2009, 09:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,608
Thanks: 792
Thanked 4,986 Times in 3,905 Posts
Default

As you are running dnsmasq on localhost as resolver and not the mydns serverm you can not query it with @localhost. You have to use:

dig @IPADDRESS www.mydomain.com

were you replace IPADDRESS with the IP of the server (not 127.0.0.1)
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #16  
Old 29th September 2009, 09:21
spikes spikes is offline
Member
 
Join Date: Sep 2009
Posts: 45
Thanks: 6
Thanked 2 Times in 1 Post
Default

I have tried with ip address and this is what I got

server1:~# dig @IPADDRESS www.mydomain.com

; <<>> DiG 9.5.1-P3 <<>> @IPADDRESS www.mydomain.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 31506
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: Messages has 476 extra bytes at end

;; QUESTION SECTION:
;www.mydomain.com. IN A

;; Query time: 0 msec
;; SERVER: IPADDRESS#53(IPADDRESS)
;; WHEN: Tue Sep 29 20:17:12 2009
;; MSG SIZE rcvd: 512
Reply With Quote
  #17  
Old 30th September 2009, 03:30
spikes spikes is offline
Member
 
Join Date: Sep 2009
Posts: 45
Thanks: 6
Thanked 2 Times in 1 Post
Default

I have started over and done complete reinstall. I see something funny here: tcp6 0 0 ::1%3217472056:domain. I also keep getting REFUSED when using dig to check my server. I don't know where I go wrong as I follow the tutorials and do not get any errors during the install. I have also added the ns1 and ns2 entries at my domain registrar pointing to the server ip address. I have added reverse dns pointing to mydomain.com.

It seems that I cannot make queries to my own server? I think I do not have the experience to see what's wrong. I'm stuck. Till can you please help me. Where to from here. I moved from shared hosting to vps and my site is down.

tcp 0 0 server1.mydomain:domain *:* LISTEN
13200/mydns
tcp 0 0 localhost.locald:domain *:* LISTEN
13200/mydns
tcp6 0 0 ::1%3217472056:domain [::]:* LISTEN
13200/mydns

I can dig google ok. Nothing works for the domain that I added tho. Have tried dig with ip address also.

server1:~# dig @localhost mydomain.com

; <<>> DiG 9.5.1-P3 <<>> @localhost mydomain.com
; (1 server found)
;; global options: printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: REFUSED, id: 13195
;; flags: qr rd; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0
;; WARNING: recursion requested but not available

;; QUESTION SECTION:
;mydomain.com. IN A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Wed Sep 30 14:23:26 2009
;; MSG SIZE rcvd: 32

Last edited by spikes; 30th September 2009 at 05:06. Reason: additional info
Reply With Quote
  #18  
Old 30th September 2009, 09:20
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,608
Thanks: 792
Thanked 4,986 Times in 3,905 Posts
Default

And you are sure that you added the dns records for mydomain.com correctly? Did you use the DNS wizard? Please post a screenshot of the dns settings of mydomain.com in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #19  
Old 30th September 2009, 09:49
spikes spikes is offline
Member
 
Join Date: Sep 2009
Posts: 45
Thanks: 6
Thanked 2 Times in 1 Post
Default

I managed to get it fixed.

Thank you

Last edited by spikes; 1st October 2009 at 06:13.
Reply With Quote
  #20  
Old 30th September 2009, 17:17
Nikola Nikola is offline
Member
 
Join Date: Mar 2009
Posts: 33
Thanks: 23
Thanked 3 Times in 1 Post
 
Default

why *.*.tld?

*.*.com. or *.com. is right... ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig setup - DNS, router and general access problems ingvar Installation/Configuration 6 31st July 2010 13:13
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 22:47
use external dns nameservers CONFUSED bobwdn Installation/Configuration 11 9th February 2009 14:50
DNS stop working MZH General 3 22nd February 2008 11:10
How to host own DNS Service in remote ISPConfig server? zenny Installation/Configuration 3 4th January 2007 15:15


All times are GMT +2. The time now is 09:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.