Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th March 2009, 02:29
kbdigital kbdigital is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default How to stop ISPconfig to write to postfix config files for a domain.

I have a domain that hosted in with us, however recently they want to use their own mail servers. I was able to config my DNS servers to read from a static config files and ignore the slave zone, so the MX record is working the way I want it to.

Is there anything I can do to stop ISPconfig from writing that domain hostname and users emails into the Postfix config files: local-host-names and virtusertable?
I tried to delete all the DNS settings in the control panel, but it seems ISPconfig did not remove from them from the database(i can see the entries from phpmyadmin) and kept writing the emails into the Postfix files.

Thank you.
Reply With Quote
Sponsored Links
  #2  
Old 17th March 2009, 10:11
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,033
Thanks: 261
Thanked 150 Times in 130 Posts
Default

Not sure if this will help, but you can set the domain to use an external mailserer.
To do so, go (in ISPconfig) to the domain > Options, and select "External Mailserver"
Make sure that you also do this for any "Co-domains" that you created for this domain!
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 17th March 2009, 17:57
kbdigital kbdigital is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thank you, edge

That did it for the subdomain.domain.com

However, I still have problem the main domain "domain.com", ISPconfig still writes "domain.com" to the Postfix's local-host-names which causes problems for the form2mail. Postfix delivers the email to the local account, instead forward it to the external mail server.

I can't see the "domain.com" anywhere in the co-domain tab or anywhere, however if i try to add the "domain.com" as a co-domain. ISPconfig tells me that "The name .domain.com is already in use by another site or domain." This is really strange.

Any ideas?

Thanks
Reply With Quote
  #4  
Old 17th March 2009, 18:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,488
Thanks: 813
Thanked 5,259 Times in 4,123 Posts
Default

Quote:
I can't see the "domain.com" anywhere in the co-domain tab or anywhere, however if i try to add the "domain.com" as a co-domain. ISPconfig tells me that "The name .domain.com is already in use by another site or domain." This is really strange.
Then the domain is either assigned to another site or it is in the recyle bin. Check all sites and empty all recycle bin's.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th March 2009, 20:10
kbdigital kbdigital is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Thanks till,

I did go through ALL to make sure that the "domain.com" is not assigned to any users/sites.

Yes, I did empty the Recycle bin too.

I use phpmyadmin and it looks like the "domain.com" is in the database and assigned to the correct user. It just does not show up in the ISPconfig tab. I can manually remove the entry but I don't know if it will cause any problem, will it?

Thanks
Reply With Quote
  #6  
Old 20th March 2009, 00:29
kbdigital kbdigital is offline
Junior Member
 
Join Date: Jun 2008
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Just want to update so it may help others.

I had to use phpmyadmin to delete the "stuck" entries in the database.
The two tables that had the offending entries were "dns_a" and "isp_isp_domain".

I don't know if it's a proper way to fix it, but it works.

Thank you.
Reply With Quote
The Following User Says Thank You to kbdigital For This Useful Post:
falko (20th March 2009)
  #7  
Old 24th March 2010, 21:20
rwijngaa rwijngaa is offline
Junior Member
 
Join Date: Jul 2009
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default Mailserver set on external but still problems

Hi all,

I host several domains on one machine (1 ip-address) and have one domain that hosts it's own mailserver so i set the Mailserver of this domain (no co-domain present) to "External Mailserver", but once in a while the domain name still gets written to /etc/postfix/local-host-names.

Anybody a clue?

(i use ispconfig 2.2.35)

Regards
Rino
Reply With Quote
  #8  
Old 26th March 2010, 02:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

So you have a web site www.example.com in ISPConfig, and you've checked "External Milserver" for www.example.com, and www.example.com is still listed /etc/postfix/local-host-names? Or is it just example.com (without www)?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 29th March 2010, 13:03
rwijngaa rwijngaa is offline
Junior Member
 
Join Date: Jul 2009
Posts: 7
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
So you have a web site www.example.com in ISPConfig, and you've checked "External Milserver" for www.example.com, and www.example.com is still listed /etc/postfix/local-host-names? Or is it just example.com (without www)?
Hi,

The account is without the www
Does this makes the difference?

Regards
Rino
Reply With Quote
  #10  
Old 29th March 2010, 13:56
Br8knitOFF Br8knitOFF is offline
Member
 
Join Date: Sep 2008
Posts: 35
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

I have a similar problem, except it continues to add the domain WITH the www host portion, thus causing all inbound mail to be rejected... very frustrating!

However, if I change the settings for the domain to point to an external mail server, then it does in fact wipe out any/all instances of the domain in the /etc/postfix/local-host-names file...

//Todd
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31
Default Postfix config for ISPConfig warlock Installation/Configuration 3 20th January 2009 20:08
Postfix config - virtual domain mapping problem spdavid Installation/Configuration 1 24th May 2008 12:49
Monit & Munin SamTzu HOWTO-Related Questions 1 4th May 2008 18:03
Prevent Apache config files from being overwritten ehsan Installation/Configuration 3 17th September 2007 10:52


All times are GMT +2. The time now is 21:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.