Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th March 2009, 20:56
Vcepelin Vcepelin is offline
Junior Member
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Fetcgmail problem

hi again
i was wondering how can i set my fetchmail
not to fetch all the mail
but the mail that is new
discarding the mail that was already been fetched
Reply With Quote
Sponsored Links
  #2  
Old 16th March 2009, 05:46
dipeshmehta dipeshmehta is offline
Senior Member
 
Join Date: Nov 2008
Location: Rajkot, India
Posts: 173
Thanks: 5
Thanked 12 Times in 12 Posts
Send a message via Yahoo to dipeshmehta Send a message via Skype™ to dipeshmehta
Default

you can use nofetchall option with poll.

Btw, it is the default option if nothing else like fetchall or keep is specified.

Dipesh
Reply With Quote
  #3  
Old 16th March 2009, 07:35
Vcepelin Vcepelin is offline
Junior Member
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok but can i use bot keep and nofetchall
Reply With Quote
  #4  
Old 16th March 2009, 09:33
dipeshmehta dipeshmehta is offline
Senior Member
 
Join Date: Nov 2008
Location: Rajkot, India
Posts: 173
Thanks: 5
Thanked 12 Times in 12 Posts
Send a message via Yahoo to dipeshmehta Send a message via Skype™ to dipeshmehta
Default

Quote:
Originally Posted by Vcepelin View Post
ok but can i use bot keep and nofetchall
yes ofcourse, you can use keep for not to delete messages from server, and alongwith you can use nofetchall to fetch only newer messages

for more details about options see man page, man pages are our friends in need
Reply With Quote
  #5  
Old 16th March 2009, 10:22
Vcepelin Vcepelin is offline
Junior Member
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

so i have a problem
i have the nofetchall parameter
but it stil fetches all the mail
(if i use the default settings without the nofetchall
parameter i stil fetches all)
im using pop3 as protocol
any ideas waht can i do ?
Reply With Quote
  #6  
Old 16th March 2009, 13:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in your fetchmailrc?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th March 2009, 14:37
Vcepelin Vcepelin is offline
Junior Member
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

poll mail.example.com
proto pop3
user "myuser@mydomain.com"
pass "password"
is myuser
keep

that's it ...
Reply With Quote
  #8  
Old 18th March 2009, 18:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Add nofetchall to it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 19th March 2009, 11:56
Vcepelin Vcepelin is offline
Junior Member
 
Join Date: Feb 2009
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default

it still fetches all the mail ...
Reply With Quote
  #10  
Old 20th March 2009, 13:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Did you restart fetchmail?

What's the output of
Code:
updatedb
locate fetchmailrc
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
Postfix+MySQL Problem jasutton Installation/Configuration 1 15th June 2006 16:06


All times are GMT +2. The time now is 11:50.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.