#1  
Old 15th March 2009, 03:07
filch filch is offline
Member
 
Join Date: Jul 2008
Posts: 43
Thanks: 1
Thanked 0 Times in 0 Posts
Default phpmyadmin error

Hi,

I have installed phpmyadmin and in the Interface config I have selected " Link to phpmyadmin in DB list". However, when I create a database and then click on the link to phpmyadmin, I get the following:

Forbidden

You don't have permission to access /phpmyadmin on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.

phpmyadmin is installed in /usr/share and proper aliases are in /etc/httpd/conf.d/phpmyadmin.conf

Any ideas on what might be wrong here. I assume it is a permissions thing. Currently /usr/share/phpmyadmin permissions are:

drwxr-xr-x 10 apache apache 4096 Feb 14 14:07 phpmyadmin

All help is very much appreciated.


Dave
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2009, 09:25
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,002 Times in 3,911 Posts
Default

1) Which ISPConfig version?
2) Which Linux distribution?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 15th March 2009, 20:52
filch filch is offline
Member
 
Join Date: Jul 2008
Posts: 43
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
1) Which ISPConfig version?
2) Which Linux distribution?
Sorry ... I usually do not forget this info. It is version 3.0.0.9 and CentOS 5.2

Thanks

Dave
Reply With Quote
  #4  
Old 15th March 2009, 20:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,002 Times in 3,911 Posts
Default

This is a known problem in centos and fedora (see bugtracker), there is no solution for that yet as aliases can not be used the way it is done in centos on a hosting server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 15th March 2009, 21:05
filch filch is offline
Member
 
Join Date: Jul 2008
Posts: 43
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Well that's too bad. The funny thing is that I still should be able to add the aliases to the httpd.conf and thereby allowing all the domains to access only their databases but not matter what I do I am always getting this permission denied thing.

Dave
Reply With Quote
  #6  
Old 15th March 2009, 21:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,002 Times in 3,911 Posts
Default

Aliases wont work, thats the core of the problem. Centos installs phpmyadmin in the wrong place, the installation place for phpmyadmin is not compatible with the suexec path that is compiled into the apache server from centos.

The following solutions will work, but are not really the optimum:

1) You create a website like phpmyadmin.yourdoamin.com and install a copy of phpmyadmin into that website. then you are able to access phpmyadmin trough the domain of this website, e.g. phpmyadmin.yourdomain.com

2) Another solution is that you make a symlink named /usr/local/ispconfig/interface/web/phpmyadmin to the installation directory of phpmyadmin. Then you will be able to access phpmyadmin trogh yourdomain.com:8080/phpmyadmin
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 15th March 2009, 23:03
qriz qriz is offline
Member
 
Join Date: Jan 2009
Location: Daytona Beach - Florida
Posts: 32
Thanks: 7
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post

The following solutions will work, but are not really the optimum:

1) You create a website like phpmyadmin.yourdoamin.com and install a copy of phpmyadmin into that website. then you are able to access phpmyadmin trough the domain of this website, e.g. phpmyadmin.yourdomain.com

2) Another solution is that you make a symlink named /usr/local/ispconfig/interface/web/phpmyadmin to the installation directory of phpmyadmin. Then you will be able to access phpmyadmin trogh yourdomain.com:8080/phpmyadmin

i tried the second like that:
$ ln -s /usr/local/ispconfig/interface/web/phpmyadmin /usr/share/phpmyadmin

didn't work it gives me 403 Permission denied

I got Debian Lenny and 3.0.0.9
and if i try Webmail or link zu phpmyadmin
i get 404 Site not found ( from client 3 Drupal installation ) ???

any ideas?
thx
Reply With Quote
  #8  
Old 15th March 2009, 23:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,002 Times in 3,911 Posts
Default

This works only if you run mod_php and not php as fcgi, it will not work with fcgi as it fails then for the same reason then the centos default setting fails.

Quote:
I got Debian Lenny and 3.0.0.9
and if i try Webmail or link zu phpmyadmin
On Debian you dont have to do anything, just install it as decribed in the perfect setup guide for ispconfig 3 and it works. I just installed it today.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 20th March 2009, 20:06
qriz qriz is offline
Member
 
Join Date: Jan 2009
Location: Daytona Beach - Florida
Posts: 32
Thanks: 7
Thanked 1 Time in 1 Post
Default I tried but ... :-(

Quote:
Originally Posted by till View Post
This works only if you run mod_php and not php as fcgi, it will not work with fcgi as it fails then for the same reason then the centos default setting fails.




On Debian you dont have to do anything, just install it as decribed in the perfect setup guide for ispconfig 3 and it works. I just installed it today.
1)

if i run mod-php i get error 500 if i run any other php i get page not found

i got also a problem to get mysqldumper to work with the databases

i got 7 Sites running and don't know how to back them up or transfer them into a new ispconfig installation.

ftp and sftp are working but crashing a lot


2) Then i tried to virtualize the whole thing in virtualbox (on a different computer) before reinstall again but stumbled in to network problems and couldn't get host and guest working properly. there is a lot of configuration tips out there but nothing like a perfect server guide what works smooth

So does any body know a working guide or can alter the perfect server on how to install a virtualized ispconfig ???
Reply With Quote
  #10  
Old 21st March 2009, 21:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,900
Thanked 2,702 Times in 2,545 Posts
 
Default

A guest in VirtualBox is not different from a physical machine regarding ISPConfig.

Quote:
if i run mod-php i get error 500 if i run any other php i get page not found
What's in the Apache error log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
LB1 Not Taking Over Shared IP Using Heartbeat 2.1.3 On FC10 64Bit asyadiqin Installation/Configuration 5 11th February 2009 20:11
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42
Frustrated with ISPConfig install! woozyerdaddee Installation/Configuration 4 19th May 2006 03:38
Installation Fails... :( cyberstorm Installation/Configuration 1 15th January 2006 18:07
Install stop at uuwish, UUDeview SeaWolf Installation/Configuration 6 4th October 2005 23:53


All times are GMT +2. The time now is 21:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.