#1  
Old 13th March 2009, 15:29
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Exclamation myDNS Template Bug

I tried manually creating a Zone, then added the proper records but it doesn't seem to work properly. When you create a manual Zone, there is only one 'NS' field so you cannot add a second NS to that Zone.

So i went about and noticed that when you create a DNS Template, you have 2 fields for the NS. Once I add the Template, then fill it out through the 'Wizard', it will not add or save the new DNS Zone. I click on 'Create DNS Record' but it just sits there and doesn't even load.

Is there away I can manually add a secondary NS when creating a manual Zone? Or any other way around this?

(Running the latest SVN for ISPCONFIG 3).

Any ideas or anyone else experiencing this issue?
Reply With Quote
Sponsored Links
  #2  
Old 13th March 2009, 18:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

You mix up the ns field with the ns records of the domain. The nameservers of a domain have to be added as ns records. Create a domain with the wizard and take a look at the records that were added for this domain to see a full example.

The DNS wizrad has no known bugs, I just tested it. If you created your own template and this does not work then there is most likely a typo in your template syntax. try to use the default template delivered with ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th March 2009, 20:29
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

I have manually set up a Zone and added the proper records as follows:






It doesn't seem to be working properly though.

Here is what it looks like when I 'dig' the domain:

Code:
; <<>> DiG 9.4.2-P2 <<>> ps3edition.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 43165
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;ps3edition.com.                        IN      A

;; AUTHORITY SECTION:
ps3edition.com.         10800   IN      SOA     ns1.iwebsource.net. admin.iwebsource.net. 2009031320 28800 7200 604800 86400

;; Query time: 48 msec
;; SERVER: 192.168.2.1#53(192.168.2.1)
;; WHEN: Fri Mar 13 15:22:15 2009
;; MSG SIZE  rcvd: 92

Here is my NSLOOKUP for the domain:

Quote:
User@Server:~# nslookup ps3edition.com
Server: 192.168.2.1
Address: 192.168.2.1#53

Non-authoritative answer:
*** Can't find ps3edition.com: No answer

What am I suppose to have in my resolv.conf?
Should I be using my Servers internal IP for the A Record?
Any ideas what might be going on?
Reply With Quote
  #4  
Old 13th March 2009, 22:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

You missed to add the dot at the end of the records.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 13th March 2009, 22:33
edge edge is online now
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,042
Thanks: 269
Thanked 154 Times in 133 Posts
Default

Quote:
Originally Posted by till View Post
You missed to add the dot at the end of the records.
Till. I think we should get somekind of validation script for this.
If no dot is added, add the dot automaticaly.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #6  
Old 13th March 2009, 23:01
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

Quote:
Originally Posted by edge View Post
Till. I think we should get somekind of validation script for this.
If no dot is added, add the dot automaticaly.
We can not add a dot automatically as records without dot are valid as well.

For example, the following A records give the same result:

mail

and

mail.domain.com.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 13th March 2009, 23:10
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
Question

Thanks for the help guys.
I apologize for my ignorance with setting up the DNS. I have a very knowledge of everything else but the DNS, this is the first time I am actually trying to get it working.

I have added the dots '.' to the end of each record but still no difference.
Question, after making the changes in ISPCONFIG, I shouldn't have to wait 24 - 48 hours right?

Here is what I currently have:


The NSLOOKUP is still giving me this error for ps3edition.com:
Code:
user@server:~# nslookup ps3edition.com
Server:		192.168.2.1
Address:	192.168.2.1#53

Non-authoritative answer:
*** Can't find ps3edition.com: No answer
Funny this is that when I do an NSLOOKUP for www.ps3edition.com, it appears to be correct:
Code:
user@serverr:~# nslookup www.ps3edition.com
Server:		192.168.2.1
Address:	192.168.2.1#53

Non-authoritative answer:
Name:	www.ps3edition.com
Address: 24.222.43.170
Oh, to add, I get an Answer when I dig www.ps3edition.com but not when I dig pd3edition.com.


Any ideas why?

Can you access www.ps3edition.com?
(I'm within the network so I cannot tell at the moment)


Last edited by astewart; 13th March 2009 at 23:16.
Reply With Quote
  #8  
Old 13th March 2009, 23:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,804
Thanks: 840
Thanked 5,614 Times in 4,425 Posts
Default

If you use nslookup like you did to query the dns server you might have to wait 24 hours. If you want to test your server right now you will have to run:

Code:
dig @localhost www.ps3edition.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 14th March 2009, 19:08
Antennipasi Antennipasi is offline
ISPConfig Developer
 
Join Date: Dec 2008
Location: Finland
Posts: 67
Thanks: 6
Thanked 13 Times in 12 Posts
Default

i ques that confuse here is bit more lowlevel what it seems at first.
from firs post i see Ispconfig's hostname is ubuntuServer.isometric.com, but all references to nameserver points to *.iwebsource.net.

could it be that *.iwebsource.net-servers are your service providers nameservers?
if so, you are trying to control nameservers that are not yours. obviously it is not going to work.

if you have access to somekind of control panel in iwebsource.net or in your domain registrant, you can handle dns from there and forget Ispconfig's dns-part.

or, start using ubuntuServer.isometric.com as NS, and instal another nameserver to somewhere. if you go this way, change domains nameservers from registrant to your ones.
Reply With Quote
  #10  
Old 15th March 2009, 21:05
astewart astewart is offline
Member
 
Join Date: Feb 2007
Posts: 95
Thanks: 1
Thanked 7 Times in 7 Posts
 
Smile

ubuntuServer.isometric.com is the fully qualified Server name.
iWebsource would be the main Domain.

The DNS is now working properly, I just had to give it some time I guess to propagate.

Thanks for all your help guys.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS startup failed gcambull General 13 6th July 2010 16:59
myDns database bug gkoo Developers' Forum 2 11th March 2009 17:29
mydns settings/help believo General 1 26th January 2009 13:49
MyDNS (Master) -> Bind (Slave) Support todgerme General 4 4th September 2007 15:45
Where do MyDNS logs go? voipfc General 3 28th November 2006 17:03


All times are GMT +2. The time now is 09:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.