#1  
Old 8th March 2009, 01:14
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default SSL site fails to load

The website https://melaniejessseminars.com/ has SSL enabled and an SSL key installed. However, Firefox and I.E. cannot load the SSL side of the website. SSL is enabled for the website.

Code:
Failed to Connect

Firefox can't establish a connection to the server at melaniejessseminars.com.

Though the site seems valid, the browser was unable to establish a connection.

    * Could the site be temporarily unavailable? Try again later.
    * Are you unable to browse other sites?  Check the computer's network connection.
    * Is your computer or network protected by a firewall or proxy? Incorrect settings can interfere with Web browsing.

The key seems to be installed correctly, the SSL directory of WEB50 has the following:
Code:
[dingle@its ssl]# ls -lah
total 24K
drwxr-xr-x 2 web50_melftp web50 4.0K Mar  7 17:13 .
drwxr-xr-x 8 web50_melftp web50 4.0K Mar  7 18:54 ..
-r-------- 1 root         root     0 Apr 23  2007 .no_delete
-rw-r--r-- 1 root         root  1002 Mar  7 18:54 www.melaniejessseminars.com.crt
-rw-r--r-- 1 root         root   769 Mar  7 17:13 www.melaniejessseminars.com.csr
-r-------- 1 root         root   887 Mar  7 17:13 www.melaniejessseminars.com.key
-rw-r--r-- 1 root         root   951 Mar  7 17:13 www.melaniejessseminars.com.key.org
NETSTAT output is as follows:
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address               Foreign Address             State       PID/Program name            
tcp        0      0 *:mysql                     *:*                         LISTEN      17833/mysqld        
tcp        0      0 *:netbios-ssn               *:*                         LISTEN      31554/smbd                    
tcp        0      0 *:ndmp                      *:*                         LISTEN      27298/perl            
tcp        0      0 *:hosts2-ns                 *:*                         LISTEN      18009/ispconfig_htt 
tcp        0      0 *:ftp                       *:*                         LISTEN      18174/proftpd: (acc 
tcp        0      0 mail.intrac.net:domain      *:*                         LISTEN      18152/named         
tcp        0      0 mail.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its7.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its6.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its5.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its4.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its3.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its2.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its1.derekgordon.com:domain *:*                         LISTEN      18152/named         
tcp        0      0 its.derekgordon.com:domain  *:*                         LISTEN      18152/named         
tcp        0      0 localhost.localdomai:domain *:*                         LISTEN      18152/named         
tcp        0      0 its4.derekgordon.com:ica    *:*                         LISTEN      7039/(squid)        
tcp        0      0 mail.derekg:afs3-fileserver *:*                         LISTEN      3001/ircd           
tcp        0      0 localhost.localdomain:rndc  *:*                         LISTEN      18152/named         
tcp        0      0 *:smtp                      *:*                         LISTEN      18106/master                         
tcp        0      1 its4.derekgordon.com:smtp   c-68-42-34-94.hsd1.nm.:2372 FIN_WAIT1   -                         
tcp        0      0 mail.derekgordon.com:46472  mail.derekgordon.com:irdmi  ESTABLISHED 21391/perl          
tcp        0      0 *:imaps                     *:*                         LISTEN      16738/dovecot       
tcp        0      0 *:pop3s                     *:*                         LISTEN      16738/dovecot       
tcp        0      0 *:pop3                      *:*                         LISTEN      16738/dovecot       
tcp        0      0 *:imap                      *:*                         LISTEN      16738/dovecot       
tcp        0      0 *:http                      *:*                         LISTEN      18032/httpd         
tcp        0      0 *:ssh                       *:*                         LISTEN      2074/sshd           
tcp        0      0 localhost6.localdomain:rndc *:*                         LISTEN      18152/named
Any help would be appreciated. I did follow the step-by-step manual and went through a couple of forum posts to see if it could be solved, no luck..

Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 8th March 2009, 01:19
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

UPDATE: I added Listen 443 to APACHE's httpd.conf and now I get a new error.

Code:
Secure Connection Failed
An error occurred during a connection to melaniejessseminars.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)
The page you are trying to view can not be shown because the authenticity of the received data could not be verified.

    * Please contact the web site owners to inform them of this problem.
Any thoughts?
Reply With Quote
  #3  
Old 8th March 2009, 16:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Which distribution are you using?

Please make sure that there's just one SSL vhost per IP address on your server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 8th March 2009, 17:39
crypted crypted is offline
Senior Member
 
Join Date: Dec 2006
Location: Oklahoma, USA
Posts: 429
Thanks: 3
Thanked 14 Times in 6 Posts
Default

CentOS 5.2 and this is the only SSL site that I'm aware of.

I verified that no sites use SSL but this one. Also, after removing the SSL CERT the same error code is presented even without SSL data available.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)

---

After removing and reinstalling SSL on that domain, the VHOSTS file no longer has SSL listed under that domain.

Last edited by crypted; 8th March 2009 at 21:31.
Reply With Quote
  #5  
Old 9th March 2009, 08:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,395
Thanks: 833
Thanked 5,490 Times in 4,322 Posts
 
Default

The SSL cert is broken. Please recreate the SSL cert in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting up a customer SSL site catdude General 3 24th January 2008 18:34
SSL for virtual hosts on one certificate rbartz Tips/Tricks/Mods 8 20th November 2007 17:59
Site SSL not working cic Installation/Configuration 6 16th October 2007 18:01
SSL Issue - Unable to connect to any site Menzor Installation/Configuration 4 27th May 2007 04:03
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29


All times are GMT +2. The time now is 05:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.