Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th August 2005, 02:14
jnoble jnoble is offline
Junior Member
 
Join Date: Aug 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default apache oddity 2.0.7

Hello, First off, Great job all!!

second, my httpd is not serving anything except the default test page for fedora3, I have one reseller, one client, and one site.


These are the errors I am seeing, I have tried all kinds of permission tricks, and no help


16.08.2005 - 17:05:46 => WARN - WARNING: could not open file /etc/httpd/vhosts/Vhosts_ispconfig.conf
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1182: WARNING: could not cp -fr /etc/httpd/vhosts/Vhosts_ispconfig.conf /etc/httpd/vhosts/Vhosts_ispconfig.conf~
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2328: WARNING: could not httpd -t &> /dev/null
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2334: httpd syntax seems to contain errors, reloading with old configuration
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2336: WARNING: could not mv -f /etc/httpd/vhosts/Vhosts_ispconfig.conf~ /etc/httpd/vhosts/Vhosts_ispconfig.conf

____________________

at the end of the install, I see these msgs, probabaly the root of above:

Connected successfully to MySQL server
cp: omitting directory `/'

Warning: fopen(/): failed to open stream: Is a directory in /root/james/install_ ispconfig/install.php on line 110

Warning: fwrite(): supplied argument is not a valid stream resource in /root/jam es/install_ispconfig/install.php on line 111

Warning: fclose(): supplied argument is not a valid stream resource in /root/jam es/install_ispconfig/install.php on line 112
Restarting some services...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
FreshClam is already running!
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.

--------

I had 2.0.7 and installed 2.0.8 over it, the end result of these errors is that my vhosts are not being written, nor accessed. anyone want to share a clue or two? I have been looking through the forums,and they have solved a few other issues so far, but I did not find this one.

Thanks In Advance
James
Reply With Quote
Sponsored Links
  #2  
Old 17th August 2005, 10:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by jnoble
16.08.2005 - 17:05:46 => WARN - WARNING: could not open file /etc/httpd/vhosts/Vhosts_ispconfig.conf
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 1182: WARNING: could not cp -fr /etc/httpd/vhosts/Vhosts_ispconfig.conf /etc/httpd/vhosts/Vhosts_ispconfig.conf~
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2328: WARNING: could not httpd -t &> /dev/null
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2334: httpd syntax seems to contain errors, reloading with old configuration
16.08.2005 - 17:05:47 => WARN - /root/ispconfig/scripts/lib/config.lib.php, Line 2336: WARNING: could not mv -f /etc/httpd/vhosts/Vhosts_ispconfig.conf~ /etc/httpd/vhosts/Vhosts_ispconfig.conf
Does /etc/httpd/vhosts/Vhosts_ispconfig.conf exist?

Quote:
I had 2.0.7 and installed 2.0.8 over it, the end result of these errors is that my vhosts are not being written, nor accessed.
You mean you had 2.0.6 and installed 2.0.7 over it. Was 2.0.6 working for you?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th August 2005, 11:47
domino domino is offline
Senior Member
 
Join Date: Aug 2005
Posts: 364
Thanks: 0
Thanked 8 Times in 7 Posts
Default

I didn't get an email notice that 2.08 was released already . Anyway, my upgrade from 2.06 to 2.07 was flawless. Just a heads up.
Reply With Quote
  #4  
Old 17th August 2005, 19:42
jnoble jnoble is offline
Junior Member
 
Join Date: Aug 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default getting better

Hello, I was doing a fresh install of 2.0.7 and got the email about 2.0.8, so went straight to it. 2.0.7 was not working properly, most of which were fixed after upgrading.

Im a little confused about how the Vhosts are supposed to be called. I thought there would be an include line in httpd.conf, but there is not one, and if I add one pointing to either
/vhosts/Vhosts_ispconfig.conf
or
/etc/httpd/vhosts/Vhosts_ispconfig.conf

it gives an error:

Code:
Starting httpd: Warning: DocumentRoot [/home/www/web3/web] does not exist
Warning: DocumentRoot [/home/www/web5/web] does not exist
                                                           [FAILED]
[root@server1 ~]# ls -la /home/www/web3/web
total 40
drwxrwxr-x  4 web3_sysop web3 4096 Aug 17 04:00 .
drwxr-xr-x  8 web3_sysop web3 4096 Aug 17 04:00 ..
drwxrwxr-x  2 web3_sysop web3 4096 Aug 16 12:38 error
-rw-rw-r--  1 web3_sysop web3 1214 Aug 16 12:40 index.html
drwxr-xr-x  2 web3_sysop web3 4096 Aug 17 04:00 stats
[root@server1 ~]# ls -la /home/www/web5/web
total 48
drwxrwxr-x  4 root web5 4096 Aug 17 04:00 .
drwxr-xr-x  8 root web5 4096 Aug 17 04:00 ..
drwxrwxr-x  2 root web5 4096 Aug 16 14:02 error
-rw-r--r--  1 root web5 1212 Aug 16 15:31 index.htm
-rw-rw-r--  1 root web5 1212 Aug 17 10:13 index.html
drwxr-xr-x  2 root web5 4096 Aug 17 04:00 stats
[root@server1 ~]#
There is def something wrong in permissions, but what is it?

Thanks
James
Reply With Quote
  #5  
Old 18th August 2005, 00:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
I thought there would be an include line in httpd.conf, but there is not one,
It can also be in apache.conf, apache2.conf, ..., the file mentioned when you run
Code:
httpd -V
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 18th August 2005, 18:54
jnoble jnoble is offline
Junior Member
 
Join Date: Aug 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Default still odd bahavior install/apache

Hello, and thanks again.

I reinstalled fedora3 (as per guide) and installed ISPconfig (as per guide) after updating the zlib to the one from fedora4 the install seemed to go good, however, I did see these errors at the end again.

Quote:
cp: omitting directory `/'

Warning: fopen(/): failed to open stream: Is a directory in /root/install_ispconfig/install.php on line 110

Warning: fwrite(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 111

Warning: fclose(): supplied argument is not a valid stream resource in /root/install_ispconfig/install.php on line 112
Restarting some services...
Im not having the skill to track those down right away, anyone seen them on Fedora3?

my httpd.conf appears to be just this one now:

/etc/httpd/conf/httpd.conf

It does not have an include at the end, nor does it look to have been modified.

httpd -V gives me this:

Quote:
Server version: Apache/2.0.53
Server built: Jul 26 2005 11:08:48
Server's Module Magic Number: 20020903:9
Architecture: 32-bit
Server compiled with....
-D APACHE_MPM_DIR="server/mpm/prefork"
-D APR_HAS_SENDFILE
-D APR_HAS_MMAP
-D APR_HAVE_IPV6 (IPv4-mapped addresses enabled)
-D APR_USE_SYSVSEM_SERIALIZE
-D APR_USE_PTHREAD_SERIALIZE
-D SINGLE_LISTEN_UNSERIALIZED_ACCEPT
-D APR_HAS_OTHER_CHILD
-D AP_HAVE_RELIABLE_PIPED_LOGS
-D HTTPD_ROOT="/etc/httpd"
-D SUEXEC_BIN="/usr/sbin/suexec"
-D DEFAULT_PIDLOG="logs/httpd.pid"
-D DEFAULT_SCOREBOARD="logs/apache_runtime_status"
-D DEFAULT_LOCKFILE="logs/accept.lock"
-D DEFAULT_ERRORLOG="logs/error_log"
-D AP_TYPES_CONFIG_FILE="conf/mime.types"
-D SERVER_CONFIG_FILE="conf/httpd.conf"


I have a copy of the server for backup (in vmware format) and am going to try fedora4 on the actual server today.

Any one that can help, Id appriciate it.
Reply With Quote
  #7  
Old 18th August 2005, 20:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Have a look here:
http://www.howtoforge.com/forums/sho...37&postcount=2
and
http://www.howtoforge.com/forums/sho...42&postcount=3
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 18th August 2005, 23:59
jnoble jnoble is offline
Junior Member
 
Join Date: Aug 2005
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default resolved - sorta

Hello, I moved to Fedora 4 and the install seems to have worked fine, im testing functions, and will let you all know in a new thread.

Thanks

James
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Quick Question(s) Apache 2 linutzy Technical 19 16th August 2006 16:20
apache user/group won't create directory weedguy Installation/Configuration 6 19th September 2005 23:40
Apache log question arcejorge General 1 29th July 2005 09:43
Apache from source on SuSE 9 Brenton Server Operation 1 25th July 2005 18:40
Apache + PHP lola Server Operation 1 25th April 2005 13:41


All times are GMT +2. The time now is 07:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.