Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th March 2006, 15:59
cccc cccc is offline
Junior Member
 
Join Date: Mar 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default iptables: Table does not exist (do you need to insmod?)

hi

I've installed shorewall firewall on debian sarge stable and I get the following:
Code:
# shorewall show capabilities
Shorewall-2.2.3 Chain capabilities at ext.undostres.ch - Sam Mr 18 15:46:57 CET 2006

Counters reset Sat Mar 18 14:55:30 CET 2006

iptables: Table does not exist (do you need to insmod?)
Code:
# iptables -V
iptables v1.2.11
Code:
# uname -a
Linux mysystem 2.6.8-2-686 #1 Tue Aug 16 13:22:48 UTC 2005 i686 GNU/Linux
depmod -a seems not to help.

what's missing and howto solve this problem ?
Reply With Quote
Sponsored Links
  #2  
Old 18th March 2006, 22:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Run
Code:
modprobe ip_tables
and add ip_tables at the end of /etc/modules.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 16th August 2007, 12:27
seblo seblo is offline
Junior Member
 
Join Date: Aug 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I also do have the same problem:

# iptables -L
iptables v1.3.8: can't initialize iptables table `filter': Table does not exist (do you need to insmod?)
Perhaps iptables or your kernel needs to be upgraded.

but when trying to do "modprobe ip_tables"

ha1:/home/slorandel # modprobe ip_tables
FATAL: Module ip_tables not found

I tried to modify the kernel configuration through "make menuconfig" but I always get the error, does somebody has other idea?

thanks, Sebastien.
Reply With Quote
  #4  
Old 17th August 2007, 16:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
grep -i iptables /boot/config-`uname -r`
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 21st August 2007, 10:46
seblo seblo is offline
Junior Member
 
Join Date: Aug 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
What's the output of
Code:

grep -i iptables /boot/config-`uname -r`

?
here it is:

Code:
# grep -i iptables /boot/config-`uname -r`
CONFIG_IP_NF_IPTABLES=y
CONFIG_IP6_NF_IPTABLES=y
Reply With Quote
  #6  
Old 22nd August 2007, 18:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

iptables is built into the kernel, so that should not be the problem.

I think you should also enable all the other iptables options in
Code:
make menuconfig
and compile a new kernel.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 23rd August 2007, 10:13
seblo seblo is offline
Junior Member
 
Join Date: Aug 2007
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Actually, it seems that my problem came from iptables installation and not from the kernel but I am not really sure, I reinstalled iptables with the following commands:

Code:
make KERNEL_DIR=/usr/src/linux
make install KERNEL_DIR=/usr/src/linux
then I recompiled my kernek with:

Code:
make dep
make bzIamge
make
make install
make modules
now it is working, thank you for your help
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
phpmyadmin configuration problem pushembekar Installation/Configuration 8 9th March 2006 21:48
websites outside ISPConfig guidovanh Installation/Configuration 13 7th March 2006 22:56
open ports rayit General 6 18th January 2006 14:23
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
/stats doesn't work (password not accepted) Hellbound General 6 15th September 2005 15:34


All times are GMT +2. The time now is 09:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.