Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st March 2009, 19:02
sizzlefire sizzlefire is offline
Junior Member
 
Join Date: Mar 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default MyDNS cannot connect to database

Hello, I followed the guide located on ISPconfig.com to install ISPconfig, however for some reason when I type the command to start or stop myDNS, i get the follwoing error:

Code:
robert@robert-laptop:~$ /etc/init.d/mydns start
Starting DNS server: mydnsmydns[31769]: error loading gid for group `nobody'
mydns[31769]: using gid 65534 from user `nobody'
mydns[31769]: Error connecting to MySQL server at localhost: Access denied for user 'username'@'localhost' (using password: YES) (errno=0)
robert@robert-laptop:~$
The strange thing is, if I edit /etc/init.d/mydns.conf, it does not reflect in the error message.

Can someone please help me figure out what I'm doing wrong.
Reply With Quote
Sponsored Links
  #2  
Old 1st March 2009, 19:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please install ISPConfig before you start mydns as mydns is not configured before ispconfig is installed.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st March 2009, 19:25
sizzlefire sizzlefire is offline
Junior Member
 
Join Date: Mar 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have installed mydns then i have installed ispconfig.

ISPconfig is already setup and running...

But the myDNS isnt working and i get that error. I have tryed to edit the config, and it does not work.
Reply With Quote
  #4  
Old 1st March 2009, 19:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Which linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 1st March 2009, 19:46
sizzlefire sizzlefire is offline
Junior Member
 
Join Date: Mar 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I am currently using Ubuntu 8.10
Reply With Quote
  #6  
Old 2nd March 2009, 12:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
 
Default

Quote:
I have tryed to edit the config, and it does not work.
The config does not has to be edited manually, it is written by the installer.

1) Download the latest ispconfig 2 release and unpack it.
2) run the uninstall.php script which is in the install folder.
3) Mkae sure that the ispconfig mysql database is deleted.
4) Reinstall ispconfig, make sure that you use the mysql root user to install it and no other mysql user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mail Question: installed smf forum on centos perfect server setup with ispconfig happz Installation/Configuration 7 22nd August 2008 13:15
Getting e-mail working hansoffate Installation/Configuration 29 13th August 2008 16:33
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
Perfect Xen 3.0 setup for Debian gurneyzap HOWTO-Related Questions 4 26th March 2006 11:30


All times are GMT +2. The time now is 20:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.