#1  
Old 18th March 2006, 15:18
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Question proftpd login problem with list

Hi,

when i or a user log in with the ftp password, proftpd takes a while to show the directories. The login hangs on the "List" command. There is a little break up to 1 second. But there is no regularity in it. Sometimes the login process is very fast.

I googled and tryed the command "DelayEngine = off", but after restart nothing is better.

Whats the problem and how to solve it ?

greetings cirox
Reply With Quote
Sponsored Links
  #2  
Old 19th March 2006, 00:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Have you tried both active and passive mode in your ftp client?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th March 2006, 00:28
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi,

yes of course. Thats what i tried, too:

I add the following lines and restart the ftp server

/etc/proftpd.conf:

<global>
IdentLookups off
DelayEngine off
</global>

thats right ?, because there was no global section .....

but no change in the speed of directory listing.

greetings cirox

Last edited by Cirox; 19th March 2006 at 01:12.
Reply With Quote
  #4  
Old 19th March 2006, 01:12
Cirox Cirox is offline
Member
 
Join Date: Mar 2006
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Hi,

problem solved ....

i simply add this at /etc/proftpd.conf and restarted the server ;-) after changing the servername in /ets/hostname from srv.example.com to srv.

UseReverseDNS off

and everything works like a harm. But i takes 12 h to find out for me. At the other site /etc/hostname /hostname /etc/resolv.conf have to have the right dns settings just like bind9.

greetings cirox
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Speed up Proftpd login for all users linuxfast Tips/Tricks/Mods 12 13th February 2007 20:55
Details on problem /mailuser login and more (long) linutzy Installation/Configuration 11 15th February 2006 19:45
Totally Confused?? :( kingtux Installation/Configuration 7 9th February 2006 23:14
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 19:11
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 18:28


All times are GMT +2. The time now is 04:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.