Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st July 2011, 14:34
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default AWStats - Shows only one month

How can I change it? I lost June, I can only see stats por Jul today... I need to keep and show always the 6 last month, where can I set it?

Thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 1st July 2011, 15:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Which ispconfig version?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 1st July 2011, 16:10
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

ISPConfig 3.0.3.3, Debian
Reply With Quote
  #4  
Old 4th July 2011, 13:38
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

I can't make it show more than the current month... I added AllowFullYearView=3 in domain conf file, but it was replaced by ispconfig... I will check if something happens tonight modifing it in awstats.conf.
Reply With Quote
  #5  
Old 4th July 2011, 16:03
ch_jacobsen ch_jacobsen is offline
Junior Member
 
Join Date: Mar 2011
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Default

I was testing this solution:

1. Enable CGI
2. create symlink in your stats folder to /usr/lib/cgi-bin/awstats.pl
3. Visit http://your-domain/stats/awstats.pl
Reply With Quote
The Following User Says Thank You to ch_jacobsen For This Useful Post:
erosbk (4th July 2011)
  #6  
Old 4th July 2011, 16:33
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Didn't work, I get access to download awstats.pl as a file (I set site to use CGI instead Fast-CGI+SuEXEC, same happens)

I think that CGI will use proc time is a user request statistics accessing awstats.pl. I think that the solution could be to keep the old statistics generated in every month change, and give access to them.

Till, could this be a possible feature to add? or it is already implemented and it is not working for me? statistics for just current month is not what users want I think, they want to see historic data.
Reply With Quote
  #7  
Old 4th July 2011, 17:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

As far as I know, keeping statistics for older months should work in ISPConfig 3.0.3.3. There was a bug in a older version which has been fixed. Or do you use a version from SVN, so the version number displayed might be incorrect?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 4th July 2011, 22:38
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Nop, I am using the last version of ispconfig. Downloaded from:
wget http://www.ispconfig.org/downloads/I...-stable.tar.gz

Almost 40 days ago in a clean Debian install. Is is only calculating current month, older files are being deleted. Is there a way to check the code?
Reply With Quote
  #9  
Old 5th July 2011, 16:09
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
Default

Are awstats working for someone showing more than current month? I have historic month bw use, but I can't see stats for older months (day by day, links, etc.)

Please help! my clients hates webalizer xD
Reply With Quote
  #10  
Old 7th July 2011, 16:39
erosbk erosbk is offline
Senior Member
 
Join Date: Mar 2011
Posts: 337
Thanks: 49
Thanked 36 Times in 30 Posts
 
Default

Till, is there something I can check for this? do I have to update/reinstall? could you help me please? I will be opening to public July 18, and I really want to offer this statistics =)

Thank you, and sorry for bother you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HOWTO: Run AWStats from the Command Line linus3x Tips/Tricks/Mods 1 22nd October 2010 22:54
Need help setting up or accessing AWStats on 3.0.2 please jwlinux Installation/Configuration 2 17th April 2010 16:38
Awstats config problem Paladinemishakal HOWTO-Related Questions 1 13th February 2009 13:38
Ispconfig + awstats on debian etch Dennis Installation/Configuration 1 19th April 2008 22:57
Suse Ispconfig and AWstats shajazzi Installation/Configuration 4 15th May 2006 23:04


All times are GMT +2. The time now is 12:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.