#1  
Old 14th August 2005, 16:47
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default Postfix set-up

Can anyone point me to a HowTo for setting up postfix after install?

I prowled around the forum enough to discover some files such as postfix's main.cf, virtualusertable, and local-host-names.

main.cf has everything commented out and does not mention my domain name or anything else. virtualusertable and local-host-names appear to be blank documents and "cant be displayed"

I am making a pretty good guess that this needs to be done before I can send and recieve mail for my domain through this mail server.

Thanks
Lance
Reply With Quote
Sponsored Links
  #2  
Old 14th August 2005, 17:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

If you use ISPconfig, then /etc/postfix/local-host-names and /etc/postfix/virtusertable are handled by ISPconfig.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th August 2005, 04:16
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
If you use ISPconfig, then /etc/postfix/local-host-names and /etc/postfix/virtusertable are handled by ISPconfig.
Okay I am back to my original question above since I won't be using ISPConfig for now.

I set up an account in Mozilla. My mail account is set up as; where it says POP Mail Server I have mail.thefractalfarm.net. For the Outing Server Settings I have the server name as smtp.thefractalfarm.net. I suspect the smtp is correct but should the inbound be pop or pop3 instead of mail?

It was failing to connect before but I got my DNS records squared away and now it is asking me for a password. I don't recall setting one! I tried my Linux root and user passwords but they did not work.
Reply With Quote
  #4  
Old 17th August 2005, 11:50
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

You can use any domain that is pointing to your server, and you can enter it as POP3 server and as SMTP server. But for simplivity I'd recommend that you simply use the IP address of your box, then you'll have no problems with your DNS settings.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 20th August 2005, 15:59
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

thanks falko, I finally got it working.

In my email client (Mozilla) for in-coming and out-going mail all I had to do was enter the mail server name, e.g. [mailserverhostname].[my-domain].[tld].

It kept asking me for a password but again I don't recall ever setting one and my root or user password did not work. After much reading I finally found a reference on the web to setting user and password for postfix
Code:
# adduser [username] 
# passwd [username] [password]
After I did that I was able to finally get mail.

Now sending mail was another story. It wouldn't connect and that is when I changed the smtp server name in Mozilla to my mail server name as described above. That change enabled Mozilla to connect for sending mail but then I got an error regarding my certificates. I have an idea it relates to when I installed postfix and made the certificates.

When setting up the certificates duiring install with the HowTo we need to enter

"Company Name" should this be our FQDN?
"Unit Name" what do we enter here?
"Server Host" name should be what? FQDN, mail server name

I have an idea the Server Host name probably needs to be the server name of my mail server as I entered in Mozilla above and as defined in my zone files. Am I on the right track?

lance
Reply With Quote
  #6  
Old 20th August 2005, 17:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
"Company Name" should this be our FQDN?
No, not the FQDN, it's the company name, like ACME, Inc.
Quote:
"Unit Name" what do we enter here?
Something like IT Department or so.

Quote:
"Server Host" name should be what? FQDN, mail server name

I have an idea the Server Host name probably needs to be the server name of my mail server as I entered in Mozilla above and as defined in my zone files. Am I on the right track?
Yes, your mailserver name, like mailserver.example.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th August 2005, 17:38
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

thanks, that will probably solve the problem with the certificate validation then. I put server1 without the FQDN when I installed.

Now the problem is how do I edit the certificate(s)? If I run through the certificate steps again in your HowTo will it regenerate them without problems? and should I shut sown postfix while I do it?

lance
Reply With Quote
  #8  
Old 20th August 2005, 17:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Quote:
Originally Posted by latcarf
Now the problem is how do I edit the certificate(s)? If I run through the certificate steps again in your HowTo will it regenerate them without problems? and should I shut sown postfix while I do it?

lance
I think so. Haven't tried yet, but I don't see why it shouldn't work...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 20th August 2005, 18:07
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
Default

okay, I'll let you know what happens
Reply With Quote
  #10  
Old 21st August 2005, 02:15
latcarf latcarf is offline
Senior Member
 
Join Date: Jul 2005
Posts: 215
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

It seemed to work since I did not get any errors on the console or during retart. Although when I sent my first message I did get a screen asking if I wanted to verify sertificate, before I received a series of error massages regarding the certificates then the window I just mentioned. It also gave me the option at the bottom to Always accept, Accept this time, or never accept. I chose Always except.

thanks for the help
lance
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix Header Checks dirk Installation/Configuration 8 30th May 2010 14:38
Virtual Hosting with Postfix alexej HOWTO-Related Questions 26 27th May 2006 06:46
Postfix ERROR! - Need fix for this! hagel General 12 22nd August 2005 17:38
Postfix Problem m u r Installation/Configuration 0 8th August 2005 20:12
Postfix on localhost andy Server Operation 1 9th May 2005 18:16


All times are GMT +2. The time now is 12:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.