#1  
Old 16th March 2006, 17:16
m u r m u r is offline
Senior Member
 
Join Date: Jul 2005
Posts: 152
Thanks: 13
Thanked 1 Time in 1 Post
Send a message via AIM to m u r Send a message via MSN to m u r
Default strange characters in blog

On a separate forum, I found a solution to a problem I'm having (strange characters showing up in my blog). Here is an example of the problem:

http://ryanbrijs.com/blog/Site/Blog/...881BBD340.html

Here is the solution, but I'm not sure how to fix my server if that is indeed the problem:

Server Problems: If a page you create in iWeb and publish to a server other than .Mac contains strange unwanted characters, try setting View > Text Encoding to UTF-8. If this makes it appear correctly, it means your server is probably forcing browsers to interpret the page as being in Latin-1 encoding. iWeb pages are in UTF-8 encoding so that they can accomodate all languages, not just English and those of W. Europe, and there is no practical way to change this.
Reply With Quote
Sponsored Links
  #2  
Old 16th March 2006, 17:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

UTF-8 is still a bit problematic.

In the header of the page you linked I see this:

HTML Code:
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
Please try this instead:

HTML Code:
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1" />
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 17th March 2006, 03:52
m u r m u r is offline
Senior Member
 
Join Date: Jul 2005
Posts: 152
Thanks: 13
Thanked 1 Time in 1 Post
Send a message via AIM to m u r Send a message via MSN to m u r
Default

I replaced the code and it still didn't work. In another forum by the makers of the blog program, they said I have "faulty server settings which force all browsers to use the wrong encoding." Is there a way to change it so my server doesn't do this? The blog "is in UTF-8 encoding so that it can accomodate all languages, not just English and those of W. Europe, and there is no practical way to change this."

Is there a way to create a .htaccess file? If so, where do I put it based on the webFTP through ISPConfig? This is what I was told in the other forum:

Web servers should not be set up this way: They should let the code inside the page determine what encoding the browser is set to. If the people running the server will not change it, you may still be able to set up a separate .htaccess file for your space .

A typical entry in an .htaccess file would be "AddDefaultCharset UTF-8" or "AddCharset UTF-8 .html" or possibly "AddDefaultCharset Off" (no quotes). This file should be located at the top level of your space on the server (not inside a public_html folder if there is one). Files with a . before the name are often invisible, so you may need to select "show hidden files" or a similar setting to see them.

If your server uses XSHTTPD, you should edit the ".charset" file to contain the line: UTF-8.

A good program for making/editing such files is TextWrangler.

If you cannot have your own .htaccess file (some servers do not allow this), the only practical solution may be to publish your page someplace else which follows the proper practice, or use a different web creation program where you can set the encoding to Latin-1.

Last edited by m u r; 17th March 2006 at 04:08.
Reply With Quote
  #4  
Old 17th March 2006, 11:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You can put these directives directly into the "Apache Directives" field in ISPConfig, or you create an .htaccess file (with Unix linebreaks!) and upload it to your blog directory with FTP.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 17th March 2006, 13:18
m u r m u r is offline
Senior Member
 
Join Date: Jul 2005
Posts: 152
Thanks: 13
Thanked 1 Time in 1 Post
Send a message via AIM to m u r Send a message via MSN to m u r
 
Default

It worked! Thank you so much! You're brilliant.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
Strange characters m u r Installation/Configuration 1 16th March 2006 18:14
Strange Behaviour ratebri General 2 30th November 2005 11:57
Forreign characters jernis Feature Requests 3 4th August 2005 13:19
Strange behaviour of foreach in PHP 4.3.11 minimi Programming/Scripts 3 30th May 2005 19:20


All times are GMT +2. The time now is 19:20.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.