Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 17th March 2006, 21:46
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Does this email I received meant that someone is using my server for relay?

And that my IP is not recognised?


JafFaizal
-------------------------------------------------------------------------

Could not deliver message to the following recipient(s):

Failed Recipient: rich@galichon.net
Reason: Recipient spam or content filter rejected the message

* *-- The header and top 20 lines of the message follows --

Received: from UnknownHost [202.157.203.30] by Mail46.webcontrolcenter.com with SMTP;
* *Fri, 17 Mar 2006 03:33:56 -0700
Received: by suse1.mileswork.com (Postfix, from userid 10024)
********id C15AA2C275; Fri, 17 Mar 2006 18:34:34 +0800 (MYT)
To: rich@galichon.net
References: <20060317103423.0914A2C211@suse1.mileswork.com>
In-Reply-To: <20060317103423.0914A2C211@suse1.mileswork.com>
From: admispconfig@localhost.mileswork.com
Subject: Suspicious Attachment
Message-Id: <20060317103434.C15AA2C275@suse1.mileswork.com>
Date: Fri, 17 Mar 2006 18:34:34 +0800 (MYT)

----------------------------------------------------------------------
Warning: Message delivery wasn't performed.

Reason: Our virus scanner detected very suspicious code in
the attachment of a mail addressed to a user of our system.

The following message will not be delivered:

From: rich@galichon.net
To: jaf@mileswork.com
Subj: Important
Date: Fri, 17 Mar 2006 10:33:47 +0000
Virus: Worm.SomeFool.Z

Feel free to contact admispconfig@localhost if you can't cope with it.
----------------------------------------------------------------------

This mail was automatically generated by TrashScan v0.12
Reply With Quote
Sponsored Links
  #12  
Old 18th March 2006, 11:08
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

This means that someone sent you a virus, and the virus scanner detected it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 18th March 2006, 11:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Regarding your main.cf: please post the output of
Code:
postconf -d|grep mynetworks
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 18th March 2006, 16:09
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Falko,

The output of, postconf -d|grep mynetworks

----------------------------------------------------------------------
parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,perm it_mx_backup_networks,qmqpd_authorized_clients,rel ay_domains,smtpd_access_maps
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetw orks}
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination

----------------------------------------------------------------------

JafFaizal
Reply With Quote
  #15  
Old 18th March 2006, 22:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please run
Code:
postconf -e 'mynetworks = 127.0.0.0/8'
and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #16  
Old 19th March 2006, 15:55
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Falko,
Did what you requested.
This is the output of, postconf -d|grep mynetworks -----------------------------------------------------------
mynetworks = 127.0.0.0/8 192.168.0.0/24
mynetworks_style = subnet
parent_domain_matches_subdomains = debug_peer_list,fast_flush_domains,mynetworks,perm it_mx_backup_networks,qmqpd_authorized_clients,rel ay_domains,smtpd_access_maps
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks
smtpd_client_event_limit_exceptions = ${smtpd_client_connection_limit_exceptions:$mynetw orks}
smtpd_recipient_restrictions = permit_mynetworks, reject_unauth_destination

----------------------------------------------------------------
Retarted postfix, /etc/init.d/postfix restart
Sending to jaffaizal@gmail.com, still got the following message from the server: ------------------------------------------------------------------------
Sending failed: Authentication failed. Most likely the password is wrong. The server responded: "Error: authentication failed" The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder. The following transport protocol was used: PLANIMA
------------------------------------------------------------------------
The password entered is correct. I know this because it is the same password for downloading email from my pop3 server. Also if sending from Uebimiau. It works.
So, what else could be wrong?

BTW, I can send to email to jaf@planima.com without the "server requires authentication" selected. But the same error message as above if "server requires authentication" selected.

JafFaizal

Last edited by jaffaizal; 19th March 2006 at 16:27.
Reply With Quote
  #17  
Old 20th March 2006, 12:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Please restart saslauthd:
Code:
/etc/init.d/saslauthd restart
If it doesn't help, reboot the system.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 7th April 2006, 06:43
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi Falko/Till,

Sorry for the long delays... have been busy with works. I am still experiencing the above problem even after reboot. Following is the output when sending email after reboot:

---------------------------------------------------------------------------

Sending failed:
Authentication failed.
Most likely the password is wrong.
The server responded: "Error: authentication failed"
The message will stay in the 'outbox' folder until you either fix the problem (e.g. a broken address) or remove the message from the 'outbox' folder.
The following transport protocol was used:
MILESWORK

---------------------------------------------------------------------------

When I click on 'Check what the server support' button, KMail returns:
---------------------------------------------------------------------------

Unknown error code 50
Your SMTP server does not support TLS. Disable TLS, if you want to connect without encryption.

---------------------------------------------------------------------------

What should my setting be in KMAIL transport setup for sending thru SMTP?
Do I need to select the 'Send custom hostname to server'? IF Yes, what is the hostname?

BTW, my system is SUSE and I did use the 'The Perfect Setup' method.

Your help is very much appreciated.

Thanks...
Jaf

Last edited by jaffaizal; 7th April 2006 at 08:32.
Reply With Quote
  #19  
Old 7th April 2006, 11:59
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in your mail log?

You should use normal settings in your email client, i.e., specify the smtp and pop3 server, your username and password, enable "Server requires authentication."; please do not use TLS for now.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 7th April 2006, 13:35
jaffaizal jaffaizal is offline
Member
 
Join Date: Feb 2006
Posts: 43
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by falko
What's in your mail log?

You should use normal settings in your email client, i.e., specify the smtp and pop3 server, your username and password, enable "Server requires authentication."; please do not use TLS for now.
I am still having the same problem... following is the mail log:

--------------------------------------------------------------------------------------------
pr 7 19:29:24 suse1 pop3d: Connection, ip=[::ffff:219.95.159.31]
Apr 7 19:29:25 suse1 pop3d: LOGIN, user=web22_jaf, ip=[::ffff:219.95.159.31]
Apr 7 19:29:25 suse1 pop3d: LOGOUT, user=web22_jaf, ip=[::ffff:219.95.159.31], top=0, retr=0, time=0, stls=1
Apr 7 19:29:26 suse1 postfix/anvil[23477]: statistics: max connection rate 1/60s for (smtp:219.95.159.31) at Apr 7 19:26$
Apr 7 19:29:26 suse1 postfix/anvil[23477]: statistics: max connection count 1 for (smtp:219.95.159.31) at Apr 7 19:26:05
Apr 7 19:29:26 suse1 postfix/anvil[23477]: statistics: max cache size 1 at Apr 7 19:26:05
Apr 7 19:29:39 suse1 pop3d: Connection, ip=[::ffff:202.157.203.30]
Apr 7 19:31:16 suse1 postfix/smtpd[23577]: warning: connect to private/tlsmgr: No such file or directory
Apr 7 19:31:17 suse1 postfix/smtpd[23577]: warning: connect to private/tlsmgr: No such file or directory
Apr 7 19:31:17 suse1 postfix/smtpd[23577]: warning: problem talking to server private/tlsmgr: No such file or directory
Apr 7 19:31:17 suse1 postfix/smtpd[23577]: warning: no entropy for TLS key generation: disabling TLS support
Apr 7 19:31:17 suse1 postfix/smtpd[23577]: warning: 219.95.159.31: hostname tm.net.my verification failed: Name or servic$
Apr 7 19:31:17 suse1 postfix/smtpd[23577]: connect from unknown[219.95.159.31]
Apr 7 19:31:18 suse1 postfix/smtpd[23577]: warning: unknown[219.95.159.31]: SASL LOGIN authentication failed
Apr 7 19:31:18 suse1 postfix/smtpd[23577]: lost connection after AUTH from unknown[219.95.159.31]
Apr 7 19:31:18 suse1 postfix/smtpd[23577]: disconnect from unknown[219.95.159.31]

-----------------------------------------------------------------------------
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Relay access denied when using SMTP to external recipients Kamran Shah Installation/Configuration 111 14th May 2014 18:10
Relay access denied maxx Installation/Configuration 17 4th April 2011 12:34
Can Send Email, But Not Recieve; Relay access denied jazzgillum Installation/Configuration 21 31st May 2007 12:46
relay access denied (i've readen the previous post about this ) jeanjacquesjeanjacques Installation/Configuration 5 21st April 2006 23:34
Relay access denied KamiTsunami Server Operation 6 7th March 2006 10:25


All times are GMT +2. The time now is 22:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.