Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th February 2009, 06:36
destr0y destr0y is offline
Junior Member
 
Join Date: Feb 2009
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Question Cloning Ubuntu 8.04 Perfect Server

Hi all,

I've got a build fairly similar to the Ubuntu 8.04 Perfect Server (LAMP+SSH+myPHPAdmin+Webmin+others) build that we're quite partial to where I work. I'd like to use this build as a standard for all servers. All of our Ubuntu instances are virtual machines, so the logistical side of the cloning question is a no-brainer..

changing the hostname / IP address of a Ubuntu box is simple enough, but where else should I be looking to change when deploying a cloned (virtual) HDD? Some of the more obvious ones:

vi /etc/hostname
vi /etc/hosts
dpkg-reconfigure postfix

I assume renaming a cloned server will also break anything certificate related (OpenSSL, SSH, etc)?

I've read about SystemImager, but its website isn't loading for me at the moment.. is it still being developed/supported?

Cheers,
Brett
Reply With Quote
Sponsored Links
  #2  
Old 17th February 2009, 15:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Quote:
Originally Posted by destr0y View Post
changing the hostname / IP address of a Ubuntu box is simple enough, but where else should I be looking to change when deploying a cloned (virtual) HDD? Some of the more obvious ones:

vi /etc/hostname
vi /etc/hosts
dpkg-reconfigure postfix
You might also want to check your Apache configuration.

Quote:
Originally Posted by destr0y View Post
I assume renaming a cloned server will also break anything certificate related (OpenSSL, SSH, etc)?
Yes - if you care about warnings in browsers, you should recreate the certificates.

Quote:
Originally Posted by destr0y View Post
I've read about SystemImager, but its website isn't loading for me at the moment.. is it still being developed/supported?
The SF page is working ( http://sourceforge.net/projects/systemimager/ ), but not their main page - not sure why...
You might want to check out CloneZilla SE: http://www.howtoforge.com/cloning-li...-clonezilla-se
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
Ubuntu 8.04 - Postfix SSL|TLS The Perfect Server make-fun Installation/Configuration 4 27th May 2008 22:36
The Perfect Server UBUNTU 8.04 stuck step 8 Samir-12 Installation/Configuration 8 25th May 2008 13:47
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30
The Perfect Setup - Ubuntu 6.10 Server Question n74jw HOWTO-Related Questions 5 27th January 2008 12:14


All times are GMT +2. The time now is 12:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.