#1  
Old 12th February 2009, 19:15
obgr_seneca obgr_seneca is offline
Junior Member
 
Join Date: May 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default amavis using ~100% CPU

Hi,
I've installed and configured a postfix/dovecot mailserver system according to the "perfect mandriva server 2009.0" howto.
Now I'm trying to configure amavisd-new as spam- and virus-protection to work with postfix.

Now I'm facing the problem that amavis is using about 100% of one CPU (on a two-CPU system) and no mail is coming through.

Here are the relevant parts of the configs. If you need anything else, please tell me.

main.cf
Code:
content_filter = lmtp-amavis:127.0.0.1:10024
receive_override_options = no_address_mappings
master.cf
Code:
#
# Amavis
# to:
lmtp-amavis    unix    -       -       y       -       2       lmtp
       -o lmtp_data_done_timeout=1200
       -o lmtp_send_xforward_command=yes
       -o disable_dns_lookup=yes
       -o disable_dns_lookups=yes
       -o max_use=20
# from:
127.0.0.1:10025        inet    n       -       y       -       -       smtpd
       -o content_filter=
       -o local_recipient_maps=
       -o relay_recipient_maps=
       -o smtpd_restriction_classes=
       -o smtpd_delay_reject=no
       -o smtpd_client_restrictions=permit_mynetworks,reject
       -o smtpd_helo_restrictions=
       -o smtpd_sender_restrictions=
       -o smtpd_recipient_restrictions=permit_mynetworks,reject
       -o smtpd_data_restrictions=reject_unauth_pipelining
       -o smtpd_end_of_data_restrictions=
       -o mynetworks=127.0.0.0/8
       -o smtpd_error_sleep_time=0
       -o smtpd_soft_error_limit=1001
       -o smtpd_hard_error_limit=1000
       -o smtpd_client_connection_count_limit=0
       -o smtpd_client_connection_rate_limit=0
       -o receive_override_options=no_header_body_checks,no_unknown_recipient_checks
amavis.conf
Code:
$inet_socket_port = 10024;   # listen on this local TCP port(s)
Code:
$notify_method  = 'smtp:[127.0.0.1]:10025';
$forward_method = 'smtp:[127.0.0.1]:10025';
Furthermore I've commented out any virusscanner except clamav. The rest is the default config comming with the packages.

Oliver
Reply With Quote
Sponsored Links
  #2  
Old 13th February 2009, 14:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 13th February 2009, 14:30
obgr_seneca obgr_seneca is offline
Junior Member
 
Join Date: May 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

We have several MB of Logs per day, most generated directly by postfix, when amavis was running and configured in postfix, we got a "lmtp-amavis file or directory not found".

But (again) we were happily able to find the problem on our own. Last year we faced a massive DoS, which seems to have crippled our whole mail-architecture causing postfix to get the whole system freezed in irregular intervals but upto several times a day.

Apparently this corrupted the amavis database. After rebuilding it, amavis is running again as it should.

But thanks non the less for your answer.

Oliver
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How cai remove amavis from postfix ? gabrix Server Operation 16 2nd October 2012 09:58
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51
CLAMAV & amavis updating problem herbie Server Operation 0 15th February 2007 23:03
Server sometimes (1 or 2 hrs) down :/ edge Server Operation 25 31st July 2006 13:44
Just installed Debian.. I'm not happy edge Installation/Configuration 10 18th June 2006 22:23


All times are GMT +2. The time now is 23:36.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.