Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th February 2009, 13:25
Puppetmaster Puppetmaster is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default "It works", but it doesn't actually :-(

Hello.
I've been following the guide: "The Perfect Server - Ubuntu Intrepid Ibex (Ubuntu 8.10)", after that I have been using the installation guide to ISPConfig...
The ISP Controlpanel is working...
I've created a test site: www.lutzen.dk, and have set up DNS (go ahead, test it). So if you try to look up the IP for www.lutzen.dk you get the correct IP: 82.143.204.139.
But, my server just returns "It works" from "/var/www/index.html".
It's like the virtual hosts is not working. That it doesnt get the Virtual Host config included or something...
I've looked in some other threads and now I placed my server outside DMZ. But it did not change anything...

What info should I post to help solve my problem?

This is the first time I play with these things. So I really doesn't have a clue what I did wrong...

I hope one of you can point me in the right direction
Reply With Quote
Sponsored Links
  #2  
Old 9th February 2009, 06:02
Allen15 Allen15 is offline
Junior Member
 
Join Date: Jan 2009
Posts: 29
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Hello. I have felt your pains recently too.

If you can get to the "It Works!" page when browsing, and not a "Shared IP" warning page, then Apache is working with the default installation page, but ISPConfig is not.

DO NOT MAKE CHANGES TO YOUR ROUTER!

Getting to the default Apache page says that packets and requests are going to the correct places, so don't go fixing what is not broken, it will only frustrate you more. Try:

/etc/init.d/ispconfig_server start

and see if you can start ISPConfig, although I suspect that there is a greater chance that you have a failed installation of ISPConfig, and may need to remove it and re-install it? Before you do a reinstallation, check your install logs for errors to see if there are more clues to point you toward your next success, like missing packages that may have crashed the install and the like.

Good luck, hang in there, and keep asking questions -- I've found that together, we CAN get there.

Allen
Reply With Quote
  #3  
Old 9th February 2009, 06:56
Puppetmaster Puppetmaster is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default Still nothing

I tried to start the ISPConfig with the:
Code:
root@server1:/etc/init.d/ispconfig_server start
Then I got this response:

Code:
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd (pid 4992) already running
FreshClam is already running!
ISPConfig system is now up and running!
It looks like that was not the problem...
What log files should I look in? And where are they placed? "/var/log/messages"?

It might be a broken installation... It I just apt-get install all the packages that ISPConfig requires, then if they are already installed it will just do nothing, or if I is not installed, then it would install it...
Then what packages should I check for?

Re-installation, no problem:-) I will do that when I figure out what I am missing.
Reply With Quote
  #4  
Old 9th February 2009, 11:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Most likely you entered the wrong IP address. make sure that you used the internal IP address were you forwarded port 80 to from your router for the website that you created in ispconfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Puppetmaster (10th February 2009)
  #5  
Old 9th February 2009, 16:38
Puppetmaster Puppetmaster is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I have altered the "It works" page, to ensure that it was my IP.
If you look: http://82.143.204.139/ it is the correct IP.
I have taken a screenshot of the setting in my router setup...
My servers internal IP is 192.168.2.4...
Attached Images
 
Reply With Quote
  #6  
Old 9th February 2009, 23:11
codydwilson codydwilson is offline
Junior Member
 
Join Date: Jun 2008
Posts: 19
Thanks: 20
Thanked 0 Times in 0 Posts
Default

Had the same problem as well. Had to do with DNS i belive, are you using godaddy for your domain? If so you have to * out the ip address in your vhosts ispconfig file, at least that's what worked for me.

Here's the thread that helped me

Last edited by codydwilson; 9th February 2009 at 23:15.
Reply With Quote
  #7  
Old 10th February 2009, 07:05
Puppetmaster Puppetmaster is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No I am not using GoGaddy.
I am using Gratisdns.dk.

What info is needed? I checked in my apache2.conf, and I get the Vhosts_ispconfig included as far as I can see...

I am new to this so I am fumbling in the dark :-(
Reply With Quote
  #8  
Old 10th February 2009, 16:51
Puppetmaster Puppetmaster is offline
Junior Member
 
Join Date: Feb 2009
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I just tried to fill in some "wefdwfefwwfe" in the "vhosts/Vhosts_ispconfig.conf" and when I reloaded apache it died.
So it is included...

Then i tried playing around with the IPs.. and it solved the problem!! Thanks for the HELP!

And now it works. Thanks for your help!!
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 03:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.