Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th February 2009, 16:02
nashchris nashchris is offline
Junior Member
 
Join Date: Dec 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Exclamation Snowballing Mail and now WWW errors...

Hi All.
I am so hoping one of the geniuses on this forum can help me.

I have setup ISPconfig using the Perfect Ubuntu server tutorial. Using Ubuntu Intrepid Ibis and ISPConfig 2.2.25. It hosts only one domain currently offering www, smtp, pop3 and samba (only to the internal network).

The setup went fine except that once it was complete, all out going mail got relay denied... Fixed this by editing the /etc/postfix/main.cf file and changing mydestination = /etc/postfix/local-host-names and restarting postfix.

Worked fine for two days. I then proceeded to add the additional 45 odd email users. Still worked fine for a few days. There were no further changes to the server, aside from the updates to the joomla site. Mail clients used mail.domain.name as their pop and smtp.

Then suddenly mail.domain.name no longer worked as the SMTP on the internal network bouncing all mail. But www.domain.name worked. Then a day or so later, the pop3 (mail.domain.name) started to work incosistantly. But the internal IP works fine for the POP3 (but not the SMTP). Everything works fine on the external interface.

Now today the www also doesn't work and all sent mail gets sent to the catchall user (webmaster@domain.name - including the internal mails).

I don't see anything odd in the configuration or the logs. I must stress that there are no errors when accessing mail or www from the exteral/internet interface.

Has ANYONE every seen this before? Where do I start to dig?

Chris
Reply With Quote
Sponsored Links
  #2  
Old 12th February 2009, 20:58
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,504
Thanks: 813
Thanked 5,265 Times in 4,129 Posts
Default

take a look at the mail.log
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 13th February 2009, 08:30
nashchris nashchris is offline
Junior Member
 
Join Date: Dec 2008
Posts: 3
Thanks: 1
Thanked 0 Times in 0 Posts
Post Log files...

Here is an extract from my mail.info file.
I haven't changed the domain names. The machine name is cam-server.camdeboo.gov.za. Emails are username@camdeboo.gov.za.

Feb 13 09:24:34 cam-server postfix/smtpd[30633]: connect from smtp.gam.co.za[196.35.164.205]
Feb 13 09:24:34 cam-server postfix/smtpd[30633]: setting up TLS connection from smtp.gam.co.za[196.35.164.205]
Feb 13 09:24:34 cam-server postfix/smtpd[30633]: Anonymous TLS connection established from smtp.gam.co.za[196.35.164.205]: TL
Sv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Feb 13 09:24:35 cam-server postfix/smtpd[30633]: 1CA6F1B7C0AC: client=smtp.gam.co.za[196.35.164.205]
Feb 13 09:24:35 cam-server postfix/cleanup[30637]: 1CA6F1B7C0AC: message-id=<!&!AAAAAAAAAAAYAAAAAAAAAHMAH5Dc4/1Aq84/ZZdgO0rCg
AAAEAAAAPAbFXgyc3JMrw3SVHA2GqYBAAAAAA==@camdeboo.g ov.za>
Feb 13 09:24:35 cam-server postfix/qmgr[30513]: 1CA6F1B7C0AC: from=<webmaster@camdeboo.gov.za>, size=27479, nrcpt=2 (queue ac
tive)
Feb 13 09:24:35 cam-server postfix/smtpd[30633]: disconnect from smtp.gam.co.za[196.35.164.205]
Feb 13 09:24:35 cam-server postfix/local[30640]: 1CA6F1B7C0AC: to=<web1_meyerh@cam-server.camdeboo.gov.za>, orig_to=<meyerh@c
amdeboo.gov.za>, relay=local, delay=0.44, delays=0.35/0.02/0/0.07, dsn=2.0.0, status=sent (delivered to command: /usr/bin/pro
cmail -f-)
Feb 13 09:24:35 cam-server postfix/pickup[24771]: 864C61B7C0AF: uid=10008 from=<web1_bosmanj>
Feb 13 09:24:35 cam-server postfix/cleanup[30637]: 864C61B7C0AF: message-id=<20090213072435.864C61B7C0AF@cam-server.camdeboo.
gov.za>
Feb 13 09:24:35 cam-server postfix/qmgr[30513]: 864C61B7C0AF: from=<web1_bosmanj@cam-server.camdeboo.gov.za>, size=424, nrcpt
=1 (queue active)
Feb 13 09:24:35 cam-server postfix/local[30638]: 1CA6F1B7C0AC: to=<web1_bosmanj@cam-server.camdeboo.gov.za>, orig_to=<bosmanj
@camdeboo.gov.za>, relay=local, delay=0.48, delays=0.35/0/0/0.13, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Feb 13 09:24:35 cam-server postfix/pickup[24771]: 8ED7F1B7C0AE: uid=10029 from=<web1_meyerh>
Feb 13 09:24:35 cam-server postfix/cleanup[30637]: 8ED7F1B7C0AE: message-id=<20090213072435.8ED7F1B7C0AE@cam-server.camdeboo.gov.za>
Feb 13 09:24:35 cam-server postfix/local[30640]: 864C61B7C0AF: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.08, delays=0.05/0.03/0/0, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Feb 13 09:24:35 cam-server postfix/qmgr[30513]: 1CA6F1B7C0AC: removed
Feb 13 09:24:35 cam-server postfix/qmgr[30513]: 864C61B7C0AF: removed
Feb 13 09:24:35 cam-server postfix/qmgr[30513]: 8ED7F1B7C0AE: from=<web1_meyerh@cam-server.camdeboo.gov.za>, size=423, nrcpt=1 (queue active)
Feb 13 09:24:35 cam-server postfix/local[30638]: 8ED7F1B7C0AE: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.14, delays=0.13/0/0/0, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Feb 13 09:24:35 cam-server postfix/qmgr[30513]: 8ED7F1B7C0AE: removed
Feb 13 09:25:40 cam-server pop3d: LOGIN, user=web1_dekkern, ip=[::ffff:192.168.20.84], port=[1326]
Feb 13 09:25:40 cam-server pop3d: LOGOUT, user=web1_dekkern, ip=[::ffff:192.168.20.84], port=[1326], top=0, retr=0, rcvd=12, sent=39, time=0
Feb 13 09:26:56 cam-server pop3d: LOGIN, user=web1_admin, ip=[::ffff:196.209.156.173], port=[2281]
Feb 13 09:26:57 cam-server pop3d: LOGOUT, user=web1_admin, ip=[::ffff:196.209.156.173], port=[2281], top=0, retr=0, rcvd=12, sent=39, time=1
Feb 13 09:27:02 cam-server postfix/smtpd[31742]: connect from unknown[192.168.20.135]
Feb 13 09:27:02 cam-server postfix/smtpd[31742]: NOQUEUE: reject: RCPT from unknown[192.168.20.135]: 554 5.7.1 <chris@xtt.co.za>: Relay access denied; from=<meyerh@camdeboo.gov.za> to=<chris@xtt.co.za> proto=ESMTP helo=<hendrina>
Feb 13 09:27:02 cam-server postfix/smtpd[31742]: NOQUEUE: reject: RCPT from unknown[192.168.20.135]: 554 5.7.1 <nash.chris@gmail.com>: Relay access denied; from=<meyerh@camdeboo.gov.za> to=<nash.chris@gmail.com> proto=ESMTP helo=<hendrina>
Feb 13 09:27:02 cam-server postfix/smtpd[31742]: B12451B7C0AC: client=unknown[192.168.20.135]
Feb 13 09:27:02 cam-server postfix/cleanup[31745]: B12451B7C0AC: message-id=<20090213072702.B12451B7C0AC@cam-server.camdeboo.gov.za>
Feb 13 09:27:02 cam-server postfix/qmgr[30513]: B12451B7C0AC: from=<meyerh@camdeboo.gov.za>, size=6613, nrcpt=1 (queue active)
Feb 13 09:27:02 cam-server postfix/pickup[24771]: CC6531B7C0AE: uid=10001 from=<web1_admin>
Feb 13 09:27:02 cam-server postfix/cleanup[31745]: CC6531B7C0AE: message-id=<20090213072702.CC6531B7C0AE@cam-server.camdeboo.gov.za>
Feb 13 09:27:02 cam-server postfix/qmgr[30513]: CC6531B7C0AE: from=<web1_admin@cam-server.camdeboo.gov.za>, size=414, nrcpt=1 (queue active)
Feb 13 09:27:02 cam-server postfix/local[31746]: B12451B7C0AC: to=<web1_admin@cam-server.camdeboo.gov.za>, orig_to=<webmaster@camdeboo.gov.za>, relay=local, delay=0.14, delays=0.04/0.01/0/0.09, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Feb 13 09:27:02 cam-server postfix/local[31761]: CC6531B7C0AE: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.06, delays=0.05/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Feb 13 09:27:02 cam-server postfix/qmgr[30513]: B12451B7C0AC: removed
Feb 13 09:27:02 cam-server postfix/qmgr[30513]: CC6531B7C0AE: removed
Feb 13 09:27:05 cam-server postfix/smtpd[31742]: disconnect from unknown[192.168.20.135]
Reply With Quote
  #4  
Old 13th February 2009, 13:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

Sounds like a DNS issue. Did you check your DNS records?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.