Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 28th January 2009, 02:25
AceFrahm AceFrahm is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Thanks: 3
Thanked 0 Times in 0 Posts
Exclamation ISPConfig 3 RC1 Incoming eMail

I think I created a mailuser correctly, but this installation isn't accepting mail for it.

But I can send an e-Mail to hotmail and to gmail from it !

This is the failure message from hotmail ( I added extra ______ to foil forum-scraping spambots):
Code:
Reporting-MTA: dns; dns01.acefrahm._____com
X-Postfix-Queue-ID: AD9301B6515
X-Postfix-Sender: rfc822; acefrahm@_____hotmail.____com
Arrival-Date: Tue, 27 Jan 2009 14:24:50 -0500 (EST)

Final-Recipient: rfc822; ace.frahm@____acefrahm.______com
Original-Recipient: rfc822;ace.frahm@____acefrahm.______com
Action: failed
Status: 5.1.1
Diagnostic-Code: x-unix; Invalid user specified.
It fails similarly when sending from gmail too.

http://www.acefrahm.com/screenshot/ScreenShot2.png

http://www.acefrahm.com/screenshot/ScreenShot3.png

http://www.acefrahm.com/screenshot/ScreenShot4.png

http://www.acefrahm.com/screenshot/ScreenShot5.png

http://www.acefrahm.com/screenshot/ScreenShot6.png
Reply With Quote
Sponsored Links
  #2  
Old 28th January 2009, 11:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Please post the error messages from the mail log of your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 28th January 2009, 21:49
AceFrahm AceFrahm is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Thanks: 3
Thanked 0 Times in 0 Posts
Post The Log

this is the latest output of /var/log/mail.log:
http://www.acefrahm.com/screenshot/mail.log

/var/log/mail.err has nothing in it.

Last edited by AceFrahm; 28th January 2009 at 21:52.
Reply With Quote
  #4  
Old 29th January 2009, 09:42
afredriksson afredriksson is offline
Junior Member
 
Join Date: Jan 2009
Location: Sweden
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
Default

Hi everyone. I have had the same problem on my Ubuntu installation and have after a few days of searching down wrong tracks found the solution.

The problem is, at least in Ubuntu, that authlib support is absent in the courier-maildrop package. Once I found out that this was my problem, I was able to get it to work by removing the courier-maildrop package and instead install the standalone maildrop package:

Code:
sudo apt-get remove courier-maildrop
sudo apt-get install maildrop
I don't know where else I need to post this solution, someone please direct me. I am a newbee to this site.

And by the way. WOW! This is a great product! :-)

Last edited by afredriksson; 29th January 2009 at 09:45.
Reply With Quote
The Following User Says Thank You to afredriksson For This Useful Post:
AceFrahm (4th February 2009)
  #5  
Old 29th January 2009, 10:11
AceFrahm AceFrahm is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Thanks: 3
Thanked 0 Times in 0 Posts
Post Replaced courier-maildrop with maildrop

And I deleted the e-mail domain and recreated it and the user.
Gmail says:


user unknown. Command output: ERR: authdaemon:
s_connect() failed: Permission denied Invalid user specified.
Status: 5.1.1

Diagnostic-Code: x-unix; ERR: authdaemon: s_connect() failed: Permission denied
Invalid user specified.

Hotmail says:
user unknown. Command output: ERR: authdaemon:s_connect() failed: Permission denied Invalid user specified.
Reply With Quote
  #6  
Old 29th January 2009, 19:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

This happens when you send an email to your server?
What's in your mail log now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 30th January 2009, 01:11
AceFrahm AceFrahm is offline
Junior Member
 
Join Date: Jun 2007
Posts: 22
Thanks: 3
Thanked 0 Times in 0 Posts
Default BAD_HEADER: Improper use of control character

I found this line in a file called:
/var/mail/www-data

Code:
   554 5.6.0 Reject, id=05252-01 - BAD_HEADER: Improper use of control character (char 0D hex): MIME-Version: 1.0\r
Here's a screen shot of that file:
http://acefrahm.com/screenshot/scree...-01-29_002.png

Here's the Show Mail Log from ISPConfig3:
http://acefrahm.com/screenshot/scree...-01-29_001.png


And here's the tail end of /var/log/mail.log
http://acefrahm.com/screenshot/scree...-01-29_003.png
Reply With Quote
  #8  
Old 30th January 2009, 12:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

What's in /etc/posstfix/main.cf? Which distribution are you using?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 30th January 2009, 12:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

Your system seems to work properly. You will just have to change the mailscan option for the email account and domain to not rejecet bad headers.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 30th January 2009, 20:39
Inco Inco is offline
Junior Member
 
Join Date: Jan 2009
Posts: 1
Thanks: 0
Thanked 1 Time in 1 Post
 
Default bad maildrop

problem in master.cf in postfix, with arguments who send pipe to maildrop and .mailfilter don't know this argument.
known torouble as "user unknown. Command output: /usr/local/bin/maildrop: Invalid user specified."
I use next configuration master.cf


maildrop unix - n n - - pipe
flags=R user=vmail argv=/usr/bin/maildrop -dvmail ${extension} ${recipient} ${user} ${domain} ${sender}

work fine. ubuntu 8.10
Reply With Quote
The Following User Says Thank You to Inco For This Useful Post:
AceFrahm (4th February 2009)
Reply

Bookmarks

Tags
incoming email refused, invalid user specified., ispconfig 3 rc1

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3RC1 - email domain vs. site domain across users Ben Developers' Forum 2 13th January 2009 18:57
ISPConfig 3.0.0.7 Beta released till General 78 24th December 2008 11:47
email receiving died ??? + report a bug in ispconfig email add/remove coolen Installation/Configuration 14 4th November 2008 19:34
ISPConfig 3.0.0.5 Beta Released till General 77 23rd July 2008 12:14
ISPConfig - Why not integrate Free Radius? Johan_Boshoff Feature Requests 3 12th October 2007 23:19


All times are GMT +2. The time now is 07:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.