#1  
Old 14th March 2006, 01:43
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default php.ini and mail questions

I'm running SuSe 9.3 with Postfix.

When I send mail from my site with mail() function I receive the email but the sender is From : www apache daemon.How can I change this tosomething else like www@www.domain.ro .
I,ve tried in /etc/php.ini to change
sendmail_path = /usr/sbin/sendmail -t -www@www.domain.ro but doesn,t work.

If I have some subdomains how can I personalize every mail sent from subdomains like subdomain1@domain.ro,subdomain2@domain.ro etc.
With Virtualhost doesn't work.

And the last question it is possible in Linux to hide php info ?(Safe mode =Off)
Browsing the Internet a couple of days doesn't bring me answers to my problems .

Thanks in advance for any help and hope that there are not too many questions in one post.

Last edited by mavgh1; 14th March 2006 at 02:23.
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2006, 09:25
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

You can supply additional header infos to the php mail function:

mail($to, $subject, $message, "From: your@yourmail.com\n");
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 14th March 2006, 13:10
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Default thanks but not from php script

Thanks but not from php script I want to solve my problem.
Reply With Quote
  #4  
Old 14th March 2006, 18:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

But that's the only way...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 14th March 2006, 21:08
mavgh1 mavgh1 is offline
Junior Member
 
Join Date: Mar 2006
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default maybe I'm wrong but

I solved the problem with phpinfo

Maybe I'm wrong but .....
I had a site hosted on a free host.When I send a email from that site without "From : " automatically the receiver of the email has a "from :" site@site.com.This is the reason why Im asking about configuring php.ini
Im not very sure but before I started this SuSe Server I read somewhere that if you have a domain and some subdomains for every subdomains you must have a php.ini(i dont know how to do this and in the last 3 days b rowsing the Internet didn't find anything about).

Last edited by mavgh1; 15th March 2006 at 00:03.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Not receiving any incoming mail. Jcorrea920 General 11 3rd April 2010 13:08
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47
Postfix mail is held in queue indefinitely... squallbsr Server Operation 9 15th January 2006 19:13
Mail server jas_esp Server Operation 1 7th December 2005 18:17


All times are GMT +2. The time now is 19:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.