Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 22nd February 2009, 11:58
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,082
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Change the lines:

Code:
NameVirtualHost *
NameVirtualHost *:80
<VirtualHost *>

to:

Code:
NameVirtualHost *:80
<VirtualHost *:80>
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Sponsored Links
  #22  
Old 22nd February 2009, 20:23
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 1 Time in 1 Post
Default

Doesn't do anything for helping the SSL to work (port 443).
Reply With Quote
  #23  
Old 23rd February 2009, 21:45
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 1 Time in 1 Post
Default

Anyone? See a couple messages above for the actual SSL/443 issues. I am looking at all of the site configs for ISPConfig3 and do not see any thing setup for SSL. I do have it enabled it under the site that needs it, but no reference under default or the specific Vhost file for the NameVirtualHost.
Reply With Quote
  #24  
Old 23rd February 2009, 22:00
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,082
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

You have to create a ssl certificate on the ssl tab.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #25  
Old 23rd February 2009, 22:24
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 1 Time in 1 Post
Default

It had one created originally, didn't start. I tried copying the GoDaddy cert as also mentioned. I then clicked the thing to Create Certificate, created it's own and I tried to restart apache but wouldn't. Here is my Vhost files:

8bitclassics.com.vhost
Code:
<VirtualHost 172.21.152.31:80>
      DocumentRoot /var/www/8bitclassics.com/web

    ServerName 8bitclassics.com
    ServerAlias www.8bitclassics.com
    ServerAdmin webmaster@8bitclassics.com

    ErrorLog /var/log/ispconfig/httpd/8bitclassics.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/8bitclassics.com/web>
        Options FollowSymLinks
        AllowOverride Indexes AuthConfig Limit FileInfo
        Order allow,deny
        Allow from all
    </Directory>

    # cgi enabled
    ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@8bitclassics.com"
    php_admin_value upload_tmp_dir /var/clients/client1/web2/tmp
    php_admin_value session.save_path /var/clients/client1/web2/tmp
    #php_admin_value open_basedir /var/clients/client1/web2:/usr/share/php5

php_admin_value memory_limit 64M
</VirtualHost>


<IfModule mod_ssl.c>
###########################################################
# SSL Vhost
###########################################################

<VirtualHost 172.21.152.31:443>
      DocumentRoot /var/www/8bitclassics.com/web

    ServerName 8bitclassics.com
    ServerAlias www.8bitclassics.com
    ServerAdmin webmaster@8bitclassics.com

    ErrorLog /var/log/ispconfig/httpd/8bitclassics.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    SSLEngine on
    SSLCertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.crt
    SSLCertificateKeyFile /var/clients/client1/web2/ssl/8bitclassics.com.key
    SSLCACertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.bundle

    # cgi enabled
    ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@8bitclassics.com"
    php_admin_value upload_tmp_dir /var/clients/client1/web2/tmp
    php_admin_value session.save_path /var/clients/client1/web2/tmp
    #php_admin_value open_basedir /var/clients/client1/web2:/usr/share/php5

php_admin_value memory_limit 64M
</VirtualHost>
</IfModule>
default

Code:
NameVirtualHost *
NameVirtualHost *:80
<VirtualHost *>
        ServerAdmin webmaster@localhost

        DocumentRoot /var/www/
        <Directory />
                Options FollowSymLinks
                AllowOverride None
        </Directory>
        <Directory /var/www/>
                Options Indexes FollowSymLinks MultiViews
                AllowOverride None
                Order allow,deny
                allow from all
        </Directory>

        ScriptAlias /cgi-bin/ /usr/lib/cgi-bin/
        <Directory "/usr/lib/cgi-bin">
                AllowOverride None
                Options +ExecCGI -MultiViews +SymLinksIfOwnerMatch
                Order allow,deny
                Allow from all
        </Directory>

        ErrorLog /var/log/apache2/error.log

        # Possible values include: debug, info, notice, warn, error, crit,
        # alert, emerg.
        LogLevel warn

        CustomLog /var/log/apache2/access.log combined
        ServerSignature On

    Alias /doc/ "/usr/share/doc/"
    <Directory "/usr/share/doc/">
        Options Indexes MultiViews FollowSymLinks
        AllowOverride None
        Order deny,allow
        Deny from all
        Allow from 127.0.0.0/255.0.0.0 ::1/128
    </Directory>

</VirtualHost>
Reply With Quote
  #26  
Old 26th February 2009, 00:10
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 1 Time in 1 Post
Default

Bump, see above message.
Reply With Quote
  #27  
Old 26th February 2009, 09:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,082
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

You still have not done what I told you in post #21 of this thread! If you dont do what we tell you, your setup will never get working.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #28  
Old 26th February 2009, 13:43
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 1 Time in 1 Post
Default

Umm, I did. Now if you wanted me to do 21 with the other last post you didn't specify. 21 by itself doesn't do anything different as mentioned in my post underneath it. I will try 21 with recreating the SSL.
Reply With Quote
  #29  
Old 26th February 2009, 20:07
koltz koltz is offline
Member
 
Join Date: Feb 2007
Posts: 61
Thanks: 0
Thanked 1 Time in 1 Post
Default

After I make the changes from post 21, it adds this to my site:

Code:
<IfModule mod_ssl.c>
###########################################################
# SSL Vhost
###########################################################

<VirtualHost 172.21.152.31:443>
      DocumentRoot /var/www/8bitclassics.com/web

    ServerName 8bitclassics.com
    ServerAlias www.8bitclassics.com
    ServerAdmin webmaster@8bitclassics.com

    ErrorLog /var/log/ispconfig/httpd/8bitclassics.com/error.log

    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    SSLEngine on
    SSLCertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.crt
    SSLCertificateKeyFile /var/clients/client1/web2/ssl/8bitclassics.com.key
    SSLCACertificateFile /var/clients/client1/web2/ssl/8bitclassics.com.bundle

    # cgi enabled
    ScriptAlias  /cgi-bin/ /var/clients/client1/web2/cgi-bin/
    AddHandler cgi-script .cgi
    AddHandler cgi-script .pl
    # mod_php enabled
    AddType application/x-httpd-php .php .php3 .php4 .php5
        php_admin_value sendmail_path "/usr/sbin/sendmail -t -i -fwebmaster@8bitclassics.com"
    php_admin_value upload_tmp_dir /var/clients/client1/web2/tmp
    php_admin_value session.save_path /var/clients/client1/web2/tmp
    #php_admin_value open_basedir /var/clients/client1/web2:/usr/share/php5

php_admin_value memory_limit 64M
</VirtualHost>
</IfModule>
Apache2 fails to restart once the SSL cert is created, here is what Apache2 says when loading

Code:
 * Restarting web server apache2                                                                                                                             [Thu Feb 26 13:05:01 2009] [warn] NameVirtualHost 172.21.152.32:443 has no VirtualHosts
[Thu Feb 26 13:05:01 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
httpd (pid 26994?) not running
[Thu Feb 26 13:05:11 2009] [warn] NameVirtualHost 172.21.152.32:443 has no VirtualHosts
[Thu Feb 26 13:05:11 2009] [warn] NameVirtualHost *:80 has no VirtualHosts
[fail]
When I delete the SSL Vhost stuff added, the site starts running again.
Reply With Quote
  #30  
Old 27th February 2009, 14:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Can you post all the NameVirtualHost lines from your Apache configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MyDNS And The MyDNSConfig Control Panel and ISPConfig pg001 General 2 29th July 2008 02:31
ispconfig 3 joining frontend Snowman General 1 28th June 2008 17:28
MyDNS + ISPConfig msource General 1 5th May 2007 13:05
MyDNS and ISPConfig CoDonCo General 3 27th July 2006 08:25
ISPConfig Devel Report. till Developers' Forum 3 27th November 2005 15:07


All times are GMT +2. The time now is 16:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.