Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th March 2006, 00:10
DanMB DanMB is offline
Junior Member
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Help Needed Please!!!

Hello,
I am really interted installing ISPConfig but im having no luck
Im using CentOS 4.2 and ive also installed the latest zlib
Im getting an error during installation:

NOTE: the optional IO::Zlib module is not installed.

The "sa-update" script requires this module to access compressed
update archive files.

REQUIRED module missing: Digest::SHA1
REQUIRED module missing: HTML::Parser
optional module missing: Net:NS
optional module missing: Mail::SPF::Query
optional module missing: IP::Country
optional module missing: Razor2
optional module missing: Net::Ident
optional module missing: IO::Socket::INET6
optional module missing: IO::Socket::SSL
optional module missing: Time::HiRes
optional module missing: LWP::UserAgent
optional module missing: HTTP:ate
optional module missing: Archive::Tar
optional module missing: IO::Zlib

warning: some functionality may not be available,
please read the above report before continuing!

ERROR: Could not configure SpamAssassin
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
tar: spamassassin.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `spamassassin': No such file or directory
tar: uudeview.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `uudeview': No such file or directory
tar: clamav.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
mv: cannot stat `clamav': No such file or directory
tar: aps.tar.gz: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors
./setup2: line 777: ispconfig_tmp/php/bin/php: No such file or directory
ERROR: The PHP binary coming with ISPConfig does not work properly on your system! The installation routine stops here!

PLEASE Help

Thank You

Last edited by DanMB; 14th March 2006 at 00:12.
Reply With Quote
Sponsored Links
  #2  
Old 14th March 2006, 00:36
DanMB DanMB is offline
Junior Member
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ive looked through the error log and looked for zlib modules couldnt find any - Im very new to the whole thnk and very stuck- can some one please help

**Ps sorry for double post
Reply With Quote
  #3  
Old 14th March 2006, 00:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by DanMB
REQUIRED module missing: Digest::SHA1
REQUIRED module missing: HTML::Parser
You must install these two Perl modules, as described here: http://www.howtoforge.com/perfect_se...dora_core_4_p5 (Fedora Core 4 is very similar to CentOS, so this should work for you).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 14th March 2006, 01:41
DanMB DanMB is offline
Junior Member
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

YEY i now have it installed but:

Starting ISPConfig system...
Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: undefined symbol: compress
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
FreshClam is already running!
ISPConfig system is now up and running!
Reply With Quote
  #5  
Old 14th March 2006, 10:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Did you get any errors during ISPConfig installation? Please check the install log in /var/log/ispconfig_install.log
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 15th March 2006, 23:58
DanMB DanMB is offline
Junior Member
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Heres the log:

Code:
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - created mydestination entry in /et$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:26 GMT 2006 - [ISPConfig] - /root/install_ispconfig/install.ph$
Mon Mar 13 23:19:27 GMT 2006 - [ISPConfig] - httpd restart successful
Mon Mar 13 23:19:29 GMT 2006 - [ISPConfig] - postfix restart successful
Mon Mar 13 23:19:37 GMT 2006 - [ISPConfig] - file /root/ispconfig/dist.info del$
Mon Mar 13 23:19:43 GMT 2006 - [ISPConfig] - directory install_ispconfig deleted
Mon Mar 13 23:19:43 GMT 2006 - [ISPConfig] - ##############################
Reply With Quote
  #7  
Old 16th March 2006, 00:49
DanMB DanMB is offline
Junior Member
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry for double post but whats his mean:
Code:
Syntax error on line 205 of /root/ispconfig/httpd/conf/httpd.conf:
Cannot load /root/ispconfig/httpd/libexec/libphp5.so into server: /root/ispconfig/httpd/libexec/libphp5.so: undefined symbol: compress
/root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started
and how do i fix it
Reply With Quote
  #8  
Old 16th March 2006, 12:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Something's wrong with ISPConfig's PHP...
When you installed ISPConfig, did you use the original ISPConfig sources, or did you maybe modify install_ispconfig/compile_aps/compile before?

What's the output of
Code:
uname -m
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 16th March 2006, 22:35
DanMB DanMB is offline
Junior Member
 
Join Date: Mar 2006
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i686 is the output
Also i didnt modify anyhting

Anyone know how to resolve this error?

Last edited by DanMB; 16th March 2006 at 23:04.
Reply With Quote
  #10  
Old 17th March 2006, 12:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Did you encounter anything unusual during the ISPConfig installation? Errors, warnings, ...?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup Fedora Core 3 IMAP administration help needed. dtism HOWTO-Related Questions 1 3rd March 2006 17:54
UebiMiau installation help needed toyito Installation/Configuration 70 1st March 2006 23:43
CentOS 4.2 - Swap Needed or Not? d3m0nic Installation/Configuration 2 1st February 2006 17:52
Debian Hosting & Configuration Help Needed jf1976 Server Operation 6 19th January 2006 07:32
Newbie help needed dathrill General 1 5th November 2005 20:58


All times are GMT +2. The time now is 08:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.