Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th January 2009, 19:46
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default setting smtp server port

I have been attempting to set up ISPConfig to relay email through a smtp server available at our ISP. I have followed the very good http://www.howtoforge.com/postfix_re...her_mailserver. Thank you, Falko.

My ISP tells me that I need to be sending relays to smtpserver.blah.net on port 465. It is my understand, through various articles I have read, that this is accomplished by adding a colon and 465 after the server. Like this >> smtpserver.blah.net:465, then as the howto indicates, followed by a space and the username@blah.net:userpassword.

I am tailing the mail.log and still seeing server connections at port 25 that are timing out. And no mail relay happening (I think.) Should this not be port 465 timing out?

I must admit that I am not sure how to test this, but I have yet to receive a test email sent to myself at a different address.

As I am using dynamic dns services through dyndns, I need to use email relay to send emails.

I am able to receive emails on my ISPConfig server, just cannot send.

Am I setting the port correctly, our is this handled differently in postfix?
Reply With Quote
Sponsored Links
  #2  
Old 26th January 2009, 21:37
merlincc merlincc is offline
Junior Member
 
Join Date: Nov 2006
Posts: 25
Thanks: 0
Thanked 1 Time in 1 Post
Default main.cf and sasl_passwd

Both files need to be changed.

In /etc/postfix/main.cf:

relayhost = [smtpserver.blah.net]:465

In /etc/postfix/sasl_passwd:

[smtpserver.blah.net]:465 username@blah.net:userpassword

Don't forget to do a postmap on sasl_passwd:

postmap /etc/postfix/sasl_passwd

Finally restart postfix:

/etc/init.d/postfix restart

Last edited by merlincc; 26th January 2009 at 21:38. Reason: Added full path for sasl_passwd
Reply With Quote
  #3  
Old 26th January 2009, 23:32
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default Now I am getting this

Thanks, Merlincc. That is getting me closer.

Now, my mail.log file says this: Jan 26 15:15:23 [myemailserverhostname] postfix/smtp[9363]: 1DD9024B19: to=<myself@diferentemailaddr.ess>, relay=smtpserver.blah.net[xxx.xxx.xx.xx]:465, delay=2722, delays=2602/0.02/120/0, dsn=4.4.2, status=deferred (lost connection with smtpserver.blah.net[xxx.xxx.xx.xx] while performing the EHLO handshake)

(Okay, I have changed some hostname and users to protect myself.)

And still no emails receive that I have sent to myself.

But, I have progressed to the "EHLO handshake" which, I think is good?
Reply With Quote
  #4  
Old 27th January 2009, 11:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,655 Times in 4,464 Posts
Default

Is "smtpserver.blah.net" the server that you used for relaying the email?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 27th January 2009, 15:03
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default smtpserver

yes, and I was instructed by ISP to use port 465.
Reply With Quote
  #6  
Old 27th January 2009, 19:27
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default Additional info

I have been looking into Postfix.

Found some tests to run. The command "telnet smtpserver.blah.net" yields an ip address followed by dots (example, Trying xxx.xxx.xxx.xx....) A telnet request to "relay-test.mail-abuse.org" yields the same result "Trying 168.61.4.13..."

These test also suggest to "ping" various ip addresses, however, if I am remembering correctly, the "perfect server" howto I followed sets the server to NOT respond to pings. Maybe?

Maybe I am wrong, but I think that does not look correct? Hum-m-m-m!

Last edited by bobwdn; 27th January 2009 at 19:30.
Reply With Quote
  #7  
Old 27th January 2009, 19:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

You must specify a port in the telnet command, e.g.
Code:
telnet smtpserver.blah.net 465
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 27th January 2009, 21:08
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default telnet to port 465

Okay, now when I "telnet smtpserver.blah.net 465" I get "Connected to smtpserver.blah.net" and a second line that says "Escape character is '^]'."

I still am not receiving email relayed thru smtpserver.blah.net to an outside testing world email address. (i.e. me at a different email address.)
Reply With Quote
  #9  
Old 27th January 2009, 21:54
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
Default Additional info

I have an extra computer here, loaded with Debian. Installed Icedove mail client and set up a fake email user. Set outgoing email server to my "smtpserver.blah.net" on port 465 and sent a test message. The smtpserver.blah.net properly asked for password and on input (of password) sent the email and it was received at my test location.

So, the relay smtp server works and there is no authentication issue regarding the user and password set on smtpserver.blah.net.

Which tells me that the problem should be some setting I have incorrectly entered. I followed the instructions of http://www.howtoforge.com/postfix_re...her_mailserver and have re-checked those settings and all appears to be correct, but . . . . what can it be?
Reply With Quote
  #10  
Old 28th January 2009, 15:10
bobwdn bobwdn is offline
Member
 
Join Date: Dec 2006
Location: Nashville, Tennessee, USA
Posts: 50
Thanks: 7
Thanked 0 Times in 0 Posts
 
Default copy of my main.cf file

Still not working. Here is a copy of my main.cf file:

Code:
root@xxx02:/home/robert# cat /etc/postfix/main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = xxx02.blah.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = xxx02.mydomain.com, localhost.mydomain.com, localhost.localdomain, localhost
relayhost = [smtpserver.blah.net]:465
mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128
mailbox_command = 
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain = 
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
smtp_sasl_auth = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = 
smtp_sasl_auth_enable = yes
After reading various forums regarding Postfix and this problem, most forum posts agreed with merlincc post about using [brackets] around the smtpserver host name. He must also have an AT&T/SBC/Ameritech type account. This may be part of the problem, the unique way that AT&T/SBC/Ameritech "leads the industry" technology. I do not know at this moment.

I am still receiving the following mail.log entries:

Code:
Jan 28 06:55:08 xxx02 postfix/error[14606]: 767B524A7E: to=<bobwdn@mydomain.com>, relay=none, delay=1507, delays=1507/0.02/0/0.03, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with smtpserver.blah.net[xxx.xxx.xxx.18] while performing the EHLO handshake)
And as if this morning I see this:

Code:
Jan 28 07:00:08 xxx02 postfix/smtp[14680]: 19CC824A5D: to=<bobwdn@mydomian.com>, relay=smtpserver.blah.net[xxx.xxx.xxx.18]:465, delay=59408, delays=59408/0.02/0.24/0, dsn=4.4.2, status=deferred (lost connection with smtpserver.blah.net[xxx.xxx.xxx.18] while receiving the initial server greeting
This has been challenging, but I am learning things.

Should I move to a Postfix forum? Ubuntu occasionally has unique ways of doing some things. Is it Ubuntu related?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 15:42
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30
Change smtp server port? MarcoV General 4 18th December 2007 18:57
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 23:53
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47


All times are GMT +2. The time now is 03:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.