Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2009, 00:06
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 264
Thanked 151 Times in 131 Posts
Default External Mailserver option not working for me.

After one week of hell (Botnet attack's on the DC) I'm finally managing to get my servers back on line again.

I needed to move some servers from the troubled DC to an other DC, and I'm amazed how willing some DC'centers are to help you, and this all for free!

Anyway. At the moment I'm seting up some servers in different DC's just incase this botnet attack starts again.
The plan is to run websites in DC1 and e-mail in DC2

For some reason I can not get the External Mailserver option to work!
The MX records are all setup fine, and emailing is working fine EXEPT when using contact options from the website(s)

In ISPconfig I have setup the mailserver to 'External Mailserver', but I keep getting the following message in the mail.log file
Quote:
NOQUEUE: reject; RCPT from localhost[127.0.0.1]: 554 5.1.1 <info@domain.tld>: Recipient address rejected: User unknown in local recipient table; from=<info@domain.tld> to=<info@domain.tld> proto=ESMTP helo=<host.otherdomain.tld>
It's obvious that the user is unknown in the local recipient as it does not exist on that server! (It does exist on the other server that it should go to)
You can also see that it does not even try to connect to the other server.

Doing a 'dig domain.tld MX' on the troubled system does show the correct server IP.

I'm lost at the moment, and hope that someone here migh know how to start debugging this problem?
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2009, 08:48
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,704
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

Please make sure that yiu set the co-domain to external mailserver too and not just the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
edge (1st February 2009)
  #3  
Old 1st February 2009, 10:09
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 264
Thanked 151 Times in 131 Posts
 
Default

I knew that it was something that easy.
Thank you.
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual users... Ubuntu 8.04 spaceuser HOWTO-Related Questions 12 19th June 2008 08:04
External Mailserver Option dont work msource Installation/Configuration 3 30th November 2007 17:55
Not working: Installing Beryl on Feisty Fawn w/ATI Radeon Card thepossiblehuman HOWTO-Related Questions 18 1st October 2007 16:37
So close to getting 3D on my ATI graphics card, please help me finish thirtythree HOWTO-Related Questions 6 27th September 2007 22:04
DRI support for X (KDE) shadowsa Installation/Configuration 2 10th December 2005 18:43


All times are GMT +2. The time now is 22:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.