#1  
Old 23rd January 2009, 09:10
bzzik bzzik is offline
Member
 
Join Date: Aug 2008
Posts: 67
Thanks: 1
Thanked 2 Times in 2 Posts
Unhappy Mail encoding problems

Hi!

I am using ISPConfig 2.2.7 with Perfect install on CentOS 5.2. I have installed standalone Telaen webmail and now faced a problem with encoding in sent mails. The problem is the following:

When I send it and then read it with Talean - encoding is correct. When I send it and read it with another web mail encoding goes wrong. For example here is mail on cyrillics:

Original mail:

Quote:
From: Test
To: test@mydomain.lv
Subject: тест
Date: 01/23/09 09:54

тест
Here is the same email, but forwarded and read with another web mail:

Quote:
--------- Original Message --------
From: Test <test@mydomain.lv>
To: test@mydomain.lv <test@mydomain.lv>
Subject: ‚е�‚
Date: 01/23/09 09:54

>
>
> ‚е�‚
>
>

Last edited by bzzik; 23rd January 2009 at 09:16.
Reply With Quote
Sponsored Links
  #2  
Old 24th January 2009, 12:47
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Are both webmail packages using the same Apache, or is one using ISPConfig's Apache and the other one the main Apache, or is one of the webmail packages even on another server?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 29th January 2009, 11:47
bzzik bzzik is offline
Member
 
Join Date: Aug 2008
Posts: 67
Thanks: 1
Thanked 2 Times in 2 Posts
Default

They are on different servers. Telaen webmail is on my main web server without ISPConfig. ISPConfig with mailserver is on another machine. And I am trying to read sent mails through different web mails such as gmail.

Where to dig?

P.S.
Thanks for helping in this case.

Last edited by bzzik; 29th January 2009 at 11:52.
Reply With Quote
  #4  
Old 30th January 2009, 12:06
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Can you compare the DefaultCharset settings of both Apaches? I guess they differ.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 31st January 2009, 19:31
bzzik bzzik is offline
Member
 
Join Date: Aug 2008
Posts: 67
Thanks: 1
Thanked 2 Times in 2 Posts
 
Default

I thought about it, but both have UTF-8...

Ohmy! I solved this! The problem lies in language files. Mailer takes encoding from language file, so I changed it to UTF-8 and it is ok now

Last edited by bzzik; 31st January 2009 at 19:42.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
procmail can't write Hellbound General 27 8th June 2009 21:51
just the last step...and it works. Postfix...need help config. ubuntusr Installation/Configuration 1 5th January 2009 09:50
Problem with dcc-client installation (Postfix) swap-as Installation/Configuration 9 18th September 2008 20:47
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ebbay Installation/Configuration 9 4th March 2006 11:47


All times are GMT +2. The time now is 06:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.