Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th January 2009, 23:53
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default phpmyadmin and webmail

I now have everything running with ispconfig3 RC1 and all is well, almost.

Let's call my domain for the server "mydomain.com".

I was able to access phpmyadmin via mydomain.com/phpmyadmin and the same for webmail (squirrelmail).

But I now created a site for mydomain.com so if you now try to visit mydomain.com/phpmyadmin I get the 404 because obviously phpmyadmin is not in that directory tree.

Do I have to move phpmyadmin into that directory if I want to access the same way or do I have to create a new site for it?
Reply With Quote
Sponsored Links
  #2  
Old 21st January 2009, 06:12
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

You can create a symlink for phpmyadmin in the side, or you access it by IP address.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st January 2009, 23:15
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default

When I use a symbolic link I get an internal server error when I try to access it.
Reply With Quote
  #4  
Old 22nd January 2009, 10:14
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Please post the exact error message that you get in the error log file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 23rd January 2009, 00:38
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default

I checked the log in /var/log/ispconfing/httpd/mysite

and found errors about the .htaccess file

.htaccess: Options not allowed here

Also, when I restart apache I get this error

Quote:

Forcing reload of web server (apache2)...[Thu Jan 22 18:45:17 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Jan 22 18:45:17 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
waiting [Thu Jan 22 18:45:19 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
[Thu Jan 22 18:45:19 2009] [error] VirtualHost *:80 -- mixing * ports and non-* ports with a NameVirtualHost address is not supported, proceeding with undefined results
.

Last edited by jcombs_31; 23rd January 2009 at 00:45.
Reply With Quote
  #6  
Old 23rd January 2009, 14:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by jcombs_31 View Post
I checked the log in /var/log/ispconfing/httpd/mysite

and found errors about the .htaccess file

.htaccess: Options not allowed here
Add something like
Code:
<Directory /path/to/documentroot>
  AllowOverride All
</Directory>
to the Apache Directives field in ISPConfig.

Quote:
Originally Posted by jcombs_31 View Post
Also, when I restart apache I get this error
This has been fixed in SVN already.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 23rd January 2009, 18:16
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default

Quote:
Originally Posted by falko View Post
Add something like
Code:
<Directory /path/to/documentroot>
  AllowOverride All
</Directory>
to the Apache Directives field in ISPConfig.

This has been fixed in SVN already.
Thanks for the AllowOverride, that fixed the phpmyadmin problems. I updated my trunk from svn and ran the update but I still get the apache error if I restart the service.
Reply With Quote
  #8  
Old 24th January 2009, 10:01
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Which Linux distribution do you use?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 24th January 2009, 16:47
jcombs_31 jcombs_31 is offline
Member
 
Join Date: Jan 2009
Location: South Florida
Posts: 83
Thanks: 2
Thanked 2 Times in 1 Post
Default

Debian Etch
Reply With Quote
  #10  
Old 25th January 2009, 19:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
 
Default

I think you have to update your sites in ISPConfig so that the vhost configuration gets rewritten.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
change webmail address, not on port 81 hanswid Installation/Configuration 3 26th September 2008 12:31
Roundcube webmail user password Mazak Installation/Configuration 5 17th April 2008 20:44
Avoid https://name.tld:81 for phpmyadmin and roundcubemail wuptydu Installation/Configuration 12 4th April 2008 18:50
ISPConfig phpMyAdmin ferradeira Installation/Configuration 10 10th November 2006 20:54
Modify PHPmyAdmin auth method Tribal-Dolphin Feature Requests 10 8th February 2006 01:27


All times are GMT +2. The time now is 18:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.