Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th January 2009, 15:21
jaytango jaytango is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Install fails - Could not unpack ISPconfig - and many other errors

Running CentOS 4.7 with PHP 4.3.9 (according to phpinfo() BUT according to #php -v it's PHP 5.2.8).
I gave it my best shot but I finally give up. It seems others have had almost identical problems as me but they either never posted their solutions or just gave up and left. Anyway, here's the deal... tried to install, all seems fine then midway I get :

In function `zif_mysql_set_charset':
/tmp/install_ispconfig/compile_aps/php-5.2.8/ext/mysql/php_mysql.c:1120: undefined reference to `mysql_set_character_set'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1
ERROR: Could not make PHP
cd: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
mv: cannot stat `binaries/aps.tar.gz': No such file or directory
mv: cannot stat `binaries/spamassassin.tar.gz': No such file or directory
mv: cannot stat `binaries/uudeview.tar.gz': No such file or directory
mv: cannot stat `binaries/clamav.tar.gz': No such file or directory
mv: cannot stat `binaries/cronolog': No such file or directory
mv: cannot stat `binaries/cronosplit': No such file or directory
mv: cannot stat `binaries/ispconfig_tcpserver': No such file or directory
mv: cannot stat `binaries/zip': No such file or directory
mv: cannot stat `binaries/unzip': No such file or directory
... and some more

The installation continues, I enter all my MySQL stuff and it works just fine then i get:


Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 2

./setup2: line 1090: mysql_config: No such file or directory
./setup2: line 1091: httpd: No such file or directory
./setup2: line 1092: httpd2: No such file or directory
./setup2: line 1093: httpd2: No such file or directory
./setup2: line 1103: ip_addresses: No such file or directory
./setup2: line 1105: /root/ispconfig/php/php: No such file or directory
./setup2: line 1106: /root/ispconfig/dist.info: No such file or directory
chmod: cannot access `/home/admispconfig/ispconfig/tools/suphp/usr/bin/php-wrapper': No such file or directory
./setup2: line 1119: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
./setup2: line 1120: /home/admispconfig/ispconfig/sysconf.txt: No such file or directory
Restarting some services...
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Shutting down proftpd: [ OK ]
shell-init: error retrieving current directory: getcwd: cannot access parent directories: No such file or directory
Starting proftpd: [ OK ]
./setup2: line 1163: /etc/rc.d/init.d/ispconfig_server: No such file or directory
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Please direct your browser to

http://www.(myserver.com):81

and log in:
Username: admin
Password: admin

./setup2: line 1189: cd: /tmp/install_ispconfig/compile_aps/../..: No such file or directory


www.(myserver.com) works just fine, I get the Apache default page but www.(myserver.com):81 doesn't work.

Here's my netstat -tap output:

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 31791/mysqld
tcp 0 0 *:3500 *:* LISTEN 3147/stunnel
tcp 0 0 *:ftp *:* LISTEN 29128/proftpd: (acc
tcp 0 0 unknown.hosting.:domain *:* LISTEN 2875/named
tcp 0 0 cust.car:domain *:* LISTEN 2875/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 2875/named
tcp 0 0 *ostgres *:* LISTEN 3296/postmaster
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 2875/named
tcp 0 0 *:imaps *:* LISTEN 3083/couriertcpd
tcp 0 0 *op3s *:* LISTEN 3071/couriertcpd
tcp 0 0 *:1029 *:* LISTEN 3157/sshd
tcp 0 0 *:submission *:* LISTEN 3058/couriertcpd
tcp 0 0 *op3 *:* LISTEN 3066/couriertcpd
tcp 0 0 *:imap *:* LISTEN 3077/couriertcpd
tcp 0 0 *:http *:* LISTEN 1928/httpd
tcp 0 0 *ostgres *:* LISTEN 3296/postmaster
tcp 0 0 *:smtp *:* LISTEN 3049/couriertcpd
tcp 0 0 *:26 *:* LISTEN 3049/couriertcpd
tcp 0 2832 cust.caroh:1029 orl.fdn.:62084 ESTABLISHED 1147/0


here's my iptables -L output:

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination


Any help at all would be much appreciated. Thank you, thank you, thank you!
Reply With Quote
Sponsored Links
  #2  
Old 16th January 2009, 22:09
jaytango jaytango is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Update:

Well, I finally got ISPconfig to finish successfully and now it loads on www.myserver.com:81. But I'm not gonna jumpfor joy just yet because I had to cheat my way through the install and I'm not sure if that's gonna affect anything. Here's what I did:

Since the first big error I saw was:

In function `zif_mysql_set_charset':
/tmp/install_ispconfig/compile_aps/php-5.2.8/ext/mysql/php_mysql.c:1120: undefined reference to `mysql_set_character_set'
collect2: ld returned 1 exit status
make: *** [sapi/cli/php] Error 1
ERROR: Could not make PHP

...I manually unpackaged the php tar and then I looked in /tmp/install_ispconfig/compile_aps/php-5.2.8/ext/mysql/php_mysql.c and comented out the whole "if" statement that checks for that mysql resource. The "if" statement didn't really execute anything except for returning a true or false.

I also had to comment out the PHP unpackage command in ./setup since I manually unpackaged it.

If you don't hear from me again then it probably ended up okay.
Reply With Quote
  #3  
Old 17th January 2009, 12:55
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Did you install your sever exactly as described in the perfect server guide for centos 4.x?

http://www.howtoforge.com/centos-4.6...-ftp-ispconfig
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 17th January 2009, 20:07
jaytango jaytango is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Unfortunately There wasn't a listing for CentOS 4.7 and I didn't want to risk using the instructions for another version. In any case, the cheat I mentioned above seemed to work. I have two vhosts running now, I've set up users' email accounts and ftp accounts so I think I might be okay. I guess I'll never find out why exactly that 'mysql_set_character_set' check in php_mysql.c kept killing the install with an error. Especially since mysql always works in the install when it asks me to enter the mysql server, user and password. Puzzling...
Reply With Quote
  #5  
Old 18th January 2009, 13:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by jaytango View Post
Unfortunately There wasn't a listing for CentOS 4.7
There is: http://www.howtoforge.com/perfect-server-centos-4.7
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 18th January 2009, 19:01
jaytango jaytango is offline
Junior Member
 
Join Date: Jan 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Oh cool, thanks Falko. There wasn't a 4.7 link at http://www.ispconfig.org/manual_installation.htm. I'll save this documentation for my next install.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 04:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.