Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th January 2009, 05:42
tyliong tyliong is offline
Member
 
Join Date: Jan 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default How to alllow an email address to send email but not recieve emal

Hi,

I am creating an autentication system, i want to turn one of my accounts into a sender account. but stop all external emails from being recieved by it.
Reply With Quote
Sponsored Links
  #2  
Old 9th January 2009, 12:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You could create a new alias in /etc/aliases:
Code:
username: /dev/null
(Replace username with the username of the account.)
Run
Code:
newaliases
afterwards and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 9th January 2009, 12:46
tyliong tyliong is offline
Member
 
Join Date: Jan 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

is the username with the @mydomain.com??
cause i have tried both with out the @ and with and i can still sendmail to the account.

I tried what u said but i got this instead
mydomain_mailer@mydomain.com... cannot alias non-local names
Reply With Quote
  #4  
Old 10th January 2009, 12:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

It's the system user name of that account (works unless you have a virtual user setup).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 10th January 2009, 12:49
tyliong tyliong is offline
Member
 
Join Date: Jan 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is there any work around for a virtual account?
Reply With Quote
  #6  
Old 11th January 2009, 14:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

You could forward the mail to a system user and then send that mail to /dev/null using the aliases file.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 11th January 2009, 15:49
tyliong tyliong is offline
Member
 
Join Date: Jan 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

but that means mail is still recieved by the virtual email client right?

How do i set up a local account to accept or send mail?
Can i access this local account through pop3 and smtp?
Reply With Quote
  #8  
Old 12th January 2009, 14:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by tyliong View Post
How do i set up a local account to accept or send mail?
Take a look here: http://www.howtoforge.com/forums/showthread.php?t=2
Quote:
Originally Posted by tyliong View Post
Can i access this local account through pop3 and smtp?
Yes.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 15th January 2009, 02:17
tyliong tyliong is offline
Member
 
Join Date: Jan 2009
Posts: 34
Thanks: 0
Thanked 0 Times in 0 Posts
Default

postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='
/etc/init.d/postfix restart

if i do these commands will all my virtual users be disabled? and only local accounts will recieve email?

do i need to modify any of the values here or i just literally take all the values u stated?
Reply With Quote
  #10  
Old 15th January 2009, 14:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

If you're currently using Maildir, you can use these settings. If you're using mbox, you shouldn't use them.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
Can send email but not recieve from a second domain-- first domain works perfect grandpagenocide General 3 31st July 2007 09:10
Can Send Email, But Not Recieve mfdp10 Installation/Configuration 15 4th June 2007 09:18


All times are GMT +2. The time now is 19:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.