Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 1st January 2009, 07:30
sierradump sierradump is offline
Junior Member
 
Join Date: May 2007
Posts: 28
Thanks: 1
Thanked 0 Times in 0 Posts
Default Trouble w/ SIMPLEINVOICES web-based application for ISPCONFIG webs. (htaccess???)

I have a client that wants to run SimpleInvoices web-based invoicing application on his website. The program is simple to install... extract the .zip contents to a folder in the users "web" directory (i.e. web/simpleinvoices), edit the config.php file to point to the users database and ADD THE UN:PW for htaccess -- I assume this is the UN:PW from the users .htpasswd file (i.e. var/www/web8/.htpasswd)?. The application is then accessible via http://www.domain.com/simpleinvoices/ .

My problem is the application has a feature of exporting invoices to .pdf. Everything works EXCEPT when it outputs the .pdf for download, the .pdf is BLANK.

here is there errors from the web users log file (i.e. /var/www/web8/log/error.log); NOTE: users ip address and domain name have been edited.

Quote:
[Wed Dec 31 22:19:37 2008] [error] [client xxx.xxx.xxx.xxx] Fetching: http://web8_admin:{A5LV9G5tDQ/E@(users.domainname.com)/simpleinvoices/index.php?module=invoices&view=templates/template&invoice=8&action=view&location=pdf, referer: http://(users.domainname.com)/simple...es&view=manage
[Wed Dec 31 22:19:37 2008] [error] [client xxx.xxx.xxx.xxx] The URL 'http://web8_admin:{A5LV9G5tDQ/E@(users.domainname.com)/simpleinvoices/index.php?module=invoices&view=templates/template&invoice=8&action=view&location=pdf' could not be parsed, referer: http://(users.domainname.com)/simple...es&view=manage
[Wed Dec 31 22:19:37 2008] [error] [client xxx.xxx.xxx.xxx] Processing of 'http://web8_admin:{A5LV9G5tDQ/E@(users.domainname.com)/simpleinvoices/index.php?module=invoices&view=templates/template&invoice=8&action=view&location=pdf' completed in 0 seconds, referer: http://(users.domainname.com)/simple...es&view=manage
I am not sure what that means exactly??? It looks as though the application is unable to connect to that url using the "http://htusername:htpassword@domainname.com"

If I type the URL in WITHOUT the htusername:htpassword@domain.com like this: http://users.domain.com/simpleinvoic...w&location=pdf I get the proper output...

Thanks for any help!

Last edited by sierradump; 1st January 2009 at 07:39.
Sponsored Links
  #2  
Old 2nd January 2009, 06:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,717
Thanks: 820
Thanked 5,322 Times in 4,175 Posts
 
Default

Duplicate thread:

http://www.howtoforge.com/forums/showthread.php?t=29918
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Problems with Wordpress based web page after installing Ispconfig Mole Installation/Configuration 50 9th May 2008 10:07
get thousands of "Mailsize" mails from own server torusturtle Installation/Configuration 20 24th December 2006 14:51
ispconfig and mambo shajazzi Installation/Configuration 70 28th March 2006 19:29


All times are GMT +2. The time now is 19:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.