Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th March 2006, 02:06
bbking bbking is offline
Junior Member
 
Join Date: Mar 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Question The Perfect Setup - Debian Sarge (3.1) problems

hi!

first of all, let me thank for this howto!

second, I'd like to make some comments, regarding the installation with help of this howto.

Code:
apt-get install wget bzip2 rdate fetchmail libdb3++-dev unzip zip ncftp xlispstat libarchive-zip-perl zlib1g-dev libpopt-dev nmap openssl lynx fileutils
my first trouble started here...it states, that it cannot find libdb3++-dev and xlispstat....I just recently discovered, that there are 14(!!) sarge install cd images available and I only downloaded 4....now how could I add the rest of them as installation sources (I already downloaded the missing images....)?

then, when I issue the command
Code:
apt-get install postfix postfix-tls libsasl2 sasl2-bin libsasl2-modules ipopd-ssl uw-imapd-ssl
I get this:
Quote:
Die folgenden Pakete haben nichterfllte Abh�gigkeiten:
exim4-base: H�gt ab: exim4-config (>= 4.30) soll aber nicht installiert werden oder
exim4-config-2
E: Kaputte Pakete
which means the dependencies could not be solves, and exim4-base depends on exim4-config, but it should not be installed, or exim4-config-2 and E: damaged packages (?).

so this is the place, where I am stuck, as I don't have a clue how to solve this. I am new to Debian, but have been using SuSE for ages....

as far, as I have figured it out, I need mysql (but it depends on exim4) and postgres (which again "forbids" the installation of exim4)....

can somebody give me a hint how to go on from here?

thanks in advance,
bbking
Reply With Quote
Sponsored Links
  #2  
Old 9th March 2006, 08:46
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,594
Thanks: 792
Thanked 4,984 Times in 3,904 Posts
Default

Your problem is that you have not chosen the network installation of the pacakes as suggested in the howto on this page:

http://www.howtoforge.com/perfect_setup_debian_sarge_p2

So not all packages where available.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 9th March 2006, 09:25
bbking bbking is offline
Junior Member
 
Join Date: Mar 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh, well, my fault...

can I change this somehow (e.g. editing the /etc/apt-sources file)? btw, while installation, the system did access the net, at least security.debian.org was contacted for each package.....

thanks & have a nice day,
bbking
Reply With Quote
  #4  
Old 9th March 2006, 09:42
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Put this into /etc/apt/sources.list:

Code:
deb http://ftp2.de.debian.org/debian/ stable main
deb-src http://ftp2.de.debian.org/debian/ stable main

deb http://security.debian.org/ stable/updates main
and run
Code:
apt-get update
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th March 2006, 11:19
bbking bbking is offline
Junior Member
 
Join Date: Mar 2006
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

thanks a lot!

with inserting these extra sources, my exim4 problems disappeared, too! I finished the installation without problems....

one quick question: when I set

postconf -e 'smtpd_tls_auth_only = no'

to yes, then only secure authentication will work, right? no plain passwords are allowed, whereas setting it to "no", plain passwords will work?

I'm not sure about this, but I'd like to only have secure passwords....

thanks for the HOWTO one more time!
Reply With Quote
  #6  
Old 9th March 2006, 21:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by bbking
one quick question: when I set

postconf -e 'smtpd_tls_auth_only = no'

to yes, then only secure authentication will work, right? no plain passwords are allowed, whereas setting it to "no", plain passwords will work?

I'm not sure about this, but I'd like to only have secure passwords....

thanks for the HOWTO one more time!
Plain text passwords will still work; TLS means that the connection is encrypted. It's like HTTPS for web sites.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 20th January 2008, 02:36
peacengell peacengell is offline
Member
 
Join Date: Jan 2008
Posts: 37
Thanks: 10
Thanked 2 Times in 2 Posts
Default hi same problem on debian

Reading package lists... Done
Building dependency tree... Done
Package libdb3++-dev is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package libdb3++-dev has no installation candidate
server:~#
i did add and make apt-get update
and apt-get upgrade all seem woks fine but when i try to install lidbb3++-dev
and xlispstat
same error i have install vmware on vista and debian inside
i can brouse internet from command (shell) usind lynx
but i can't get these two software install help please i wanna learn how to install
and configure a debian server mainly linux server so i didn't install xwindows so help me please thanks
alot newbeeeeeeeeeeeee
Reply With Quote
  #8  
Old 20th January 2008, 03:15
peacengell peacengell is offline
Member
 
Join Date: Jan 2008
Posts: 37
Thanks: 10
Thanked 2 Times in 2 Posts
Default

Get:1 http://security.debian.org stable/updates Release.gpg [189B]
Get:2 http://ftp2.de.debian.org stable Release.gpg [378B]
Hit http://security.debian.org stable/updates Release
Hit http://ftp2.de.debian.org stable Release
Ign http://security.debian.org stable/updates/main Packages/DiffIndex
Ign http://ftp2.de.debian.org stable/main Packages/DiffIndex
Hit http://security.debian.org stable/updates/main Packages
Ign http://ftp2.de.debian.org stable/main Sources/DiffIndex
Hit http://ftp2.de.debian.org stable/main Packages
Hit http://ftp2.de.debian.org stable/main Sources
Fetched 379B in 2s (139B/s)
Reading package lists... Done
server:~#
and also i get these when i make apt-get update
and here is my /etc/apt/sources.list file cat
server:/# cat /etc/apt/sources.list
deb http://ftp2.de.debian.org/debian/ stable main
deb-src http://ftp2.de.debian.org/debian/ stable main
deb http://security.debian.org/ stable/updates main
server:/#
and my /etc/resolv.conf
server:/# cat /etc/resolv.conf
nameserver 192.168.2.1
nameserver 62.231.32.10
nameserver 62.231.32.11
server:/#

why i get this problem
help me please i'm stuck here thanks you very much
thanks

Last edited by peacengell; 20th January 2008 at 03:18.
Reply With Quote
  #9  
Old 20th January 2008, 19:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Are you using Etch or Sarge? If you use Sarge, please replace stable with sarge in /etc/apt/sources.list and run
Code:
apt-get update
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
peacengell (20th January 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
The Perfect Setup - Debian Sarge (3.1) Issues krazy1 HOWTO-Related Questions 10 9th May 2006 17:02
Debian Sarge, ISPConfig, perfect setup followed, email can't login! Zoon Installation/Configuration 3 12th February 2006 20:58
Problem on Debian Sarge Perfect Setup daniel_rodriguez HOWTO-Related Questions 4 12th January 2006 14:10
Debian Sarge Perfect Setup Rocky Installation/Configuration 2 4th November 2005 16:32
Perfect setup (debian sarge) Pelle Installation/Configuration 4 11th October 2005 17:17


All times are GMT +2. The time now is 17:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.