Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th December 2008, 01:53
michaelbc michaelbc is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Not able to login to ispconfig panel

Hi,
I am running ISPConfig 2.2.29 on Fedora 9
Everything is working great sites, mail, ftp.
This is what I did that caused the login problem.
I checked the "maildir" box on the general tab in the panel but didn't check it on any of the sites.
Now when I go to https://cns1.myserver.com:81 I get the logon screen, I put in admin and pass and it seems to just reload the login panel, I get no errors for wrong pass or password it just doesn't load into the application.
My hope is that you could tell me what line instruction I can alter to uncheck that panel and get me back in.
Thank you

Last edited by michaelbc; 29th December 2008 at 04:03.
Reply With Quote
Sponsored Links
  #2  
Old 29th December 2008, 09:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

The maildir checkbox is not related to the ispconfig login, so that could not have caused the problem. Did you change anything else outside of ispconfig like the mysql root password?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th December 2008, 01:20
michaelbc michaelbc is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
The maildir checkbox is not related to the ispconfig login, so that could not have caused the problem. Did you change anything else outside of ispconfig like the mysql root password?
Thank you Till,

Password is still the same and I have actually checked all that, all logins even for sites do not work either.
This is the other thing I did, "now that I think about it".

{{{ "(COPY AND PASTED FROM "HOW TO FORGE") After you have installed ISPConfig, you must modify the template file for /etc/proftpd_ispconfig.conf which is called /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master, because otherwise the users that you create with ISPConfig won't be able to log in using FTP. Instead of modifying /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master (which gets overwritten each time you update ISPConfig) we copy /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master to /root/ispconfig/isp/conf/customized_templates/ and modify that one. If ISPConfig finds a template in /root/ispconfig/isp/conf/customized_templates/, it will use that one instead of the default template in /root/ispconfig/isp/conf/. Templates in /root/ispconfig/isp/conf/customized_templates/ don't get overwritten when you update ISPConfig.

cp /root/ispconfig/isp/conf/proftpd_ispconfig.conf.master /root/ispconfig/isp/conf/customized_templates/

Now open /root/ispconfig/isp/conf/customized_templates/proftpd_ispconfig.conf.master and comment out the DefaultAddress 127.0.0.1 line:

vi /root/ispconfig/isp/conf/customized_templates/proftpd_ispconfig.conf.master"}}}

I did the copy and commented out the Local?

I did this after adding my sites though?

Thank you

Last edited by michaelbc; 30th December 2008 at 05:22.
Reply With Quote
  #4  
Old 30th December 2008, 09:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Changing this template should not be nescesary normally. When you remove it, webftp will fail. You should remove the customized template.

To the ispconfig login problem: Please post the output of:

netstat -tap
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 31st December 2008, 03:11
michaelbc michaelbc is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

[root@cns1 ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:33509 *:* LISTEN 2165/rpc.statd
tcp 0 0 *:mysql *:* LISTEN 2606/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 2147/rpcbind
tcp 0 0 *:81 *:* LISTEN 2868/ispconfig_http
tcp 0 0 cns1.mydomain.ca:domain *:* LISTEN 3172/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 3172/named
tcp 0 0 *:ssh *:* LISTEN 2506/sshd
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2749/cupsd
tcp 0 0 *:smtp *:* LISTEN 5888/master
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 3172/named
tcp 0 740 cns1.mydomain.ca:ssh d10-18-16-194.b:responsenet ESTABLISHED 19359/0
tcp 0 0 *:imaps *:* LISTEN 2628/dovecot
tcp 0 0 *op3s *:* LISTEN 2628/dovecot
tcp 0 0 *op3 *:* LISTEN 2628/dovecot
tcp 0 0 *:imap *:* LISTEN 2628/dovecot
tcp 0 0 *:sunrpc *:* LISTEN 2147/rpcbind
tcp 0 0 *:http *:* LISTEN 3073/httpd
tcp 0 0 *:ftp *:* LISTEN 5790/proftpd: (acce
tcp 0 0 *:ssh *:* LISTEN 2506/sshd
tcp 0 0 *:smtp *:* LISTEN 5888/master
tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 3172/named
tcp 0 0 *:https *:* LISTEN 3073/httpd
[root@cns1 ~]#
Reply With Quote
  #6  
Old 31st December 2008, 14:05
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
Default

Thats ok so far.

Please try to login to mysql with the command:

mysql -h localhost -u root -p

and then enter the mysql root password when requested.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 1st January 2009, 06:38
michaelbc michaelbc is offline
Junior Member
 
Join Date: Dec 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

login as: root
root@000.000.000.000's password:
Last login: Tue Dec 30 16:44:51 2008 from 000.000.000.000
[root@cns1 ~]# mysql -h localhost -u root -p
Enter password:
Welcome to the MySQL monitor. Commands end with ; or \g.
Your MySQL connection id is 85
Server version: 5.0.51a Source distribution

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>

Thank you Till
my login seems to work fine for MySQL
I said in my firstpost that ftp work's ok but thats not entirely true, ftp is working but I am not able to log on with user and pass only anonamous.
I get a 530 user incorrect, I was on these sites prior to this problem uploading via ftp so I know they did work?

Should I just reinstall ISPConfig at this point, I'm pretty fast at it by this point, Lol. A yum update wouldn't have been a cause would it?
I appologize for the obvious Nubi Linux Questions
I always use vi for editing and can not recall any editing except the work done, during install, this was a 3 day old install. From what I remember I only used the panel for any changes?.
I appreciate the help and unless you think further post may benefit others I don't mind reloading.
Let me know what log if any may tell me why login seems to just kick me back to login without any error?

Thank you
Reply With Quote
  #8  
Old 1st January 2009, 12:27
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,022
Thanks: 840
Thanked 5,653 Times in 4,462 Posts
 
Default

Quote:
A yum update wouldn't have been a cause would it?
A yum update can cause this, if yum overrides or destrois some existing configuration, but normally yum does not harm anything except the bind configuration. The easiest solution might be a reinstall.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 17:59
ISPConfig 3.0.0.4 Beta Released till General 54 4th March 2009 10:55
MyDNS And The MyDNSConfig Control Panel and ISPConfig pg001 General 2 29th July 2008 03:31
Discrepance between ISPConfig panel and database claudioimai Installation/Configuration 1 12th September 2007 18:13
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 16:16


All times are GMT +2. The time now is 19:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.