#1  
Old 21st November 2008, 23:31
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 5 Times in 4 Posts
Default need to reconfigure the locales

Hi all,

I am trying setting up an site with Gallery2 in it, in the Dutch language.
I have my server installed the perfect way Ubuntu 8.04 (Uk).

If I read it correctly on the gallery2 site faq
Quote:
G2 depends on the system it runs on to switch to other languages than English. G2 needs php with gettext support and each language you want to switch to in G2 needs to be installed on your system. If you have command line access (ssh / telnet) to the (unix, linux) server, you can query for supported languages by `locale -a`. If only "C/POSIX" is returned, no other languages are supported and you need to reconfigure the locales and then restart apache.
I must set up gettext somehow in php. I have searched my php.ini but can't find anything to enable gettext. I have also found a thread here that says it can't be installed in ISPConfig
http://www.howtoforge.com/forums/sho...43&postcount=4

Must I realy install all again in the Dutch language so start from scratch again? I hope not.

TIA

Hope the post is in the right section btw
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
Sponsored Links
  #2  
Old 22nd November 2008, 14:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

What's the output of
Code:
locale -a
?

Quote:
I must set up gettext somehow in php. I have searched my php.ini but can't find anything to enable gettext. I have also found a thread here that says it can't be installed in ISPConfig
http://www.howtoforge.com/forums/sho...43&postcount=4
This refers to the PHP that comes with ISPConfig, but not your main PHP installation. gettext is probably already enabled.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 22nd November 2008, 18:04
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 5 Times in 4 Posts
Default

The output is only the Uk and Us language I have done that already as mentioned in the Gallery thread. I guess this is normal because I installed an Uk Ubuntu version. So my simple thought is to put also the nl_NL? language somewhere in there, but I don't know how.
apt-get???

Code:
root@server1:~# locale -a
C
en_GB.utf8
en_US.utf8
POSIX
root@server1:~#
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #4  
Old 22nd November 2008, 18:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

try:

dpkg-reconfigure locales
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 22nd November 2008, 18:17
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by till View Post
try:

dpkg-reconfigure locales
Code:
root@server1:~# dpkg-reconfigure locales
Generating locales...
  en_GB.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
Generation complete.
root@server1:~#
Output is that all is up to date. Of course just installed everything. But still no nl_NL.
I think if I install the dutch language somehow everything is working fine. Or is the gettext not enabled????
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #6  
Old 22nd November 2008, 18:45
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 5 Times in 4 Posts
Default

Think I find my own answer I did this

Code:
apt-get install language-pack-nl language-support-nl
Than this

Code:
dpkg-reconfigure locales
Output

Code:
root@server1:~# dpkg-reconfigure locales
Generating locales...
  en_GB.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  nl_BE.UTF-8... up-to-date
  nl_NL.UTF-8... up-to-date
Generation complete.
root@server1:~#
AHA the Dutch are arrived!!

Going to check my Galley2 now.

Thanks and will let you guys know of this was right..

That did the trick for me all is working fine.
__________________
Updating my server to Debian Squeeze, so here I go again...

Last edited by DaRKNeSS666NL; 1st January 2009 at 12:17.
Reply With Quote
The Following User Says Thank You to DaRKNeSS666NL For This Useful Post:
falko (23rd November 2008)
  #7  
Old 30th December 2008, 23:39
raymonvdm raymonvdm is offline
Junior Member
 
Join Date: Nov 2008
Posts: 26
Thanks: 0
Thanked 3 Times in 3 Posts
Default

This did NOT solve my squirrelmail problem. (only english is working)
Reply With Quote
  #8  
Old 1st January 2009, 12:20
DaRKNeSS666NL DaRKNeSS666NL is offline
HowtoForge Supporter
 
Join Date: Nov 2006
Posts: 207
Thanks: 17
Thanked 5 Times in 4 Posts
Default

Okee will try to help you but I am petty new to this my self so if I can't forgive me.

What's the output of
Code:
locale -a
?
__________________
Updating my server to Debian Squeeze, so here I go again...
Reply With Quote
  #9  
Old 1st January 2009, 23:09
raymonvdm raymonvdm is offline
Junior Member
 
Join Date: Nov 2008
Posts: 26
Thanks: 0
Thanked 3 Times in 3 Posts
 
Default

I have found a solution

http://ubuntuforums.org/showthread.php?t=208145


vim /var/lib/locales/supported.d/local

nl_NL.ISO-8859-1 ISO-8859-1 <-- add these rule
en_US.UTF-8 UTF-8


dpkg-reconfigure locales

And now dutch is working. I need to do this for other languages
Reply With Quote
The Following User Says Thank You to raymonvdm For This Useful Post:
falko (2nd January 2009)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
reconfigure screen resolution, debian or ubuntu bdpf Installation/Configuration 1 14th July 2008 13:56
Postfix - can't send/recieve mails to/from outside world grosas Installation/Configuration 25 24th November 2007 19:25
Help Question before I reconfigure my Server jka/v Installation/Configuration 3 2nd November 2006 09:03
reconfigure xserver cwall64 Installation/Configuration 1 30th July 2006 16:37


All times are GMT +2. The time now is 14:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.